实验环境OSPF协议_环境配置

配置命令

配置loopback地址及各个接口ip地址

(iou2,3,4命令相似)

IOU1(config)#interface loopback 0

IOU1(config-if)#ip address 1.1.1.1 255.255.255.255

IOU1(config-if)#ex

IOU1(config)#interface ethernet 0/0

IOU1(config-if)#ip address 10.0.12.1 255.255.255.0

IOU1(config-if)#no shutdown  

IOU1(config-if)#ex

IOU1(config)#interface ethernet 0/1

IOU1(config-if)#ip address 10.0.13.1 255.255.255.0

IOU1(config-if)#no shutdown


配置ospf协议

(iou2,3,4命令相似)

IOU1(config)#router ospf 1

IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 0

IOU1(config-router)#network 10.0.12.0 0.0.0.255 area 0

IOU1(config-router)#network 10.0.13.1 0.0.0.0 area 0

测试

使用show ip interface brief查看接口ip

OSPF协议_ip地址_02

使用show ip ospf neighbor查看DR和BDR

OSPF协议_ip地址_03

使用show ip ospf database查看

OSPF协议_ip地址_04

使用ping命令查看全网互通

OSPF协议_环境配置_05