1、实验目的


通过本实验可以掌握:

ACL 的工作方式和工作过程

定义编号和命名标准 ACL 的方法

接口和 VTY 下应用标准 ACL 的方法


2、实验拓扑


配置 ACL 实验拓扑如下图所示。本实验中,通过配置标准 ACL 实现拒绝 PC2 所在网段访问 Ser01,同时只允许主机 PC1 访问路由器 IOU1、IOU2 和 IOU3 的 Telnet 服务,实现对路由器进行远程管理。整个网络配置 OSPF 路由协议保证 IP 的连通性。


3.实验拓扑图


ACL实验_4s


IP地址规划

IOU1

e0/0:172.16.1.254/24

e0/1:172.16.2.254/24

s2/0:172.16.12.1/24

IOU4

s2/0:172.16.12.2/24

s2/1:172.16.23.1/24

IOU5

s2/0:172.16.23.2/24

e0/0:172.16.3.254/24

PC1(IOU2)

IP:192.168.1.100/24

GW:192.168.1.254

PC2(IOU3)

IP:192.168.2.100/24

GW:192.168.2.254

Ser01(IOU6)

IP:192.168.3.100/24

GW:192.168.3.254


代码与注释

(部分内容参见上篇博客,默认初始进入特权模式)

PC1:

config terminal

配置端口:

interface ethernet 0/0

ip address 172.16.1.100 255.255.255.0

no shutdown

exit

配置静态路由:

ip route 0.0.0.0 0.0.0.0 172.16.1.254


PC2:

config terminal

配置端口:

interface ethernet 0/0

ip address 172.16.2.100 255.255.255.0

no shutdown

exit

配置静态路由:

ip route 0.0.0.0 0.0.0.0 172.16.2.254


SER01:

config terminal

配置端口:

interface e0/0

ip address 172.16.3.100 255.255.255.0

no shutdown

exit

配置静态路由:

ip route 0.0.0.0 0.0.0.0 172.16.3.254

配置远程登录:

username admin privilege 15 password cisico  //配置登录名和密码

line vty 0 4  //配置远程登录端口

login local  //配置本地登录

transport input telnet  //配置远程登录方式(输入telnet)

exit


IOU1:

config terminal

配置端口:

interface e0/0

ip address 172.16.1.254 255.255.255.0

no shutdown

interface e0/1

ip address 172.16.2.254 255.255.255.0

no shutdown

interface s2/0

ip address 172.16.12.1 255.255.255.0

no shutdown

exit

配置动态路由RIP:

router rip  //配置路由RIP

version 2  //版本2

no auto-summary  //关闭自动汇总

network 172.16.0.0   //配置直连网段


IOU4:

config terminal

配置端口:

interface s2/0

ip address 172.16.12.2 255.255.255.0

no shutdown

interface s2/1

ip address 172.16.23.1 255.255.255.0

no shutdown

exit

配置动态路由RIP:

router rip

version 2

no auto-summary

network 172.16.0.0

exit


IOU5:

config terminal

配置端口:

interface s2/0

ip address 172.16.23.2 255.255.255.0

no shutdown

interface e0/0

ip address 172.16.3.254 255.255.255.0

no shutdown

exit

配置动态路由RIP:

router rip

version 2

no auto-summary

network 172.16.0.0

exit

配置远程登录:

username admin privilege 15 password cisico

line vty 0 4

login local

transport input telnet

exit

查看路由表:

exit

show  ip route

ACL实验_静态路由_02

配置ACL:

access-list 1 permit 172.16.1.0 0.0.0.255   //配置标准ACL

line vty 0 4

access-class 1 in   //端口应用ACL

exit

access-list 100 permit icmp 172.16.2.0 0.0.0.255 host 172.16.3.100   //配置扩展ACL

access-list 100 permit tcp 172.16.2.0 0.0.0.255 host 172.16.3.100 eq telnet

access-list 100 permit tcp 172.16.1.0 0.0.0.255 host 172.16.3.100 eq telnet

interface e0/0

ip access-group 100 out

exit


测试:

PC1测试:

ping 172.16.3.100

telnet 172.16.3.254

ACL实验_4s_03


PC2测试:

ping 172.16.3.100

telnet 172.16.3.254

ACL实验_静态路由_04


结果符合配置预期,配置完成

(如有疏漏,还望读者指出)