拓扑图思科防火墙ASA配置NAT_静态路由

1.IOU1的配置

IOU1(config)#interface ethernet 0/0
IOU1(config-if)#duplex full
IOU1(config-if)#ip address 200.1.1.2 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface loopback 0
IOU1(config-if)#ip address 218.85.152.99 255.255.255.255
IOU1(config-if)#no shutdown
IOU1(config-if)#exit

使用 show ip interface brief 查看路由接口

思科防火墙ASA配置NAT_ide_02

2.IOU2的配置

IOU2(config)#interface ethernet 0/0
IOU2(config-if)#duplex full
IOU2(config-if)#ip address 192.168.0.11 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface loopback 0
IOU2(config-if)#ip address 192.168.1.11 255.255.255.255
IOU2(config-if)#no shutdown
IOU2(config-if)#exit

使用 show ip interface brief 查看路由接口思科防火墙ASA配置NAT_内网_03

3.IOU3的配置

IOU3(config)#interface ethernet 0/0
IOU3(config-if)#duplex full
IOU3(config-if)#ip address 172.16.1.1 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
IOU3(config)#interface loopback 0
IOU3(config-if)#ip address 172.16.88.10 255.255.255.255
IOU3(config-if)#no shutdown
IOU3(config-if)#exit

使用 show ip interface brief 查看路由接口

思科防火墙ASA配置NAT_静态路由_04

4.ASA的配置

ciscoasa> enable 
ciscoasa# conf t
ciscoasa(config)# hostname ASA
ASA(config)# interface gigabitEthernet 0
ASA(config-if)# nameif outside
ASA(config-if)# ip address 200.1.1.1 255.255.255.0
ASA(config-if)# no shu
ASA(config-if)# exit
ASA(config)# interface gigabitEthernet 1
ASA(config-if)# nameif inside
ASA(config-if)# ip address 172.16.1.254 255.255.255.0
ASA(config-if)# no shu
ASA(config-if)# exit
ASA(config)# interface gigabitEthernet 2
ASA(config-if)# nameif dmz
ASA(config-if)# security-level 50
ASA(config-if)# ip address 192.168.0.254 255.255.255.0
ASA(config-if)# no shu
ASA(config-if)# exit

使用 show interface ip brief 查看接口思科防火墙ASA配置NAT_静态路由_05

二、配置路由

1.IOU2的配置

IOU2(config)#ip route 0.0.0.0 0.0.0.0 192.168.0.254

使用 show ip route 查看静态路由

思科防火墙ASA配置NAT_ide_06

2.IOU3的配置

IOU3(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.254

使用 show ip route 查看静态路由思科防火墙ASA配置NAT_静态路由_07

3.ASA的配置

ASA(config)# route outside 0 0 200.1.1.2   
ASA(config)# route dmz 192.168.1.0 255.255.255.0 192.168.0.11
ASA(config)# route inside 172.16.88.0 255.255.255.0 172.16.1.1

三、配置动态NAT实现telnet外网

定义动态NAT的地址池

ASA(config)# object network out_pool
ASA(config-network-object)# range 200.1.1.10 200.1.1.20
ASA(config-network-object)# exit

指定内网网段

ASA(config)# object network inside_1
ASA(config-network-object)# subnet 172.16.1.0 255.255.255.0
ASA(config-network-object)# exit
ASA(config)# object network inside_2
ASA(config-network-object)# sub
ASA(config-network-object)# subnet 172.16.88.0 255.255.255.0
ASA(config-network-object)# exit
ASA(config)# object network dmz_1
ASA(config-network-object)# sub
ASA(config-network-object)# subnet 192.168.0.0 255.255.255.0
ASA(config-network-object)# exit
ASA(config)# object network dmz_2
ASA(config-network-object)# subnet 192.168.1.0 255.255.255.0
ASA(config-network-object)# exit

创建内网地址组

ASA(config)# object-group network inside_group
ASA(config-network-object-group)# network-object object inside_1
ASA(config-network-object-group)# network-object object inside_2
ASA(config-network-object-group)# exit
ASA(config)# object-group network dmz_group
ASA(config-network-object-group)# network-object object dmz_1
ASA(config-network-object-group)# network-object object dmz_2
ASA(config-network-object-group)# exit

ASA配置nat

ASA(config)# nat (inside,outside) source dynamic inside_group out_pool
ASA(config)# nat (dmz,outside) source dynamic dmz_group out_pool

最后测试一下就好了思科防火墙ASA配置NAT_内网_08谢谢观看!!!