实验拓扑

路由重分发_redis

网络地址规划如下

IOU1

e0/0:192.168.13.1

IOU4

e0/0:192.168.34.4

e0/1:192.168.12.1

loopback 0:4.4.4.4

e0/2:100.0.0.1


loopback 0:1.1.1.1

IOU6

e0/0:100.0.0.2



IOU2

e0/0:192.168.12.2

IOU3

e0/0:192.168.13.3

e0/1:192.168.25.2

e0/1:192.168.34.3

loopbzck 0:2.2.2.2

loopback 0:3.3.3.3


IOU5



e0/0:192.168.25.5

loopback 0:5.5.5.5

一、配置IP地址

1.IOU1的基础配置

IOU1(config)#interface ethernet 0/0
IOU1(config-if)#ip address 192.168.13.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface ethernet 0/1
IOU1(config-if)#ip address 192.168.12.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface ethernet 0/2
IOU1(config-if)#ip address 100.0.0.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface loopback 0
IOU1(config-if)#ip address 1.1.1.1 255.255.255.255
IOU1(config-if)#no shutdown
IOU1(config-if)#exit

使用show ip interface brief查看接口状态

路由重分发_redis_02

2.IOU2的基础配置

IOU2(config)#interface ethernet 0/0
IOU2(config-if)#ip address 192.168.12.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface ethernet 0/1
IOU2(config-if)#ip address 192.168.25.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface loopback 0
IOU2(config-if)#ip address 2.2.2.2 255.255.255.255
IOU2(config-if)#no shutdown
IOU2(config-if)#exi

使用show ip interface brief查看接口状态

路由重分发_5e_03

3.IOU3的基础配置

IOU3(config)#interface ethernet 0/0
IOU3(config-if)#ip address 192.168.13.3 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
IOU3(config)#interface ethernet 0/1
IOU3(config-if)#ip address 192.168.34.3 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
IOU3(config)#interface loopback 0
IOU3(config-if)#ip address 3.3.3.3 255.255.255.255
IOU3(config-if)#no shutdown
IOU3(config-if)#exit

使用show ip interface brief查看接口状态

路由重分发_5e_04

4.IOU4的基础配置

IOU4(config)#interface ethernet 0/0
IOU4(config-if)#ip address 192.168.34.4 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#interface loopback 0
IOU4(config-if)#ip address 4.4.4.4 255.255.255.255
IOU4(config-if)#no shutdown
IOU4(config-if)#exit

查看接口状态

路由重分发_redis_05

5.IOU5的基础配置

IOU5(config)#interface ethernet 0/0
IOU5(config-if)#ip address 192.168.25.5 255.255.255.0
IOU5(config-if)#no shutdown
IOU5(config-if)#exit
IOU5(config)#interface loopback 0
IOU5(config-if)#ip address 5.5.5.5 255.255.255.255
IOU5(config-if)#no shutdown
IOU5(config-if)#exit

查看接口状态

路由重分发_redis_06

6.IOU6的基础配置

IOU6(config)#interface ethernet 0/0
IOU6(config-if)#ip address 100.0.0.2 255.255.255.0
IOU6(config-if)#no shutdown
IOU6(config-if)#exit

查看接口状态

路由重分发_路由表_07

二、配置ospf和rip

1.IOU1的配置

IOU1(config)#router ospf 1
IOU1(config-router)#network 192.168.13.0 0.0.0.255 area 1
IOU1(config-router)#network 192.168.12.0 0.0.0.255 area 0
IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 0
IOU1(config-router)#exit

2.IOU2的配置

IOU2(config)#router ospf 1
IOU2(config-router)#network 192.168.12.0 0.0.0.255 area 0
IOU2(config-router)#network 2.2.2.2 0.0.0.0 area 0
IOU2(config-router)#exit
IOU2(config)#router rip
IOU2(config-router)#version 2
IOU2(config-router)#no auto-summary
IOU2(config-router)#network 192.168.25.0
IOU2(config-router)#exit

3.IOU3的配置

IOU3(config)#router ospf 1
IOU3(config-router)#network 192.168.13.3 0.0.0.255 area 1
IOU3(config-router)#network 3.3.3.3 0.0.0.0 area 1
IOU3(config-router)#exit

4.IOU5的配置

IOU5(config)#router rip
IOU5(config-router)#version 2
IOU5(config-router)#no auto-summary
IOU5(config-router)#network 192.168.25.0
IOU5(config-router)#network 5.0.0.0
IOU5(config-router)#exit

在IOU2中重分发ospf和rip

IOU2(config)#router ospf 1               
IOU2(config-router)#no redistribute rip subnets metric 5
IOU2(config-router)#redistribute rip metric 200 subnets
IOU2(config-router)#exit
IOU2(config)#router rip
IOU2(config-router)#redistribute ospf 1 metric 5
IOU2(config-router)#exit

查看路由表

路由重分发_redis_08

在IOU1中重分发默认路由

IOU1(config)#ip route 0.0.0.0 0.0.0.0 100.0.0.2
IOU1(config)#router ospf 1
IOU1(config-router)#default-information originate
IOU1(config-router)#exit

查看路由表

路由重分发_redis_09

在IOU3中重分发静态路由和直连路由

IOU3(config)#router ospf 1
IOU3(config-router)#redistribute static subnets
IOU3(config-router)#redistribute connected subnets
IOU3(config-router)#exit

查看路由表

路由重分发_5e_10

使用ping通测试

路由重分发_redis_11谢谢观看!