BGP配置实验_BGP

配置IP地址

IOU1

IOU1(config)#interface ethernet 0/0 
IOU1(config-if)#duplex full
IOU1(config-if)#ip address 12.12.12.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface loopback 0
IOU1(config-if)#ip address 1.1.1.1 255.255.255.0
IOU1(config-if)#exit

IOU2

IOU2(config)#interface ethernet 0/0
IOU2(config-if)#duplex full
IOU2(config-if)#ip address 12.12.12.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface ethernet 0/1
IOU2(config-if)#duplex full
IOU2(config-if)#ip address 23.23.23.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface loopback 0
IOU2(config-if)#ip address 2.2.2.2 255.255.255.0
IOU2(config-if)#exit

IOU3以及默认路由

IOU3(config)#interface ethernet 0/1
IOU3(config-if)#duplex full
IOU3(config-if)#ip address 34.34.34.3 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
IOU3(config)#interface loopback 0
IOU3(config-if)#ip address 3.3.3.3 255.255.255.0
IOU3(config-if)#exit
IOU3(config)#ip route 4.4.0.4 255.255.255.255 34.34.34.4

IOU4以及默认路由

IOU4(config)#interface ethernet 0/0
IOU4(config-if)#duplex full
IOU4(config-if)#ip address 34.34.34.4 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#interface loopback 0
IOU4(config-if)#ip address 4.4.0.4 255.255.255.0
IOU4(config-if)#interface loopback 1
IOU4(config-if)#ip address 4.4.1.4 255.255.255.0
IOU4(config-if)#interface loopback 2
IOU4(config-if)#ip address 4.4.2.4 255.255.255.0
IOU4(config-if)#interface loopback 3
IOU4(config-if)#ip address 4.4.3.4 255.255.255.0
IOU4(config-if)#exit
IOU4(config)#ip route 3.3.3.3 255.255.255.255 34.34.34.3

配置BGP

IOU1

IOU1(config)#router bgp 100
IOU1(config-router)#neighbor 2.2.2.2 remote-as 100
IOU1(config-router)#neighbor 2.2.2.2 update-source loopback 0
IOU1(config-router)#neighbor 3.3.3.3 remote-as 100
IOU1(config-router)#neighbor 3.3.3.3 update-source loopback 0
IOU1(config-router)#exit

IOU2

IOU2(config)#router bgp 100
IOU2(config-router)#neighbor 1.1.1.1 remote-as 100
IOU2(config-router)#neighbor 1.1.1.1 update-source loopback 0
IOU2(config-router)#neighbor 3.3.3.3 remote-as 100
IOU2(config-router)#neighbor 3.3.3.3 update-source loopback 0
IOU2(config-router)#exit

IOU3

IOU3(config)#router bgp 100
IOU3(config-router)#neighbor 1.1.1.1 remote-as 100
IOU3(config-router)#neighbor 1.1.1.1 update-source loopback 0
IOU3(config-router)#neighbor 2.2.2.2 remote-as 100
IOU3(config-router)#neighbor 2.2.2.2 update-source loopback 0
IOU3(config-router)#neighbor 4.4.0.4 remote-as 200
IOU3(config-router)#neighbor 4.4.0.4 update-source loopback 0
IOU3(config-router)#neighbor 4.4.0.4 ebgp-multihop 10
IOU3(config-router)#exit

IOU4

IOU4(config)#router bgp 200
IOU4(config-router)#neighbor 3.3.3.3 remote-as 100
IOU4(config-router)#neighbor 3.3.3.3 update-source loopback 0
IOU4(config-router)#neighbor 3.3.3.3 ebgp-multihop 10
IOU4(config-router)#exit

配置OSPF

IOU1

IOU1(config)#router ospf 1
IOU1(config-router)#network 12.12.12.0 0.0.0.255 area 0
IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 0
IOU1(config-router)#exit

IOU2

IOU2(config)#router ospf 1
IOU2(config-router)#network 12.12.12.0 0.0.0.255 area 0
IOU2(config-router)#network 23.23.23.0 0.0.0.255 area 0
IOU2(config-router)#network 2.2.2.2 0.0.0.0 area 0
IOU2(config-router)#exit

IOU3

IOU3(config)#router ospf 1
IOU3(config-router)#network 23.23.23.0 0.0.0.255 area 0
IOU3(config-router)#network 3.3.3.3 0.0.0.255 area 0
IOU3(config-router)#exit

使用show ip bgp summary查看邻接表

BGP配置实验_OSPF_02

使用show ip route查看路由表

BGP配置实验_BGP_03 使用ping测试

BGP配置实验_BGP_04