实验描述:

1.网络拓扑及互联IP地址规划如图所示

2.R1、R2、R3各自创建Loopback接口,IP地址地址为x.x.x.x为路由器的编号

3.R1、R2、R3运行OSPF,宣告三者互联接口及各自的Loopback接口

4.BGP的AS规划如图所示

5.完成基本的IP、IGP配置,建立BGP连接

实验拓扑如下:

BGP路由协议_路由协议

第一步接口配置IP地址,接口状态为UP UP

配置命令省略!!!

可以使用show ip interface brief 查看接口的IP地址和接口状态

第二步配置OSPF动态路由协议

在IOU1、IOU2、IOU3上配置

配置命令如下:

IOU1(config)#router ospf 1
IOU1(config-router)#router-id 1.1.1.1
IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 0
IOU1(config-router)#network 12.12.12.0 0.0.0.255 area 0
IOU1(config-router)#network 13.13.13.0 0.0.0.255 area 0
IOU1(config-router)#exit
IOU2(config)#router ospf 1
IOU2(config-router)#router
IOU2(config-router)#router-id 2.2.2.2
IOU2(config-router)#network 2.2.2.2 0.0.0.0 area 0
IOU2(config-router)#network 12.12.12.0 0.0.0.255 area 0
IOU2(config-router)#exit
IOU3(config)#router ospf 1
IOU3(config-router)#router
IOU3(config-router)#router-id 3.3.3.3
IOU3(config-router)#network 13.13.13.0 0.0.0.255 area 0
IOU3(config-router)#network 3.3.3.3 0.0.0.0 area 0
IOU3(config-router)#exit

可以使用show ip route查看路由表信息

图片略!!!

第三步BGP路由协议

在IOU1、IOU2、IOU3、IOU4、IOU5上配置

配置命令如下:

IOU1(config)#router bgp 123
IOU1(config-router)#bgp router-id 1.1.1.1
IOU1(config-router)#no synchronization
IOU1(config-router)#neighbor 2.2.2.2 remote-as 123
IOU1(config-router)#neighbor 3.3.3.3 remote-as 123
IOU1(config-router)#neighbor 2.2.2.2 update-source loopback 0
IOU1(config-router)#neighbor 3.3.3.3 update-source loopback 0
IOU1(config-router)#neighbor 3.3.3.3 route-reflector-client
IOU1(config-router)#neighbor 2.2.2.2 route-reflector-client
IOU1(config-router)#network 1.1.1.0 mask 255.255.255.0
IOU1(config-router)#network 12.12.12.0 mask 255.255.255.0
IOU1(config-router)#network 13.13.13.0 mask 255.255.255.0
IOU1(config-router)#exit
IOU2(config)#router bgp 123
IOU2(config-router)#bgp router-id 2.2.2.2
IOU2(config-router)#no synchronization
IOU2(config-router)#neighbor 1.1.1.1 remote-as 123
IOU2(config-router)#neighbor 24.24.24.4 remote-as 100
IOU2(config-router)#neighbor 1.1.1.1 update-source loopback 0
IOU2(config-router)#network 2.2.2.0 mask 255.255.255.0
IOU2(config-router)#exit
IOU3(config)#router bgp 123
IOU3(config-router)#bgp router-id 3.3.3.3
IOU3(config-router)#no synchronization
IOU3(config-router)#neighbor 1.1.1.1 remote-as 123
IOU3(config-router)#neighbor 1.1.1.1 update-source loopback 0
IOU3(config-router)#neighbor 35.35.35.5 remote-as 200
IOU3(config-router)#network 3.3.3.0 mask 255.255.255.0
IOU3(config-router)#exit
IOU4(config)#router bgp 100
IOU4(config-router)#bgp router-id 4.4.4.4
IOU4(config-router)#no synchronization
IOU4(config-router)#neighbor 24.24.24.2 remote-as 123
IOU4(config-router)#network 100.1.1.0 mask 255.255.255.0
IOU4(config-router)#network 100.2.2.0 mask 255.255.255.0
IOU4(config-router)#network 24.24.24.0 mask 255.255.255.0
IOU4(config-router)#exit
IOU5(config)#router bgp 200
IOU5(config-router)#bgp router-id 5.5.5.5
IOU5(config-router)#no synchronization
IOU5(config-router)#neighbor 35.35.35.3 remote-as 123
IOU5(config-router)#network 100.1.1.0 mask 255.255.255.0
IOU5(config-router)#network 100.2.2.0 mask 255.255.255.0
IOU5(config-router)#network 35.35.35.0 mask 255.255.255.0
IOU5(config-router)#exit

可以使用show ip bgp命令查看

BGP路由协议_路由协议_02

使用show ip route命令查看

BGP路由协议_路由表_03

使用ping命令测试网络连通性

BGP路由协议_路由表_04

最后,技术上有你有我,愿我们早日成为大牛!