实验案例:两个区域的ASA配置

Cisco ASA基础_基本配置

连接网络,其中路由器R1和R2用来模拟PC

需求描述

要求配置ASA的接口和ACL,并验证接口之间的通信。

配置步骤

1.配置路由器和ASA的接口,实现网络互通

2.分别配置R1和R2模拟PC,并启用telnet,验证在R1上可以telnet到R2,但在R2上不能telnet到R1。

3.使用show conn datail命令查看conn表

4.测试在R1上能否ping通R2,然后配置ACL实现在R1上ping通R2

5.配置ACL实现在R2上telnet到R1

配置命令如下:

R1和R2的接口基本配置命令如下:

R1

R1(config)#interface ethernet 0/0
R1(config-if)#duplex full
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

默认路由

R1(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.254

启用telnet

R1(config)#username bdqn privilege 15 password 123.123
R1(config)#line vty 0 4
R1(config-line)#login local
R1(config-line)#transport input telnet
R1(config-line)#exit

R2

R2(config)#interface ethernet 0/0
R2(config-if)#duplex full
R2(config-if)#ip address 172.16.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

默认路由

R2(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.254

启用telnet

R2(config)#username bdqn privilege 15 password 123.123
R2(config)#line vty 0 4
R2(config-line)#login local
R2(config-line)#transport input telnet
R2(config-line)#exit

配置ASA的接口

ciscoasa(config)# interface gigabitEthernet 0
ciscoasa(config-if)# nameif inside
INFO: Security level for "inside" set to 100 by default.
ciscoasa(config-if)# ip address 10.1.1.254 255.255.255.0
ciscoasa(config-if)# no shutdown
ciscoasa(config-if)# exit

ciscoasa(config)# interface gigabitEthernet 1
ciscoasa(config-if)# nameif outside
INFO: Security level for "outside" set to 0 by default.
ciscoasa(config-if)# ip address 172.16.1.254 255.255.255.0
ciscoasa(config-if)# no shutdown
ciscoasa(config-if)# exit

验证在R1上可以telnet到R2,但在R2上不能telnet到R1。

Cisco ASA基础_ide_02

Cisco ASA基础_基本配置_03

使用show conn datail命令查看conn表

Cisco ASA基础_基本配置_04

配置ACL实现在R1上ping通R2

ciscoasa(config)# access-list ping permit icmp host 10.1.1.1 host 172.16.1.1
ciscoasa(config)# access-group ping in interface outside

Cisco ASA基础_基本配置_05

配置ACL实现在R2上telnet到R1

ciscoasa(config)# access-list telnet permit ip host 172.16.1.1 host 10.1.1.1
ciscoasa(config)# access-group telnet in interface outside

Cisco ASA基础_基本配置_06

本实验结束,如有错误还请谅解,谢谢观看!!!