实验中需要使用到OSPF、rip、静态路由、默认路由、NAT、路由重分发几种协议

拓扑如下:

Cisco路由重分发实验案例_ide

IP地址规划如下:

IOU1

eth 0/0:100.0.0.1/24

eth 0/1:192.168.12.1/24

eth 0/2:192.168.13.1/24

loopback 0:1.1.1.1/32

IOU2

eth 0/0:192.168.12.2/24

eth 0/1:192.168.25.2/24

loopback 0 :2.2.2.2/32

IOU3

eth 0/0:192.168.13.3/24

eth 0/1:192.168.34.3/24

loopback 0: 3.3.3.3/32

IOU4 

eth 0/0:192.168.34.4/24

loopback 0:4.4.4.4/32

IOU5

eht 0/0:192.168.25.5/24

loopback 0:5.5.5.5/32

IOU6

eth 0/0:100.0.0.6/24

第一步配置接口ip地址,接口状态UP UP

IOU1上的配置

IOU1#configure terminal
IOU1(config)#interface ethernet 0/0
IOU1(config-if)#ip address 100.0.0.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface ethernet 0/1
IOU1(config-if)#ip address 192.168.12.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface ethernet 0/2
IOU1(config-if)#ip address 192.168.13.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface loopback 0
IOU1(config-if)#ip address 1.1.1.1 255.255.255.255
IOU1(config-if)#exit

在IOU上配置一条去往ISP的默认路由命令如下:

IOU1(config)#ip route 0.0.0.0 0.0.0.0 100.0.0.6

IOU2上的配置

IOU2#configure terminal
IOU2(config)#interface ethernet 0/0
IOU2(config-if)#ip address 192.168.12.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface ethernet 0/1
IOU2(config-if)#ip address 192.168.25.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface loopback 0
IOU2(config-if)#ip address 2.2.2.2 255.255.255.255
IOU2(config-if)#exit

IOU3上的配置

IOU3#configure terminal
IOU3(config)#interface ethernet 0/0
IOU3(config-if)#ip address 192.168.13.3 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
IOU3(config)#interface ethernet 0/1
IOU3(config-if)#ip address 192.168.34.3 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
IOU3(config)#interface loopback 0
IOU3(config-if)#ip address 3.3.3.3 255.255.255.255
IOU3(config-if)#exit

在IOU上配置一条去往IOU4的静态路由命令如下:

IOU3(config)#ip route 4.4.4.4 255.255.255.255 192.168.34.4


IOU4上的配置

IOU4#configure terminal
IOU4(config)#interface ethernet 0/0
IOU4(config-if)#ip address 192.168.34.4 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#interface loopback 0
IOU4(config-if)#ip address 4.4.4.4 255.255.255.255
IOU4(config-if)#exit

在IOU4上配置一条出去的默认路由命令如下:

IOU4(config)#ip route 0.0.0.0 0.0.0.0 192.168.34.3

IOU5上的配置

IOU5#configure terminal
IOU5(config)#interface ethernet 0/0
IOU5(config-if)#ip address 192.168.25.5 255.255.255.0
IOU5(config-if)#no shutdown
IOU5(config-if)#exit
IOU5(config)#interface loopback 0
IOU5(config-if)#ip address 5.5.5.5 255.255.255.255
IOU5(config-if)#exit

ISP上的配置

ISP#configure terminal
ISP(config)#interface ethernet 0/0
ISP(config-if)#ip address 100.0.0.6 255.255.255.0
ISP(config-if)#no shutdown
ISP(config-if)#exit

使用show ip interface brief查看接口信息和状态(其他路由也使用同样的命令查看这里省略)

Cisco路由重分发实验案例_静态路由_02


第二配置OSPF、rip协议

IOU1上的配置

IOU1(config)#router ospf 1
IOU1(config-router)#router-id 1.1.1.1
IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 0
IOU1(config-router)#network 192.168.13.0 0.0.0.255 area 1
IOU1(config-router)#network 192.168.12.0 0.0.0.255 area 0
IOU1(config-router)#exit

IOU2上的配置

IOU2(config)#router ospf 1
IOU2(config-router)#router-id 2.2.2.2
IOU2(config-router)#network 2.2.2.2 0.0.0.0 area 0
IOU2(config-router)#network 192.168.12.0 0.0.0.255 area 0
IOU2(config-router)#exit
IOU2(config)#router rip
IOU2(config-router)#version 2
IOU2(config-router)#no auto-summary
IOU2(config-router)#network 192.168.25.0
IOU2(config-router)#exit

IOU5上的配置

IOU5(config)#router rip 
IOU5(config-router)#version 2
IOU5(config-router)#no auto-summary
IOU5(config-router)#network 192.168.25.0
IOU5(config-router)#network 5.0.0.0
IOU5(config-router)#exit

查看IOU2的路由表有rip的路由也有OSPF的路由

Cisco路由重分发实验案例_路由表_03

而IOU1上却没有IOU5的路由,而且IOU1上的默认路由IOU2也没有

Cisco路由重分发实验案例_ide_04

因为他们是不同的协议

接下来分别在IOU2、IOU1上配置路由重分发

IOU2上的配置命令

把rip宣告到OSPF

IOU2(config)#router ospf 1
IOU2(config-router)#redistribute rip metric 200 subnets metric-type 1
IOU2(config-router)#exit

IOU1查看路由表发现有了IOU5的信息

Cisco路由重分发实验案例_ide_05

但是IOU5却没有ospf的信息

Cisco路由重分发实验案例_静态路由_06

接下来要把OSPF宣告到rip

IOU2(config)#router rip
IOU2(config-router)#redistribute ospf 1 metric 5
IOU2(config-router)#exit

可以在IOU5使用show ip route查看路由表

IOU5上已经有了IOU1、IOU2的路由信息了,但是IOU1上的路由表没有。

配置路由重分发将默认路由宣告到OSPF

在IOU1上配置

IOU1(config)#router ospf 1
IOU1(config-router)#default-information originate always
IOU1(config-router)#exit

default-information originate always 这个命令的意思以不管有没有默认路由,都强制散发一条默认路由

Cisco路由重分发实验案例_静态路由_07

发现IOU2上已经有了默认路由,但是IOU5上有没有呢?

Cisco路由重分发实验案例_ide_08

发现IOU5也已经有了

接下来配置IOU3

在IOU3上配置OSPF命令如下:

IOU3(config)#router ospf 1
IOU3(config-router)#router-id 3.3.3.3
IOU3(config-router)#network 3.3.3.3 0.0.0.0 area 1
IOU3(config-router)#netwrok 192.168.13.0 0.0.0.255 area 1
IOU3(config-router)#network 192.168.13.0 0.0.0.255 area 1
IOU3(config-router)#exit

查看IOU3的路由表

Cisco路由重分发实验案例_静态路由_09

接下来吧静态路由宣告出去命令如下:

IOU3(config)#router ospf 1
IOU3(config-router)#redistribute static metric 5 metric-type 1
IOU3(config-router)#redistribute connected subnets
IOU3(config-router)#exit

在IOU上查看路由表,看有没有静态路由

Cisco路由重分发实验案例_ide_10

已经有了,接下来在IOU4上ping测试网连通性

Cisco路由重分发实验案例_路由表_11

发现外网ping不通

这需要配置NAT,配置静态NAT、动态NAT、PAT都行,我这里都配

在IOU1上配置静态NAT

指定192.168.13.3 访问外网后的地址是100.0.0.50

IOU1(config)#ip nat inside source static 192.168.13.3 100.0.0.50   

在IOU1上配置动态NAT

192.168.34.4 访问外的地址是随机的100.0.0.100 100.0.0.150

IOU1(config)#ip nat pool 1 100.0.0.100 100.0.0.150 netmask 255.255.255.0
IOU1(config)#access-list 2 permit 192.168.34.4 0.0.0.255
IOU1(config)#ip nat inside source list 2 pool 1

在IOU1上配置PAT

多对一的方式

IOU1(config)#ip nat pool pat 100.0.0.200 100.0.0.200 netmask 255.255.255.0
IOU1(config)#access-list 3 permit 192.168.25.5 0.0.0.255
IOU1(config)#access-list 3 permit 192.168.12.5 0.0.0.255
IOU1(config)#ip nat inside source list 3 pool pat overload
IOU1(config)#

最后配置出入接口

IOU1(config)#interface ethernet 0/2
IOU1(config-if)#ip nat inside
IOU1(config-if)#exit
IOU1(config)#interface ethernet 0/1
IOU1(config-if)#ip nat inside
IOU1(config-if)#exit
IOU1(config)#interface et
IOU1(config)#interface ethernet 0/0
IOU1(config-if)#ip nat outside
IOU1(config-if)#exit

ping测试网络连通信

Cisco路由重分发实验案例_路由表_12

查看NAT信息

Cisco路由重分发实验案例_路由表_13

谢谢观看!!!