实验拓扑图

OSPF多区域案例—路由重分发_ide

拓扑网络规划:

IOU1

Loopback0: 1.1.1.1

IOU2

Loopback0:2.2.2.2

e0/0: 192.168.20.2

e0/0: 192.168.40.1

e0/1: 192.168.40.2

e0/1: 192.168.50.1

e0/2: 100.0.0.2

IOU4

Loopback0: 4.4.4.4

IOU3

Loopback0: 3.3.3.3

e0/0: 192.168.10.2

e0/0: 192.168.20.1

IOU5

Loopback0: 5.5.5.5

e0/1: 192.168.10.1

e0/0: 192.168.50.2

ISP

Loopback0: 100.10.10.10


e0/0: 100.0.0.1


一、配置路由器的接口地址和loopback

1、IOU1的基础配置

IOU1(config)#in loopback 0
IOU1(config-if)#ip address 1.1.1.1 255.255.255.255
IOU1(config-if)#ex
IOU1(config)#in e 0/0
IOU1(config-if)#ip add 192.168.20.2 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#ex
IOU1(config)#in e 0/1
IOU1(config-if)#ip add 192.168.40.2 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#ex
IOU1(config)#in e 0/2
IOU1(config-if)#ip add 100.0.0.2 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#ex
IOU1(config)#ip route 0.0.0.0 0.0.0.0 100.0.0.1 //配置默认路由

使用show ip interface brief命令查看接口信息

OSPF多区域案例—路由重分发_redis_02


2、IOU2的基础配置

IOU2(config)#in loopback 0
IOU2(config-if)#ip add 2.2.2.2 255.255.255.255
IOU2(config-if)#ex
IOU2(config)#in e 0/0
IOU2(config-if)#ip add 192.168.40.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#ex
IOU2(config)#in e 0/1
IOU2(config-if)#ip add 192.168.50.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#ex

使用show ip interface brief命令查看接口信息

OSPF多区域案例—路由重分发_路由表_03


3、IOU3的基础配置

IOU3(config)#in loopback 0
IOU3(config-if)#ip add 3.3.3.3 255.255.255.0
IOU3(config-if)#ex
IOU3(config)#in e 0/0
IOU3(config-if)#ip add 192.168.20.1 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#ex
IOU3(config)#in e 0/1
IOU3(config-if)#ip add 192.168.10.1 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#ex

使用show ip interface brief命令查看接口信息

OSPF多区域案例—路由重分发_ide_04


4、IOU4的基础配置

IOU4(config)#in loopback 0
IOU4(config-if)#ip add 4.4.4.4 255.255.255.255
IOU4(config-if)#ex
IOU4(config)#in e 0/0
IOU4(config-if)#ip add 192.168.10.2 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#ex

使用show ip interface brief命令查看接口信息

OSPF多区域案例—路由重分发_ide_05


5、IOU5的基础配置

IOU5(config)#in loopback 0
IOU5(config-if)#ip add 5.5.5.5 255.255.255.255
IOU5(config-if)#ex
IOU5(config)#in e 0/0
IOU5(config-if)#ip add 192.168.50.2 255.255.255.0
IOU5(config-if)#no shutdown
IOU5(config-if)#ex

使用show ip interface brief命令查看接口信息

OSPF多区域案例—路由重分发_redis_06


二、配置OSPF、RIP、NAT协议

1、配置OSPF协议

IOU1配置

IOU1(config)#router ospf 1
IOU1(config-router)#router-id 1.1.1.1
IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 0
IOU1(config-router)#network 192.168.20.0 0.0.0.255 area 1
IOU1(config-router)#network 192.168.40.0 0.0.0.255 area 0
IOU1(config-router)#ex
IOU1(config)#router ospf 1
IOU1(config-router)#default-information originate always
IOU1(config-router)#ex

IOU2配置

IOU2(config)#router ospf 1
IOU2(config-router)#router-id 2.2.2.2
IOU2(config-router)#network 2.2.2.2 0.0.0.0 area 0
IOU2(config-router)#network 192.168.40.0 0.0.0.255 area 0
IOU2(config-router)#ex

IOU3配置

IOU3(config)#ip route 4.4.4.4 255.255.255.255 192.168.10.2   //配置静态路由
IOU3(config)#router ospf 1
IOU3(config-router)#router-id 3.3.3.3
IOU3(config-router)#network 192.168.20.0 0.0.0.255 area 1
IOU3(config-router)#network 3.3.3.3 0.0.0.0 area 1
IOU3(config-router)#ex
IOU3(config)#router ospf 1
IOU3(config-router)#redistribute connected subnets
IOU3(config-router)#ex
IOU3(config)#router ospf 1
IOU3(config-router)#redistribute static metric 5 metric-type 1
IOU3(config-router)#

IOU4配置

IOU4(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.1


2、配置RIP协议

IOU2配置

IOU2(config)#router rip 
IOU2(config-router)#version 2
IOU2(config-router)#no auto-summary
IOU2(config-router)#network 192.168.50.0
IOU2(config-router)#ex
IOU2(config)#router ospf 1
IOU2(config-router)#redistribute rip metric 200 subnets
IOU2(config-router)#ex
IOU2(config)#router rip
IOU2(config-router)#redistribute ospf 1 metric 15
IOU2(config-router)#ex

IOU5配置

IOU5(config)#router rip 
IOU5(config-router)#version 2
IOU5(config-router)#no auto-summary
IOU5(config-router)#network 192.168.50.0
IOU5(config-router)#network 5.0.0.0
IOU5(config-router)#ex


3、配置NAT协议

IOU1配置

IOU1(config)#ip nat pool pat 100.0.0.10 100.0.0.10 netmask 255.255.255.0  
IOU1(config)#access-list 1 permit 192.168.0.0 0.0.255.255
IOU1(config)#ip nat inside source list 1 interface ethernet 0/2 overload
IOU1(config)#interface e0/2
IOU1(config-if)#ip nat outside
IOU1(config-if)#ex
IOU1(config)#interface e0/1
IOU1(config-if)#ip nat inside
IOU1(config-if)#ex
IOU1(config)#interface e0/0
IOU1(config-if)#ip nat inside
IOU1(config-if)#ex

ISP配置

IOU6(config)#in e 0/0
IOU6(config-if)#ip add 100.0.0.1 255.255.255.0
IOU6(config-if)#no shutdown
IOU6(config-if)#ex
IOU6(config)#in loopback 0
IOU6(config-if)#ip add 100.10.10.10 255.255.255.255
IOU6(config-if)#ex


在IOU1上使用show ip route查看路由表

OSPF多区域案例—路由重分发_ide_07

在IUO5上使用ping命令测试

OSPF多区域案例—路由重分发_redis_08