试验拓扑图


OSPF虚链路配置_路由表

配置IP地址


IOU1配置命令

IOU1(config)#int eth 0/0
IOU1(config-if)#ip address 10.0.12.1 255.255.255.0
IOU1(config-if)#no shu
IOU1(config-if)#ex
IOU1(config)#int eth 0/1
IOU1(config-if)#ip address 10.0.23.1 255.255.255.0
IOU1(config-if)#no shu
IOU1(config-if)#ex
IOU1(config)#int loo0
IOU1(config-if)#ip address 1.1.1.1 255.255.255.255
IOU1(config-if)#no shu
IOU1(config-if)#ex

用show ip interface brief查看接口

OSPF虚链路配置_链路_02

IOU2配置命令

IOU2(config)#int eth 0/0
IOU2(config-if)#ip address 10.0.12.2 255.255.255.0
IOU2(config-if)#no shu
IOU2(config-if)#ex
IOU2(config)#int eth 0/1
IOU2(config-if)#ip address 10.0.14.2 255.255.255.0
IOU2(config-if)#no shu
IOU2(config-if)#ex
IOU2(config)#int loo0
IOU2(config-if)#ip address 2.2.2.2 255.255.255.255
IOU2(config-if)#no shu
IOU2(config-if)#ex

用show ip interface brief查看接口

OSPF虚链路配置_ip地址_03

IOU3配置命令

IOU3(config)#int eth 0/0
IOU3(config-if)#ip address 10.0.23.3 255.255.255.0
IOU3(config-if)#no shu
IOU3(config-if)#ex
IOU3(config)#int loo0
IOU3(config-if)#ip address 3.3.3.3 255.255.255.255
IOU3(config-if)#no shu
IOU3(config-if)#ex

用show ip interface brief查看接口

OSPF虚链路配置_路由表_04

IOU4配置命令

IOU4(config)#int eth 0/0
IOU4(config-if)#ip address 10.0.14.4 255.255.255.0
IOU4(config-if)#no shu
IOU4(config-if)#ex
IOU4(config)#int loo0
IOU4(config-if)#ip address 4.4.4.4 255.255.255.255
IOU4(config-if)#no shu
IOU4(config-if)#ex

用show ip interface brief查看接口

OSPF虚链路配置_ip地址_05


配置OSPF宣告

  1. ​IOU1
IOU1(config)#router ospf 1
IOU1(config-router)#router-id 1.1.1.1
IOU1(config-router)#network 10.0.12.0 0.0.0.255 area 1
IOU1(config-router)#network 10.0.23.0 0.0.0.255 area 2
IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 1
IOU1(config-router)#ex
  1. IOU2
IOU2(config)#router ospf 1
IOU2(config-router)#router-id 2.2.2.2
IOU2(config-router)#network 10.0.14.0 0.0.0.255 area 0
IOU2(config-router)#network 10.0.12.0 0.0.0.255 area 1
IOU2(config-router)#network 2.2.2.2 0.0.0.0 area 1
IOU2(config-router)#ex
  1. IOU3
IOU3(config)#router ospf 1
IOU3(config-router)#router-id 3.3.3.3
IOU3(config-router)#network 10.0.23.0 0.0.0.255 area 2
IOU3(config-router)#network 3.3.3.3 0.0.0.0 area 2
  1. IOU4
IOU4(config)#router ospf 1
IOU4(config-router)#router-id 4.4.4.4
IOU4(config-router)#network 4.4.4.4 0.0.0.0 area 0
IOU4(config-router)#network 10.0.14.0 0.0.0.255 area 0

配置虚链路

  1. ​IOU1
IOU1(config)#router ospf 1
IOU1(config-router)#area 1 virtual-link 2.2.2.2

查看路由表

OSPF虚链路配置_链路_06

  1. IOU2​
IOU2(config)#router ospf 1
IOU2(config-router)#area 1 virtual-link 1.1.1.1

查看路由表

OSPF虚链路配置_ip地址_07