Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP实验案例_ip地址

配置trunk

IOU6配置:

使用dot1q封装

IOU6(config)#interface range ethernet 0/1-3

IOU6(config-if-range)#switchport trunk encapsulation dot1q

IOU6(config-if-range)#switchport mode trunk

IOU6(config-if-range)#ex


配置以太网通道

IOU6(config)#interface range ethernet 0/0-1

IOU6(config-if-range)#channel-group 1 mode on

IOU6(config)#interface port-channel 1

IOU6(config-if)#switchport trunk encapsulation dot1q

IOU6(config-if)#switchport mode trunk


另一边的IUO7的配置命令更IOU6基本一致

IOU7配置:

使用dot1q封装

IOU7config)#interface range ethernet 0/1-3

IOU7(config-if-range)#switchport trunk encapsulation dot1q

IOU7(config-if-range)#switchport mode trunk

IOU7(config-if-range)#ex


配置以太网通道

IOU7(config)#interface range ethernet 0/0-1

IOU7(config-if-range)#channel-group 1 mode on

IOU7(config)#interface port-channel 1

IOU7(config-if)#switchport trunk encapsulation dot1q

IOU7(config-if)#switchport mode trunk


IUO5只需要配置trunk封装

IUO5配置命令

IOU5(config)#interface range ethernet 0/1-3

IOU5(config-if-range)#switchport trunk encapsulation dot1q

IOU5(config-if-range)#switchport mode trunk

IOU5(config-if-range)#ex


使用 show trunk interface查看配置结果

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP实验案例_封装_02

 创建vlan10-13

IOU6

IOU6(config)#vlan 10-13

IOU6(config-vlan)#exit


IOU7

IOU6(config)#vlan 10-13

IOU6(config-vlan)#exit


IOU5

IOU6(config)#vlan 10-13

IOU6(config-vlan)#exit

 

MST多生成树

IOU6配置

IOU6(config)#spanning-tree mode mst

IOU6(config)#spanning-tree mst configuration

IOU6(config-mst)#name cisco

IOU6(config-mst)#revision 1

IOU6(config-mst)#instance 1 vlan 10,11

IOU6(config-mst)#instance 2 vlan 12,13

IOU6(config-mst)#exit

IOU6(config)#spanning-tree mst 1 root primary

IOU6(config)#spanning-tree mst 2 root secondary

IOU7配置

IOU7(config)#spanning-tree mode mst

IOU7(config)#spanning-tree mst configuration

IOU7(config-mst)#name cisco

IOU7(config-mst)#revision 1

IOU7(config-mst)#instance 1 vlan 10,11

IOU7(config-mst)#instance 2 vlan 12,13

IOU7(config-mst)#exit

IOU7(config)#spanning-tree mst 1 root secondary

IOU7(config)#spanning-tree mst 2 root primary

 

IOU5配置

Iou5配置与核心大致相同

IOU5(config)#spanning-tree mode mst

IOU5(config)#spanning-tree mst configuration

IOU5(config-mst)#name cisco

IOU5(config-mst)#revision 1

IOU5(config-mst)#instance 1 vlan 10,11

IOU5(config-mst)#instance 2 vlan 12,13

IOU5(config-mst)#exit

 

在接入层使用show spanning-tree mst 1 ,2查看配置结果

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP实验案例_ip地址_03

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP实验案例_封装_04

配置RRP

iou6配置

IOU6(config)#track 100 interface ethernet 0/2 line-protocol

Vlan10:IOU6(config)#interface vlan 10

IOU6(config-if)#ip address 192.168.10.60 255.255.255.192

IOU6(config-if)#vrrp 10 ip 192.168.10.62

IOU6(config-if)#vrrp 10 priority 110

IOU6(config-if)#vrrp 10 preempt

IOU6(config-if)#vrrp 10 track 100 decrement 30

Vlan11:IOU6(config)#interface vlan 11

IOU6(config-if)#ip address 192.168.10.124 255.255.255.192

IOU6(config-if)#vrrp 11 ip 192.168.10.126

IOU6(config-if)#vrrp 11 priority 110

IOU6(config-if)#vrrp 11 preempt

IOU6(config-if)#vrrp 11 track 100 decrement 30

Vlan12:IOU6(config)#interface vlan 12

IOU6(config-if)#ip address 192.168.10.188 255.255.255.192

IOU6(config-if)#vrrp 12 ip 192.168.10.190

IOU6(config-if)#vrrp 12 priority 90

IOU6(config-if)#vrrp 12 preempt

Vlan13:IOU6(config)#interface vlan 13

IOU6(config-if)#ip address 192.168.10.252 255.255.255.192

IOU6(config-if)#vrrp 13 ip 192.168.10.254

IOU6(config-if)#vrrp 13 priority 90

IOU6(config-if)#vrrp 13 preempt

 

IOU7配置

Iou7:

IOU7(config)#track 100 interface ethernet 0/2 line-protocol

IOU7(config-track)#ex

IOU7(config)#interface vlan 10

IOU7(config-if)#ip address 192.168.10.61 255.255.255.192

IOU7(config-if)#vrrp 10 ip 192.168.10.62

IOU7(config-if)#vrrp 10 priority 90

IOU7(config-if)#vrrp 10 preempt

IOU7(config-if)#no sh

IOU7(config-if)#interface vlan 11

IOU7(config-if)#ip address 192.168.10.125 255.255.255.192

IOU7(config-if)#vrrp 11 ip 192.168.10.126

IOU7(config-if)#vrrp 11 priority 90

IOU7(config-if)#vrrp 11 preempt

IOU7(config-if)#no sh

IOU7(config-if)#interface vlan 12

IOU7(config-if)#ip address 192.168.10.189 255.255.255.192

IOU7(config-if)#vrrp 12 ip 192.168.10.190

IOU7(config-if)#vrrp 12 priority 110

IOU7(config-if)#vrrp 12 preempt

IOU7(config-if)#vrrp 12 track 100 decrement 30

IOU7(config-if)#no sh

IOU7(config-if)#interface vlan 13

IOU7(config-if)#ip address 192.168.10.253 255.255.255.192

IOU7(config-if)#vrrp 13 ip 192.168.10.254

IOU7(config-if)#vrrp 13 priority 110

IOU7(config-if)#vrrp 13 preempt

IOU7(config-if)#vrrp 13 track 100 decrement 30

IOU7(config-if)#no sh

 

 

使用show vrrp brief查看iou6,7配置结果

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP实验案例_ip地址_05

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP实验案例_路由表_06

配置网络设备IP地址:

Iou6:

IOU6(config)#interface ethernet 0/2

IOU6(config-if)#no switchport

IOU6(config-if)#ip address 172.16.1.1 255.255.255.0

IOU6(config-if)#no shutdown

Iou7:

IOU7(config)#interface ethernet 0/2

IOU7(config-if)#no switchport

IOU7(config-if)#ip address 172.16.2.1 255.255.255.0

IOU7(config-if)#no sh

Iou8:

IOU8(config)#interface ethernet 0/0

IOU8(config-if)#duplex full

IOU8(config-if)#ip address 172.16.1.2 255.255.255.0

IOU8(config-if)#no sh

IOU8(config-if)#ex

IOU8(config)#interface ethernet 0/1

IOU8(config-if)#duplex full

IOU8(config-if)#ip address 172.16.2.2 255.255.255.0

IOU8(config-if)#no sh

IOU8(config-if)#no shutdown

IOU8(config-if)#ex

IOU8(config)#interface loo0

IOU8(config-if)#ip address 1.1.1.1 255.255.255.255

IOU8(config-if)#ex

配置静态/默认路由

Iou6:

ip route 0.0.0.0 0.0.0.0 172.16.1.2

Iou7:

ip route 0.0.0.0 0.0.0.0 172.16.2.2

iou8:

IOU8(config)#ip route 192.168.10.0 255.255.255.128 172.16.1.1

IOU8(config)#ip route 192.168.10.128 255.255.255.128 172.16.2.1

IOU8(config)#ip route 192.168.10.0 255.255.255.128 172.16.2.1 11

IOU8(config)#ip route 192.168.10.128 255.255.255.128 172.16.1.1 11

在iou8查看路由表:

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP实验案例_路由表_07

配置DHCP:

Iou8上配置:

IOU8(config)#ip dhcp pool vlan10

IOU8(dhcp-config)#network 192.168.10.0 /26

IOU8(dhcp-config)#default-router 192.168.10.62

IOU8(dhcp-config)#dns-server 8.8.8.8

IOU8(dhcp-config)#exit

IOU8(config)#ip dhcp pool vlan11

IOU8(dhcp-config)#network 192.168.10.64 /26

IOU8(dhcp-config)#default-router 192.168.10.126

IOU8(dhcp-config)#dns-server 8.8.8.8

IOU8(dhcp-config)#exit

IOU8(config)#ip dhcp pool vlan12

IOU8(dhcp-config)#network 192.168.10.128 /26

IOU8(dhcp-config)#default-router 192.168.10.190

IOU8(dhcp-config)#dns-server 8.8.8.8

IOU8(dhcp-config)#exit

IOU8(config)#ip dhcp pool vlan13

IOU8(dhcp-config)#network 192.168.10.192 /26

IOU8(dhcp-config)#default-router 192.168.10.254

IOU8(dhcp-config)#dns-server 8.8.8.8

IOU8(dhcp-config)#exit

在iou6和iou7上配置DHCP中继

Iou6:

IOU6(config)#interface vlan 10

IOU6(config-if)#ip helper-address 1.1.1.1

IOU6(config-if)#interface vlan 11

IOU6(config-if)#ip helper-address 1.1.1.1

IOU6(config-if)#interface vlan 12

IOU6(config-if)#ip helper-address 1.1.1.1

IOU6(config)#interface vlan 13

IOU6(config-if)#ip helper-address 1.1.1.1

IOU6(config-if)#ex

Iou7:

IOU6(config)#interface vlan 10

IOU6(config-if)#ip helper-address 1.1.1.1

IOU6(config-if)#interface vlan 11

IOU6(config-if)#ip helper-address 1.1.1.1

IOU6(config-if)#interface vlan 12

IOU6(config-if)#ip helper-address 1.1.1.1

IOU6(config)#interface vlan 13

IOU6(config-if)#ip helper-address 1.1.1.1

IOU6(config-if)#ex

 

在PC上验证DHCP:

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP实验案例_ip地址_08

在pc上测试网络连通性

Cisco使用MSTP+VRRP+静态路由+子网划分+DHCP实验案例_封装_09