网络实验拓扑:

            BGP配置实验案例_ip地址

配置IP地址:

iou1:

IOU1#configure terminal
IOU1(config)#interface ethernet 0/0
IOU1(config-if)#ip address 12.12.12.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#ex
IOU1(config)#interface loopback 0
IOU1(config-if)#ip address 1.1.1.1 255.255.255.0
IOU1(config-if)#ex

iou2:

IOU2#configure terminal
IOU2(config)#interface ethernet 0/0
IOU2(config-if)#ip address 12.12.12.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#ex
IOU2(config)#interface ethernet 0/1
IOU2(config-if)#ip address 23.23.23.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#ex
IOU2(config)#interface loopback 0
IOU2(config-if)#ip address 2.2.2.2 255.255.255.0
IOU2(config-if)#ex

iou3:

IOU3(config)#interface ethernet 0/0
IOU3(config-if)#ip address 23.23.23.3 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#ex
IOU3(config)#interface ethernet 0/1
IOU3(config-if)#ip address 34.34.34.3 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#ex
IOU3(config)#interface loopback 0
IOU3(config-if)#ip address 3.3.3.3 255.255.255.0
IOU3(config-if)#ex

iou4:

IOU4(config)#interface ethernet 0/0
IOU4(config-if)#ip address 34.34.34.4 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#ex
IOU4(config)#interface loopback 0
IOU4(config-if)#ip address 4.4.4.4 255.255.255.0
IOU4(config-if)#ex

配置OSPF

iou1:

IOU1(config)#router ospf 1
IOU1(config-router)#router-id 1.1.1.1
IOU1(config-router)#network 12.12.12.0 0.0.0.255 area 0
IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 0
IOU1(config-router)#ex

iou2:

IOU2(config)#router ospf 1
IOU2(config-router)#router-id 2.2.2.2
IOU2(config-router)#network 2.2.2.2 0.0.0.0 area 0
IOU2(config-router)#network 12.12.12.0 0.0.0.255 area 0
IOU2(config-router)#network 23.23.23.0 0.0.0.255 area 0
IOU2(config-router)#ex

iou3:

IOU3(config)#router ospf 1
IOU3(config-router)#router-id 3.3.3.3
IOU3(config-router)#network 3.3.3.3 0.0.0.0 area 0
IOU3(config-router)#network 23.23.23.0 0.0.0.255 area 0
IOU3(config-router)#exit

配置BGP:

iou1:

IOU1(config)#router bgp 100
IOU1(config-router)#bgp router-id 1.1.1.1
IOU1(config-router)#neighbor 2.2.2.2 remote-as 100
IOU1(config-router)#neighbor 3.3.3.3 remote-as 100
IOU1(config-router)#neighbor 2.2.2.2 update-source loopback 0
IOU1(config-router)#neighbor 3.3.3.3 update-source loopback 0
IOU1(config-router)#network 1.1.1.0 mask 255.255.255.0
IOU1(config-router)#no synchronization
IOU1(config-router)#ex

iou2:

IOU2(config)#router bgp 100
IOU2(config-router)#bgp router-id 2.2.2.2
IOU2(config-router)#no synchronization
IOU2(config-router)#neighbor 1.1.1.1 remote-as 100
IOU2(config-router)#neighbor 3.3.3.3 remote-as 100
IOU2(config-router)#neighbor 1.1.1.1 update-source loopback 0
IOU2(config-router)#neighbor 3.3.3.3 update-source loopback 0
IOU2(config-router)#network 2.2.2.0 mask 255.255.255.0
IOU2(config-router)#ex

iou3:

IOU3(config)#router bgp 100
IOU3(config-router)#bgp router-id 3.3.3.3
IOU3(config-router)#no synchronization
IOU3(config-router)#neighbor 1.1.1.1 remote-as 100
IOU3(config-router)#neighbor 2.2.2.2 remote-as 100
IOU3(config-router)#neighbor 4.4.4.4 remote-as 200
IOU3(config-router)#neighbor 1.1.1.1 update-source loopback 0
IOU3(config-router)#neighbor 2.2.2.2 update-source loopback 0
IOU3(config-router)#neighbor 4.4.4.4 update-source loopback 0
IOU3(config-router)#network 3.3.3.0 mask 255.255.255.0
IOU3(config-router)#neighbor 4.4.4.4 ebgp-multihop 2
IOU3(config-router)#ex

iou4:

OU4(config)#router bgp 200
IOU4(config-router)#bgp router-id 4.4.4.4
IOU4(config-router)#neighbor 3.3.3.3 remote-as 100
IOU4(config-router)#no synchronization
IOU4(config-router)#neighbor 3.3.3.3 update-source loopback 0
IOU4(config-router)#neighbor 3.3.3.3 ebgp-multihop 2
IOU4(config-router)#network 4.4.4.0 mask 255.255.255.0
IOU4(config-router)#ex

配置静态/默认路由:

iou3:

IOU3(config)#ip route 4.4.4.4 255.255.255.255 34.34.34.4

iou4:

IOU4(config)#ip route 3.3.3.3 255.255.255.255  34.34.34.3

查看路由表:

            BGP配置实验案例_路由表_02

查看bgp:

iou1:

            BGP配置实验案例_路由表_03

iou2:

            BGP配置实验案例_路由表_04

iou3:

            BGP配置实验案例_ip地址_05

iou4:

            BGP配置实验案例_ip地址_06