实验拓扑图

cisco配置GPE_路由表

地址如图所示

实验步骤

1.配置地址

IOU1

IOU1(config)#interface ethernet 0/0
IOU1(config-if)#duplex full
IOU1(config-if)#ip address 10.10.12.2 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface ethernet 0/1
IOU1(config-if)#duplex full
IOU1(config-if)#ip address 10.10.23.2 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit

IOU2

IOU2(config)#interface ethernet 0/1
IOU2(config-if)#duplex full
IOU2(config-if)#ip address 192.168.1.254 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface ethernet 0/0
IOU2(config-if)#duplex full
IOU2(config-if)#ip address 10.10.12.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit

IOU3

IOU3(config)#interface ethernet 0/1
IOU3(config-if)#duplex fu
IOU3(config-if)#ip address 192.168.2.254 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
IOU3(config)#interface ethernet 0/0
IOU3(config-if)#duplex full
IOU3(config-if)#ip address 10.10.23.1 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit

PC1

IOU4(config)#interface ethernet 0/1
IOU4(config-if)#duplex full
IOU4(config-if)#ip address 192.168.1.1 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.254
IOU4(config)#exit

PC2

IOU5(config)#interface ethernet 0/0
IOU5(config-if)#duplex full
IOU5(config-if)#ip address 192.168.2.1 255.255.255.0
IOU5(config-if)#no shutdown
IOU5(config-if)#exit
IOU5(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.254
IOU5(config)#exit

配置默认路由

IOU2

IOU2(config)#ip route 0.0.0.0 0.0.0.0 10.10.12.2

IOU3

IOU3(config)#ip route 0.0.0.0 0.0.0.0 10.10.23.2

2.配置OSPF协议

IOU2

IOU2(config)#router ospf 1
IOU2(config-router)#network 192.168.1.0 0.0.0.255 area 0
IOU2(config-router)#network 192.168.13.0 0.0.0.255 area 0
IOU2(config-router)#exit

IOU3

IOU3(config)#router ospf 1
IOU3(config-router)#network 192.168.2.0 0.0.0.255 area 0
IOU3(config-router)#network 192.168.13.0 0.0.0.255 area 0
IOU3(config-router)#exit

查看路由表

cisco配置GPE_路由表_02

3.配置GPE

IOU2

IOU2(config)#interface tunnel 0
IOU2(config-if)#tunnel source ethernet 0/0
IOU2(config-if)#tunnel destination 10.10.23.1
IOU2(config-if)#tunnel mode gre ip
IOU2(config-if)#ip address 192.168.13.1 255.255.255.0
IOU2(config-if)#tunnel key 123456
IOU2(config-if)#exit

IOU3

IOU3(config)#interface tunnel 0
IOU3(config-if)#tunnel source ethernet 0/0
IOU3(config-if)#tunnel destination 10.10.12.1
IOU3(config-if)#tunnel mode gre ip
IOU3(config-if)#ip address 192.168.13.2 255.255.255.0
IOU3(config-if)#tunnel key 123456
IOU3(config-if)#exit

查看地址配置

cisco配置GPE_路由表_03

cisco配置GPE_路由表_04

测试能否ping通

cisco配置GPE_路由表_05