实验拓扑

高级交换综合项目_2d

地址规划如图所示


实验要求以及步骤:

一、 安全管理

1. 依据图中拓扑,为全网设备定义主机名、关闭域名解析、并在 Console 和 VTY 线路下关闭线路超时并开启输出同步。

R1配置

IOU1(config)#hostname R1
R1(config)#no ip domain-lookup
R1(config)#line console 0
R1(config-line)#exec-timeout 0 0
R1(config-line)#logging synchronous
R1(config-line)#exit
R1(config)#line vty 0 4
R1(config-line)#exec-timeout 0 0
R1(config-line)#logging synchronous
R1(config-line)#exit

2. 为实现安全远程登录,要求在设备 CS1 上创建本地用户名 bdqn,密码 benet,并只允许 3 个管理员同时远程登录 ,其中管理员地址分别为 192.168.10.1~192.168.10.3;要求只运行 SSH 协议进行登录,并且关闭其他虚拟终端线路。

R1配置

R1(config)#username bdqn privilege 15 password benet
R1(config)#line vty 0 2
R1(config-line)#login local
R1(config-line)#transport input ssh
R1(config-line)#exit
R1(config)#access-list 1 permit 192.168.10.1
R1(config)#access-list 1 permit 192.168.10.2
R1(config)#access-list 1 permit 192.168.10.3
R1(config)#line vty 0 2
R1(config-line)#access-class 1 in
R1(config-line)#exit
R1(config)#line vty 3 4
R1(config-line)#transport input none
R1(config-line)#exit

3. 在设备 CS1 设置 banner。

R1配置

R1(config)#banner login #THLS LS BENETLSB#

4. 在 CS2 上关闭 HTTP 服务,开启 HTTPS 服务并调用本地认证

R1配置

R1(config)#no ip http server 
R1(config)#ip http secure-server

5. 在 R1 的 E0/0 上关闭 CDP 服务

R1配置

R1(config)#no cdp run

6. 汇聚和接入交换机的管理 vlan 为 vlan1, 所在网段为 192.168.1.0/24, 其中 DS1 的管理 IP 为 192.168.1.1/24, DS2 为 192.168.1.2/24, DS3 为 192.168.1.3/24, DS4 为192.168.1.4/24 。 要求二层交换机可以远程管理。

CS1配置

IOU2(config)#interface vlan 1
IOU2(config-if)#ip address 192.168.1.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit

CS2配置

IOU3(config)#interface vlan 1
IOU3(config-if)#ip address 192.168.1.2 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit

DN1配置

IOU4(config)#interface vlan 1
IOU4(config-if)#ip address 192.168.1.3 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#exit

DN2配置

IOU5(config)#interface vlan 1
IOU5(config-if)#ip address 192.168.1.4 255.255.255.0
IOU5(config-if)#no shutdown
IOU5(config-if)#exit

二、 交换技术

1、 Trunk 技术

 DS1、DS2、AS1 交换机之间强制启用 Trunk 并关闭 DTP 协商,并采用 802.1Q 进行封装

所有交换机要求 Trunk 上只允许 VLAN110203040 通过

DS1配置

DS1(config)#interface range ethernet 0/2-3 , ethernet 1/0-1 
DS1(config-if-range)#switchport trunk encapsulation dot1q
DS1(config-if-range)#switchport mode trunk
DS1(config-if-range)#switchport trunk allowed vlan 1,10,20,30,40
DS1(config-if-range)#exit

DS2配置

DS2(config)#interface range ethernet 0/2-3 , ethernet 1/0-1
DS2(config-if-range)#switchport trunk encapsulation dot1q
DS2(config-if-range)#switchport mode trunk
DS2(config-if-range)#switchport trunk allowed vlan 1,10,20,30,40
DS2(config-if-range)#exit

AS1

AS1(config)#interface range ethernet 0/0-1
AS1(config-if-range)#switchport trunk encapsulation dot1q
AS1(config-if-range)#switchport mode trunk
AS1(config-if-range)#switchport trunk allowed vlan 1,10,20,30,40
AS1(config-if-range)#exit

AS2

As2(config)#interface range ethernet 0/0-1
As2(config-if-range)#switchport trunk encapsulation dot1q
As2(config-if-range)#switchport mode trunk
As2(config-if-range)#switchport trunk allowed vlan 1,10,20,30,40
As2(config-if-range)#exit

查看结果

高级交换综合项目_redis_02

2、VTP&VLAN 技术

  •  总部 DS1 和 DS2 均为 Server, 其他交换机为 Client。
  •  总部 VTP 管理域为 bdqn, 密码为 benet。
  • 总部全局开启 VTP 修剪
  • 在 DS1 上创建 VLAN10/20/30/40, 并要求全局同步。
  • 将不同用户接口放入相应的 VLAN 中。

DS1

DS1(config)#vtp domain bdqn
Changing VTP domain name from NULL to bdqn
DS1(config)#vtp mode server
Device mode already VTP Server for VLANS.
DS1(config)#vtp password benet
Setting device VTP password to benet
DS1(config)#vlan 10,20,30,40
DS1(config-vlan)#exit

DS2

DS2(config)#vtp domain bdqn
Domain name already set to bdqn.
DS2(config)#vtp mode server
Device mode already VTP Server for VLANS.
DS2(config)#vtp password benet
Setting device VTP password to benet

AS1

AS1(config)#vtp domain bdqn
Domain name already set to bdqn.
AS1(config)#vtp mode client
Setting device to VTP Client mode for VLANS.
AS1(config)#vtp password benet
Setting device VTP password to benet
AS1(config)#interface e0/2
AS1(config-if)#switchport mode access
AS1(config-if)#switchport access vlan 10
AS1(config-if)#exit
AS1(config)#interface e0/3
AS1(config-if)#switchport mode access
AS1(config-if)#switchport access vlan 20
AS1(config-if)#exit

AS2

As2(config)#vtp domain bdqn
Domain name already set to bdqn.
As2(config)#vtp mode client
Setting device to VTP Client mode for VLANS.
Setting device VTP password to benet
As2(config)#interface e0/2
As2(config-if)#switchport mode ac
As2(config-if)#switchport access vlan 30
As2(config-if)#exit
As2(config)#interface e0/3
As2(config-if)#switchport mode ac
As2(config-if)#switchport access vlan 40
As2(config-if)#exit

查看是否全局同步

高级交换综合项目_2d_03

高级交换综合项目_2d_04

高级交换综合项目_redis_05

查看是否将vlan加入接口

高级交换综合项目_redis_06

高级交换综合项目_2d_07

3、 STP 技术

 部署 MSTP, 全局 MSTP 域为 PL, 修订号为 1, 并创建两个实例, 其中实例 1 映射 10 和 30, 实例 2 映射 20 和 40;

DS1

DS1(config)#spanning-tree mode mst
DS1(config)#spanning-tree mst configuration
DS1(config-mst)#revision 1
DS1(config-mst)#name cisco
DS1(config-mst)#instance 1 vlan 10,30
DS1(config-mst)#instance 2 vlan 20,40
DS1(config-mst)#exit

DS2

DS2(config)#spanning-tree mode mst
DS2(config)#spanning-tree mst configuration
DS2(config-mst)#revision 1
DS2(config-mst)#name cisco
DS2(config-mst)#instance 1 vlan 10,30
DS2(config-mst)#instance 2 vlan 20,40

AS1

AS1(config)#spanning-tree mode mst 
AS1(config)#spanning-tree mst configuration
AS1(config-mst)#revision 1
AS1(config-mst)#name cisco
AS1(config-mst)#instance 1 vlan 10,30
AS1(config-mst)#instance 2 vlan 20,40
AS1(config-mst)#exit

AS2

As2(config)#spanning-tree mode mst 
As2(config)#spanning-tree mst configuration
As2(config-mst)#revision 1
As2(config-mst)#name cisco
As2(config-mst)#instance 1 vlan 10,30
As2(config-mst)#instance 2 vlan 20,40
As2(config-mst)#exit

要求 DS1 为实例 1 的主根, 实例 2 的备根; DS2 为实例 1 的备根, 实例 2 的主根

DS1配置

DS1(config)#spanning-tree mst 1 root primary 
DS1(config)#spanning-tree mst 2 root secondary

DS2配置

DS2(config)#spanning-tree mst 1 root secondary 
DS2(config)#spanning-tree mst 2 root primary

在接入层交换机上开启 BPDU 防护, 当违反规则时, 要求 30S 后恢复

AS1

AS1(config)#interface range ethernet 0/2-3
AS1(config-if-range)#spanning-tree bpduguard enable
AS1(config-if-range)#exit
AS1(config)#errdisable recovery cause bpduguard
AS1(config)#errdisable recovery interval 30
AS1(config)#

AS2

AS2(config)#interface range ethernet 0/2-3
AS2(config-if-range)#spanning-tree bpduguard enable
AS2(config-if-range)#exit
AS2(config)#errdisable recovery cause bpduguard
AS2(config)#errdisable recovery interval 30
AS2(config)#

4、 HSRP 技术

部署 HSRP 技术,要求 DS1 作为 VLAN10/30 的主网关,VLAN20/40 的备网关,DS2其中网关地址如下:

  • VLAN10, 主 192.168.10.252/24, 备 192.168.10.253/24, 虚 192.168.10.254/24
  • VLAN20, 主 192.168.20.252/24, 备 192.168.20.253/24, 虚 192.168.20.254/24 
  • VLAN30, 主 192.168.30.252/24, 备 192.168.30.253/24, 虚 192.168.20.254/24
  • VLAN40, 主 192.168.40.252/24, 备 192.168.40.253/24, 虚 192.168.20.254/24

DS1

DS1(config)#interface vlan 10                  
DS1(config-if)#ip address 192.168.10.252 255.255.255.0
DS1(config-if)#standby 10 ip 192.168.10.254
DS1(config-if)#standby 10 priority 110
DS1(config-if)#standby 10 preempt
DS1(config-if)#no shutdown
DS1(config-if)#exit
DS1(config)#interface vlan 20
DS1(config-if)#ip address 192.168.20.252 255.255.255.0
DS1(config-if)#standby 20 ip 192.168.20.254
DS1(config-if)#standby 20 priority 90
DS1(config-if)#standby 20 preempt
DS1(config-if)#no shutdown
DS1(config-if)#exit
DS1(config)#interface vlan 30
DS1(config-if)#ip address 192.168.30.252 255.255.255.0
DS1(config-if)#standby 30 priority 110
DS1(config-if)#standby 30 preempt
DS1(config-if)#no shutdown
DS1(config-if)#exit
DS1(config)#interface vlan 40
DS1(config-if)#ip address 192.168.40.252 255.255.255.0
DS1(config-if)#standby 40 ip 192.168.40.254
DS1(config-if)#standby 40 priority 90
DS1(config-if)#standby 40 preempt
DS1(config-if)#no shutdown
DS1(config-if)#exit

DS2

DS2(config)#interface vlan 10
DS2(config-if)#ip address 192.168.10.253 255.255.255.0
DS2(config-if)#standby 10 ip 192.168.10.254
DS2(config-if)#standby priority 90
DS2(config-if)#standby preempt
DS2(config-if)#no shutdown
DS2(config-if)#exit
DS2(config)#interface vlan 20
DS2(config-if)#ip address 192.168.20.253 255.255.255.0
DS2(config-if)#standby 20 priority 110
DS2(config-if)#standby 20 preempt
DS2(config-if)#no shutdown
DS2(config-if)#exit
DS2(config)#interface vlan 30
DS2(config-if)#ip address 192.168.30.253 255.255.255.0
DS2(config-if)#standby 30 ip 192.168.30.254
DS2(config-if)#standby 30 priority 90
DS2(config-if)#standby preempt
DS2(config-if)#no shutdown
DS2(config-if)#exit
DS2(config)#interface vlan 40
DS2(config-if)#ip address 192.168.40.253 255.255.255.0
DS2(config-if)#standby 40 ip 192.168.40.254
DS2(config-if)#standby 40 priority 110
DS2(config-if)#standby 40 preempt
DS2(config-if)#no shutdown
DS2(config-if)#exit

查看配置结果

高级交换综合项目_redis_08

高级交换综合项目_路由表_09

5、 DHCP Relay 技术

在 R1 上同时部署 DHCP 服务, 方便不同 VLAN 的主机接入网络,其中主 DNS 为8.8.8.8, 备用 DNS 为 114.114.114.114。

R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#exit
R1(config)#ip dhcp pool vlan10
R1(dhcp-config)#network 192.168.10.0 /24
R1(dhcp-config)#default-router 192.168.10.254
R1(dhcp-config)#dns-server 8.8.8.8
R1(dhcp-config)#exit
R1(config)#ip dhcp pool vlan20
R1(dhcp-config)#network 192.168.20.0 /24
R1(dhcp-config)#default-router 192.168.20.254
R1(dhcp-config)#dns-server 8.8.8.8
R1(dhcp-config)#exit
R1(config)#ip dhcp pool vlan30
R1(dhcp-config)#network 192.168.30.0 /24
R1(dhcp-config)#default-router 192.168.30.254
R1(dhcp-config)#dns-server 8.8.8.8
R1(dhcp-config)#exit
R1(config)#ip dhcp pool vlan40
R1(dhcp-config)#network 192.168.40.0 /24
R1(dhcp-config)#default-router 192.168.40.254
R1(dhcp-config)#dns-server 8.8.8.8
R1(dhcp-config)#exit

在 DS1 和 DS2 上部署 DHCP 中继技术。

DS1

DS1(config)#interface vlan 10
DS1(config-if)#ip helper-address 1.1.1.1
DS1(config-if)#exit
DS1(config)#interface vlan 20
DS1(config-if)#ip helper-address 1.1.1.1
DS1(config-if)#exit
DS1(config)#interface vlan 30
DS1(config-if)#ip helper-address 1.1.1.1
DS1(config-if)#exit
DS1(config)#interface vlan 40
DS1(config-if)#ip helper-address 1.1.1.1
DS1(config-if)#exit

DS2

DS2(config)#interface vlan 10
DS2(config-if)#ip helper-address 1.1.1.1
DS2(config-if)#exit
DS2(config)#interface vlan 20
DS2(config-if)#ip helper-address 1.1.1.1
DS2(config-if)#exit
DS2(config)#interface vlan 30
DS2(config-if)#ip helper-address 1.1.1.1
DS2(config-if)#exit
DS2(config)#interface vlan 40
DS2(config-if)#ip helper-address 1.1.1.1
DS2(config-if)#exit

6、 Etherchannel 技术

为实现链路冗余并提供网络带宽,要求在汇聚层交换机之间部署 L2 Etherchannel 技术,在核心交换机之间部署 L3 Etherchannel

CS1

CS1(config)#interface range ethernet 0/1-2
CS1(config-if-range)#no switchport
CS1(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1
CS1(config)#interface port-channel 1
CS1(config-if)#no switchport
CS1(config-if)#exit
CS1(config)#interface port-channel 1
CS1(config-if)#ip address 172.16.23.1 255.255.255.0
CS1(config-if)#no shutdown
CS1(config-if)#exit

CS2

CS2(config)#interface range ethernet 0/1-2
CS2(config-if-range)#no switchport
CS2(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1
CS2(config-if-range)#exit
CS2(config)#interface port-channel 1
CS2(config-if)#ip address 172.16.23.2 255.255.255.0
CS2(config-if)#no shutdown
CS2(config-if)#exit

查看地址配置

高级交换综合项目_2d_10

高级交换综合项目_2d_11

7、 Port-Security 技术

  • 为实现用户接入安全,要求在所有用户接入接口启用端口安全技术。
  • 开启地址学习,并定义最大 MAC 数为 1。
  • 定义用户违反规则为 shutdown 模式,并要求在 30s 后自动恢复。

AS1​

AS1(config)#interface range ethernet 0/2-3
AS1(config-if-range)#switchport port-security
AS1(config-if-range)#switchport port-security mac-address sticky
AS1(config-if-range)#switchport port-security maximum 2
AS1(config-if-range)#switchport port-security violation shutdown
AS1(config-if-range)#exite
AS1(config)#errdisable recovery cause psecure-violation
AS1(config)#errdisable recovery interval 30
AS1(config)#exit

AS2

AS2(config)#interface range ethernet 0/2-3
AS2(config-if-range)#switchport port-security mac-address sticky
AS2(config-if-range)#switchport port-security maximum 2
AS2(config-if-range)#switchport port-security violation shutdown
AS2(config-if-range)#exit
AS2(config)#errdisable recovery cause psecure-violation
AS2(config)#errdisable recovery interval 30
AS2(config)#exit

8、 DHCP Snooping 技术

在 AS1 上部署 DHCP 侦听技术, 防止 DHCP 欺骗

AS1

AS1(config)#ip dhcp snooping 
AS1(config)#ip dhcp snooping vlan 10 20
AS1(config)#interface range ethernet 0/0-1
AS1(config-if-range)#ip dhcp snooping trust
AS1(config-if-range)#exit

AS2

AS2(config)#ip dhcp snooping 
AS2(config)#ip dhcp snooping vlan 30 40
AS2(config)#interface range ethernet 0/0-1
AS2(config-if-range)#ip dhcp snooping trust
AS2(config-if-range)#exit

查看是否能自动拿到地址

高级交换综合项目_2d_12

高级交换综合项目_redis_13

三、 路由技术

在全网所有三层设备部署动态路由协议 OSPF, 其中 R1、 CS1、 CS2 通告到骨干区域中, CS1、 CS2、 DS1 通告到区域 10 中, CS1、 CS2、 DS2 通告到区域 20 中。

  • 要求 VLAN10 和 VLAN30 的流量路径是: DS1—>CS1—>R1, 并且当 CS1 出现故障后, 流量路径切换为 DS1—>CS2—>R1
  • 要求 VLAN20 和 VLAN40 的流量路径是: DS2—>CS2—>R1, 并且当 CS2 出现故障后, 流量路径切换为 DS2—>CS1—>R1
  • 在 R1 上创建环回接口 Lo1, 地址为 1.1.1.1/32, 要求全网能与之通信

配置地址

R1

R1(config)#interface ethernet 0/0
R1(config-if)#duplex full
R1(config-if)#ip address 172.16.12.2 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface ethernet 0/1
R1(config-if)#duplex full
R1(config-if)#ip address 172.16.13.2 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

CS1

CS1(config)#interface e0/0
CS1(config-if)#no switchpo
CS1(config-if)#ip address 172.16.12.1 255.255.255.0
CS1(config-if)#no shutdown
CS1(config-if)#exit
CS1(config)#interface e0/3
CS1(config-if)#no switchport
CS1(config-if)#ip address 172.16.24.1 255.255.255.0
CS1(config-if)#no shutdown
CS1(config-if)#exit
CS1(config)#interface e1/0
CS1(config-if)#no switchport
CS1(config-if)#ip address 172.16.25.1 255.255.255.0
CS1(config-if)#no shutdown
CS1(config-if)#exit

CS2

CS2(config)#interface e0/0
CS2(config-if)#no switchport
CS2(config-if)#ip address 172.16.13.1 255.255.255.0
CS2(config-if)#no shutdown
CS2(config-if)#exit
CS2(config)#interface e0/3
CS2(config-if)#no switchport
CS2(config-if)#ip address 172.16.35.1 255.255.255.0
CS2(config-if)#no shutdown
CS2(config-if)#exit
CS2(config-if)#interface e1/0
CS2(config-if)#no switchport
CS2(config-if)#ip address 172.16.34.1 255.255.255.0
CS2(config-if)#no shutdown
CS2(config-if)#exit

DS1

DS1(config)#interface e0/1
DS1(config-if)#no switchport
DS1(config-if)#ip address 172.16.34.2 255.255.255.0
DS1(config-if)#no shutdown
DS1(config-if)#exit
DS1(config)#interface e0/0
DS1(config-if)#no switchport
DS1(config-if)#ip address 172.16.24.2 255.255.255.0
DS1(config-if)#no shutdown
DS1(config-if)#exit

DS2

DS2(config)#interface e0/0
DS2(config-if)#no switchport
DS2(config-if)#ip address 172.16.35.2 255.255.255.0
DS2(config-if)#no shutdown
DS2(config-if)#exit
DS2(config)#interface e0/1
DS2(config-if)#no switchport
DS2(config-if)#ip address 172.16.25.2 255.255.255.0
DS2(config-if)#no shutdown
DS2(config-if)#exit

R1

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 172.16.12.0 0.0.0.255 area 0
R1(config-router)#network 172.16.13.0 0.0.0.255 area 0
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
R1(config-router)#exit

CS1

CS1(config)#router ospf 1
CS1(config-router)#router-id 2.2.2.2
CS1(config-router)#network 172.16.12.0 0.0.0.255 area 0
CS1(config-router)#network 172.16.23.0 0.0.0.255 area 0
CS1(config-router)#network 172.16.24.0 0.0.0.255 area 10
CS1(config-router)#network 172.16.25.0 0.0.0.255 area 20
CS1(config-router)#

CS2

CS2(config)#router ospf 1
CS2(config-router)#router-id 3.3.3.3
CS2(config-router)#network 172.16.13.0 0.0.0.255 area 0
CS2(config-router)#network 172.16.23.0 0.0.0.255 area 0
CS2(config-router)#network 172.16.35.0 0.0.0.255 area 20
CS2(config-router)#network 172.16.34.0 0.0.0.255 area 10

DS1

DS1(config)#router ospf 1
DS1(config-router)#router-id 4.4.4.4
DS1(config-router)#network 172.16.24.0 0.0.0.255 area 10
DS1(config-router)#network 172.16.34.0 0.0.0.255 area 10
DS1(config-router)#redistribute connected subnets
DS1(config-router)#

DS2

DS2(config)#router ospf 1
DS2(config-router)#router-id 5.5.5.5
DS2(config-router)#network 172.16.35.0 0.0.0.255 area 20
DS2(config-router)#network 172.16.25.0 0.0.0.255 area 20
DS2(config)#router ospf 1
DS2(config-router)#redistribute connected subnets
DS2(config-router)#exit

查看路由表

高级交换综合项目_redis_14

配置默认路由

R1(config)#router ospf 1
R1(config-router)#default-information originate always

查看路由表

高级交换综合项目_路由表_15

测试结果

高级交换综合项目_路由表_16