虚链路_链路

IOU1

OU1(config)#interface ethernet 0/0
IOU1(config-if)#ip add 10.0.12.2 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#ex
IOU1(config)#interface ethernet 0/1
IOU1(config-if)#ip add 10.0.14.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#ex
IOU1(config)#interface loopback 0
IOU1(config-if)#ip add 1.1.1.1 255.255.255.255
IOU1(config-if)#no shutdown
IOU1(config-if)#ex

IOU2

IOU2(config)#interface ethernet 0/0
IOU2(config-if)#ip add 10.0.12.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#ex
IOU2(config)#interface ethernet 0/1
IOU2(config-if)#ip add 10.0.23.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#ex
IOU2(config)#interface loopback 0
IOU2(config-if)#ip add 2.2.2.2 255.255.255.255
IOU2(config-if)#no shutdown
IOU2(config-if)#ex

IOU3

IOU3(config)#interface ethernet 0/1
IOU3(config-if)#ip add 10.0.23.2 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#ex
IOU3(config)#interface loopback 0
IOU3(config-if)#ip add 3.3.3.3 255.255.255.255
IOU3(config-if)#no shutdown
IOU3(config-if)#ex

IOU4

IOU4(config)#interface et 0/1
IOU4(config-if)#ip add 10.0.14.2 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#ex
IOU4(config)#interface loopback 0
IOU4(config-if)#ip add 4.4.4.4 255.255.255.255
IOU4(config-if)#no shutdown
IOU4(config-if)#ex

OSPF配置

IOU1

IOU1(config)#router ospf 1
IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 1
IOU1(config-router)#network 10.0.12.0 0.0.0.255 area 1
IOU1(config-router)#network 10.0.14.0 0.0.0.255 area 0
IOU1(config-router)#ex

IOU2

IOU2(config)#router ospf 1
IOU2(config-router)#network 2.2.2.2 0.0.0.0 area 1
IOU2(config-router)#network 10.0.12.0 0.0.0.255 area 1
IOU2(config-router)#network 10.0.23.0 0.0.0.255 area 2
IOU2(config-router)#ex

IOU3

IOU3(config)#router ospf 1
IOU3(config-router)#network 10.0.23.0 0.0.0.255 area 2
IOU3(config-router)#network 3.3.3.3 0.0.0.0 area 2

IOU4

IOU4(config)#router ospf 1 
IOU4(config-router)#network 4.4.4.4 0.0.0.0 area 0
IOU4(config-router)#network 10.0.14.0 0.0.0.255 area 0

虚链路

IOU1

IOU1(config)#router ospf 1
IOU1(config-router)#area 1 virtual-link 2.2.2.2

IOU2

IOU2(config)#router ospf 1
IOU2(config-router)#area 1 virtual-link 1.1.1.1

IOU1ping通

虚链路_链路_02

IOU2ping通

虚链路_链路_03