拓扑如下:

OSPF配置NAAT区域,地址汇总_ip地址

配置命令如下:

一,配置IP地址

IOU1(config)#interface ethernet 0/0
IOU1(config-if)#duplex full
IOU1(config-if)#ip add 10.0.12.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface ethernet 0/0
IOU1(config-if)#duplex full
IOU1(config-if)#ip address 10.0.77.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#interface loopback 0
IOU1(config-if)#ip addr 1.1.1.1 255.255.255.255
IOU1(config-if)#exit
IOU2(config)#interface ethernet 0/0
IOU2(config-if)#duplex full
IOU2(config-if)#ip address 10.0.12.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface ethernet 0/1
IOU2(config-if)#duplex full
IOU2(config-if)#ip addr 10.0.23.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface ethernet 0/2
IOU2(config-if)#duplex full
IOU2(config-if)#ip address 10.0.56.1 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#interface loopback 0
IOU2(config-if)#ip address 2.2.2.2 255.255.255.255
IOU2(config-if)#exit
IOU3(config)#interface ethernet 0/0
IOU3(config-if)#duplex full
IOU3(config-if)#ip addr 10.0.23.2 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
IOU3(config)#interface ethernet 0/1
IOU3(config-if)#ip address 10.0.34.1 255.255.255.0
IOU3(config-if)#no shutdown
IOU3(config-if)#exit
IOU3(config)#interface loopback 0
IOU3(config-if)#ip addr 3.3.3.3 255.255.255.255
IOU3(config-if)#exit
IOU4(config)#interface ethernet 0/0
IOU4(config-if)#duplex full
IOU4(config-if)#ip address 10.0.34.2 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#interface ethernet 0/1
IOU4(config-if)#duplex full
IOU4(config-if)#ip addr 10.0.45.1 255.255.255.0
IOU4(config-if)#no shutdown
IOU4(config-if)#exit
IOU4(config)#interface loopback 0
IOU4(config-if)#ip address 4.4.4.4 255.255.255.255
IOU4(config-if)#exit
IOU5(config)#interface ethernet 0/0
IOU5(config-if)#duplex full
IOU5(config-if)#ip addr 10.0.56.2 255.255.255.0
IOU5(config-if)#no shutdown
IOU5(config-if)#exit
IOU5(config)#interface ethernet 0/1
IOU5(config-if)#duplex full
IOU5(config-if)#ip addr 10.0.66.1 255.255.255.0
IOU5(config-if)#no shutdown
IOU5(config-if)#exit
IOU5(config)#interface loopback 0
IOU5(config-if)#ip addr 5.5.5.5 255.255.255.255
IOU5(config-if)#exit
IOU6(config)#interface ethernet 0/0
IOU6(config-if)#duplex full
IOU6(config-if)#ip addr 10.0.66.2 255.255.255.0
IOU6(config-if)#no shutdown
IOU6(config-if)#exit
IOU6(config)#interface loopback 0
IOU6(config-if)#ip address 6.6.6.6 255.255.255.0
IOU6(config-if)#exit
IOU7(config)#interface ethernet 0/0
IOU7(config-if)#duplex full
IOU7(config-if)#ip address 10.0.45.2 255.255.255.0
IOU7(config-if)#no shutdown
IOU7(config-if)#exit
IOU7(config)#interface loopback 0
IOU7(config-if)#ip addr 172.16.2.1 255.255.255.255
IOU7(config-if)#exit
IOU7(config)#interface loopback 1
IOU7(config-if)#ip addr 172.168.2.2 255.255.255.255
IOU7(config-if)#exit
IOU7(config)#interface loopback 2
IOU7(config-if)#ip addr 172.168.2.3 255.255.255.255
IOU7(config-if)#exit
IOU7(config)#interface loopback 3
IOU7(config-if)#ip addr 172.16.2.3 255.255.255.255
IOU7(config-if)#exit
IOU8(config)#interface ethernet 0/0
IOU8(config-if)#no switchport
IOU8(config-if)#ip addres 10.0.77.2 255.255.255.0
IOU8(config-if)#no shutdown
IOU8(config-if)#exit
IOU8(config)#interface ethernet 0/1
IOU8(config-if)#switchport trunk encapsulation dot1q
IOU8(config-if)#switchport mode trunk
IOU8(config-if)#exit
IOU8(config)#vlan 10,20,30,40
IOU8(config-vlan)#exit
IOU8(config)#interface vlan 10
IOU8(config-if)#ip address 172.16.1.1 255.255.255.0
IOU8(config-if)#no shutdown
IOU8(config-if)#exit
IOU8(config)#interface vlan 20
IOU8(config-if)#ip address 172.16.2.1 255.255.255.0
IOU8(config-if)#no shutdown
IOU8(config-if)#exit
IOU8(config)#interface vlan 30
IOU8(config-if)#ip addr 172.16.3.1 255.255.255.0
IOU8(config-if)#no shutdown
IOU8(config-if)#exit
IOU8(config)#interface vlan 40
IOU8(config-if)#ip addr 172.16.4.1 255.255.255.0
IOU8(config-if)#no shutdown
IOU8(config-if)#exit
IOU9(config)#interface e0/0       
IOU9(config-if)#switchport trunk encapsulation dot1q
IOU9(config-if)#switchport mode trunk
IOU9(config-if)#exit

二,配置OSPF和RIP

IOU1(config)#router ospf 1
IOU1(config-router)#network 10.0.77.0 0.0.0.255 area 1
IOU1(config-router)#network 10.0.12.0 0.0.0.255 area 1
IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 1
IOU1(config-router)#exit
IOU2(config)#router ospf 1
IOU2(config-router)#network 10.0.12.0 0.0.0.255 area 1
IOU2(config-router)#network 10.0.23.0 0.0.0.255 area 0
IOU2(config-router)#network 10.0.56.0 0.0.0.255 area 3
IOU2(config-router)#network 2.2.2.2 0.0.0.0 area 0
IOU2(config-router)#exit
IOU2(config)#router ospf 1
IOU2(config-router)#area 3 nssa
IOU2(config-router)#exit
IOU2(config)#router ospf 1
IOU2(config-router)#area 1 range 172.16.0.0 255.255.224.0
IOU2(config-router)#exit
IOU3(config)#router ospf 1
IOU3(config-router)#network 10.0.23.0 0.0.0.255 area 0
IOU3(config-router)#network 10.0.34.0 0.0.0.255 area 2
IOU3(config-router)#network 3.3.3.3 0.0.0.0 area 0
IOU3(config-router)#exit
IOU4(config)#router ospf 1
IOU4(config-router)#network 10.0.34.0 0.0.0.255 area 2
IOU4(config-router)#network 4.4.4.4 0.0.0.0 area 2
IOU4(config-router)#exit
IOU4(config)#router rip
IOU4(config-router)#no auto-summary
IOU4(config-router)#network 10.0.45.0
IOU4(config-router)#
IOU4(config)#router ospf 1
IOU4(config-router)#redistribute rip metric 20 subnets
IOU4(config-router)#exit
IOU4(config)#router rip
IOU4(config-router)#redistribute ospf 1 metric 5
IOU4(config-router)#exit
IOU5(config)#router ospf 1
IOU5(config-router)#network 10.0.56.0 0.0.0.255 area 3
IOU5(config-router)#network 5.5.5.5 0.0.0.0 area 3
IOU5(config-router)#exit
IOU5(config)#router rip
IOU5(config-router)#version 2
IOU5(config-router)#no auto-summary
IOU5(config-router)#network 10.0.66.0
IOU5(config-router)#exit
IOU5(config)#router ospf 1
IOU5(config-router)#redistribute rip metric 20 subnets
IOU5(config-router)#exit
IOU5(config)#router rip
IOU5(config-router)#redistribute ospf 1 metric 5
IOU5(config-router)#exit
IOU5(config)#router ospf 1
IOU5(config-router)#area 3 nssa
IOU5(config-router)#exit
IOU6(config)#router rip
IOU6(config-router)#version 2
IOU6(config-router)#no auto-summary
IOU6(config-router)#network 10.0.66.0
IOU6(config-router)#exit
IOU7(config)#router rip 
IOU7(config-router)#version 2
IOU7(config-router)#no auto-summary
IOU7(config-router)#network 10.0.45.0
IOU7(config-router)#exit
IOU7(config)#router rip
IOU7(config-router)#network 172.16.2.1
IOU7(config-router)#network 172.16.2.2
IOU7(config-router)#network 172.16.2.3
IOU7(config-router)#network 172.16.2.4
IOU7(config-router)#exit
IOU8(config)#router ospf 1
IOU8(config-router)#network 10.0.77.0 0.0.0.255 area 1
IOU8(config-router)#network 172.16.1.1 0.0.0.0 area 1
IOU8(config-router)#network 172.16.2.1 0.0.0.0 area 1
IOU8(config-router)#network 172.16.3.1 0.0.0.0 area 1
IOU8(config-router)#network 172.16.4.1 0.0.0.0 area 1
IOU8(config-router)#exit

三,测试

IOU2# ping 2.2.2.2