实验需求

实验使用网段192.168.10.0/24分配IP地址,划分vlan 10~13,每个vlan不超过50台主机,配置MSTP协议实现负载均衡、配置VRRP协议实现网关备份,使用静态路由实现全网互通,在路由器上配置DHCP分发IP地址
实验目的
1、掌握子网划分
2、掌握MSTP协议配置及使用场景
3、掌握VRRP协议配置及使用场景
4、掌握DHCP服务器及中继配置
5、掌握静态路由器的配置及使用场景


cisco MSTP+VRRP+静态路由+子网划分+DHCP综合实验 _优先级

ip地址规划

    IOU1
e0/0:172.16.1.2/24
e0/1:172.16.2.2/24
loo0: 1.1.1.1/32
    SW1
vlan10:192.168.10.60/26
vlan11:192.168.10.124/26
vlan12:192.168.10.188/26
vlan13:192.168.10.252/26
vip:192.168.10.62
vip:192.168.10.126
vip:192.168.10.190
vip:192.168.10.254
    SW2
vlan10:192.168.10.61/26
vlan11:192.168.10.125/26
vlan12:192.168.10.189/26
vlan13:192.168.10.253/26
vip:192.168.10.62
vip:192.168.10.126
vip:192.168.10.190
vip:192.168.10.254


iou1配置:

interface ethernet 0/0  //进入0/0接口

duplex full //全双工

ip address 172.16.1.2 255.255.255.0 //指定IP

no shutdown   //开启接口

interface ethernet 0/1  //进入0/1接口

duplex full //全双工

ip address 172.16.2.2 255.255.255.0 //指定IP

no shutdown   //开启接口

interface loopback 0   //进入本地接口

ip address 1.1.1.1 255.255.255.255    //指定Ip

no shutdown  //开启接口


ip route 192.168.10.0 255.255.255.128 172.16.1.1

ip route 192.168.10.128 255.255.255.128 172.16.2.1

ip route 192.168.10.0 255.255.255.128 172.16.2.1 11  //配置浮动路由

ip route 192.168.10.128 255.255.255.128 172.16.1.1  11


ip dhcp pool vlan10        //创建名为vlan10的地址池

network 192.168.10.0        // 网段

default-router 192.168.10.62         //默认网关

dns-server 8.8.8.8         //dns服务器地址

ip dhcp pool vlan11         //创建名为vlan11的地址池

network 192.168.10.64         // 网段

default-router 192.168.10.126       //默认网关

dns-server 8.8.8.8          //dns服务器地址

ip dhcp pool vlan12        //创建名为vlan12的地址池

network 192.168.10.128         // 网段

default-router 192.168.10.190         //默认网关

dns-server 8.8.8.8               //dns服务器地址

ip dhcp pool vlan13           //创建名为vlan13的地址池

network 192.168.10.192           // 网段

default-router 192.168.10.254     //默认网关

dns-server 8.8.8.8        //dns服务器地址

iou2:

interface range ethernet 0/0-2

switchport trunk encapsulation dolt1q  // 0/0-2接口配置封装

switchport mode trunk    //配置trunk模式


interface range ethernet  0/0-1

channel-group 1 mode on      //捆绑以太网通道

interface port-channel 1      //进入以太网链路

switchport trunk encapsulation dolt1q        // 配置封装

switchport mode trunk    //配置trunk模式

ex         //退出


vlan 10-13    //创建vlan10到13


spanning-tree mode mst       //更改为MST模式

spanning-tree mst configuration      //进入MST工作模式

name cisco                 //取名Cisco

revision 1                   //等级1

instance 1 vlan 10,11        

instance 2 vlan 12,13


spanning-tree mst 1 root primary         //指定为mst1的根网桥

spanning-tree mst 2 root secondary   //指定为mst2的非根网桥


interface vlan 10             //进入vlan 10

ip address 192.168.10.60 255.255.255.192              //设置IP地址

no shutdown       //关闭接口

vrrp 10 ip 192.168.10.62         // 指定虚拟网关

vrrp 10 priority 110           //指定优先级

vrrp 10 preempt        //抢占


track 100 interface ethernet 0/3 line-protocol         //跟踪端口0/3

interface vlan 10             //进入vlan 10

vrrp 10 track 100 decrement 30         //指定减少优先级


interface vlan 11            //进入vlan 11

ip address 192.168.10.124 255.255.255.192              //设置IP地址

vrrp 11 ip 192.168.10.126         // 指定虚拟网关

vrrp 11 priority 110           //指定优先级

vrrp 11 preempt        //抢占

vrrp 11 track 100 decrement 30         //指定减少优先级

no shutdown       //关闭接口


interface vlan 12            //进入vlan 12

ip address 192.168.10.188 255.255.255.192              //设置IP地址

vrrp 12 ip 192.168.10.190         // 指定虚拟网关

vrrp 12 priority 90           //指定优先级

vrrp 12 preempt        //抢占

no shutdown       //开启接口


interface vlan 13           //进入vlan 13

ip address 192.168.10.252 255.255.255.192              //设置IP地址

vrrp 13 ip 192.168.10.254         // 指定虚拟网关

vrrp 13 priority 90           //指定优先级

vrrp 13 preempt        //抢占

no shutdown       //开启接口


interface ethernet 0/3  //进入0/3接口

no switchport  //关闭路由功能

ip address 172.16.1.1 255.255.255.0  //指定IP

no shutdown //开启接口


ip route 0.0.0.0 0.0.0.0 172.16.1.2    //配置默认路由


interface vlan 10

ip helper-address 1.1.1.1  //dhcp中继

interface vlan 11

ip helper-address 1.1.1.1  //dhcp中继

interface vlan 12

ip helper-address 1.1.1.1  //dhcp中继

interface vlan 13

ip helper-address 1.1.1.1  //dhcp中继

iou3

interface range ethernet 0/0-2

switchport trunk encapsulation dolt1q  // 0/0-2接口配置封装

switchport mode trunk    //配置trunk模式


interface range ethernet  0/0-1

channel-group 1 mode on      //捆绑以太网通道

interface port-channel 1      //进入以太网链路

switchport trunk encapsulation dolt1q        // 配置封装

switchport mode trunk    //配置trunk模式

ex         //退出


vlan 10-13    //创建vlan10到13


spanning-tree mode mst                //更改为MST模式

spanning-tree mst configuration              //进入MST工作模式

name cisco                //取名Cisco

revision 1                  //等级1

instance 1 vlan 10,11

instance 2 vlan 12,13


spanning-tree mst 1 root secondary        //指定为mst1的非根网桥

spanning-tree mst 2 root primary   //指定为mst2的根网桥


interface vlan 12             //进入vlan 12

ip address 192.168.10.189 255.255.255.192              //设置IP地址

no shutdown       //关闭接口

vrrp 12 ip 192.168.10.190         // 指定虚拟网关

vrrp 12 priority 110           //指定优先级

vrrp 12 preempt        //抢占


track 100 interface ethernet 0/3 line-protocol         //跟踪端口0/3

interface vlan 12             //进入vlan 12

vrrp 10 track 100 decrement 30         //指定减少优先级


interface vlan 13            //进入vlan 13

ip address 192.168.10.253 255.255.255.192              //设置IP地址

vrrp 13 ip 192.168.10.254         // 指定虚拟网关

vrrp 13 priority 110           //指定优先级

vrrp 13 preempt        //抢占

vrrp 13 track 100 decrement 30         //指定减少优先级

no shutdown       //关闭接口


interface vlan 11           //进入vlan 11

ip address 192.168.10.125 255.255.255.192              //设置IP地址

vrrp 11 ip 192.168.10.126         // 指定虚拟网关

vrrp 11 priority 90           //指定优先级

vrrp 11 preempt        //抢占

no shutdown       //关闭接口


interface vlan 10           //进入vlan 10

ip address 192.168.10.61 255.255.255.192              //设置IP地址

vrrp 10 ip 192.168.10.62         // 指定虚拟网关

vrrp 10 priority 90           //指定优先级

vrrp 10 preempt        //抢占

no shutdown       //关闭接口


interface ethernet 0/3  //进入0/3接口

no switchport  //关闭路由功能

ip address 172.16.2.1 255.255.255.0  //指定IP

no shutdown //开启接口


ip route 0.0.0.0 0.0.0.0 172.16.2.2   //配置默认路由

show ip route   //查看路由表


interface vlan 10

ip helper-address 1.1.1.1  //dhcp中继

interface vlan 11

ip helper-address 1.1.1.1  //dhcp中继

interface vlan 12

ip helper-address 1.1.1.1  //dhcp中继

interface vlan 13

ip helper-address 1.1.1.1  //dhcp中继

iou4

interface range ethernet 0/0-1

switchport trunk encapsulation dolt1q  // 0/0-2接口配置封装

switchport mode trunk    //配置trunk模式


vlan 10-13    //创建vlan10到13


spanning-tree mode mst             //更改为MST模式

spanning-tree mst configuration             //进入MST工作模式

name cisco                 //取名Cisco

revision 1               //等级1

instance 1 vlan 10,11

instance 2 vlan 12,13


#show spanning-tree mst 1


interface ethernet 0/2

switchport mode access   //配置接入

switchport access vlan 10    //加入vlan10

interface ethernet 0/3

switchport mode access   //配置接入

switchport access vlan 11    //加入vlan11

interface ethernet 1/0

switchport mode access   //配置接入

switchport access vlan 12    //加入vlan12

interface ethernet 1/1

switchport mode access   //配置接入

switchport access vlan 13    //加入vlan13