OSPF LSA的详细概述

原理概述:

OSPF是一种基于链路状态的动态路由协议,每台 OSPF 路由器都会生成相关的LSA,并将这些LSA通告出去。路由器收到LSA后,会将它们存放在链路状态数据库LSDB中。

LSA有多种不同的类型,不同类型的LSA的功能和作用是不同的,下面介绍几种常见的LSA:

Type-1 LSA(Router LSA):每台路由器都会产生,用来描述路由器的直连链路状态和开销值。Type-1 LSA只能在所属区域内部泛洪,不能泛洪到其他区域。

Type-2 LSA(Network LSA):它是DR产生的,主要用来描述该DR所在网段的网络掩码以及该网段内有那些路由器。Type-2 LSA只能在所属区域内部泛洪,不能泛洪到其他区域。

Type-3 LSA(Network Summary LSA);它是由ABR(Area Boundary Router)产生的,ABR路由器将所连区域的Type-1和Type-2 LSA 转换为 Type-3 LSA,用来描述区域间的路由信息。Type-3 LSA可以泛洪到整个AS(Autonomous System,自治域)内部,但不能泛洪到Totally Stub区域和Totally NSSA(Not-So-Stubby Area)区域。

Type-4 LSA(ASBR Summary LSA);它是由ASBR(Autonomous System Boundary Router)所在区域的ABR产生的,用来描述到ASBR的路由。Type-4LSA 可以泛洪到整个AS内部,但不能泛洪到Stub区域、Totally Stub区域、NSSA区域和Totally NSSA区域中。

Type-5 LSA(AS External LSA):它是由ASBR产生的,用来描述到AS外部网络的路由。Type-5 LSA可以泛洪到整个AS内部,但不能泛洪到Stub区域、Totally Stub区域、NSSA区域和Totally NSSA区域中。

Type-6 LSA(Group Membership LSA):在MOSPF中用于标识组播组成员使用的用户组播路由。

Type-7 LSA(NSSA LSA):它是由NSSA区域或Totally NSSA区域的NSSA ASBR产生的,用来描述到AS外部的路由。Type-7 LSA只能出现在所属NSSA区域或Totally NSSA区域内部。

Type:

显示信息中,Type表示了LSA的类型,这里表示的是Router LSA。不同类型的LSA的作用和泛洪区域范围是不相同的。Router LSA描述了路由器的直连链路或接口,泛洪范围为所在区域的内部,以使本区域的其他路由器了解其直连链路或接口的状态信息;

其他参数的含义:

Ls id:

对于Router LSA,Ls id就是产生该Router LSA的路由器的Router-ID。

Adv rtr:

Adv rtr描述了LSA是由哪台路由器产生的。对于Router LSA来讲,Adv rtr就是产生该Router LSA的路由器的Router-ID。

Seq#:

这一条LSA都会维护一个Seq#(序列号),产生这条LSA的路由器默认会过30s的周期泛洪这条LSA,每次泛洪时,序列号就加1,LSA的序列号越大,表明这条LSA越新。

Chksum:

chksum(校验和)用来校验LSA的完整性。所有的LSA都会保存在路由器的LSDB中,每5min会计算一次。如果路由器收到了同一条LSA,且序列号相同,则会比较它们的校验和,校验和越大就被认为相应的LSA越新。

Ls age:

Ls age是指LSA的老化时间,用来表示LSA已经存活了多长时间,最大值为3600s。当一台路由器产生一条LSA的时候,路由器会将LSA的老化时间设置为0。LSA在产生之后,无论是停留在路由器的LSDB内,还是在传递过程之中,老化时间都会不断增加,为了防止因LSA的过期而造成路由回馈,路由器会每隔30min泛洪自己产生的LSA。若序列号与校验和的比较都不能确定出最新的LSA时,则会比较老化时间。

在LSDB中,如果老化时间相差大于15min以上,则Ls age的值越小,说明LSA越新,如果相差15min内,则认为两条LSA是一样的。

在上面的显示信息中,Link count以上的参数信息通常被称为LSA头部信息,Link count及以下部分为具体的链路描述信息,Link count标识了这条LSA描述的链路信息的数量。对于P-2-P链路类型,Link ID是指链路上邻居接口的IP地址;对于TranNet链路类型,Link ID是指DR接口的IP地址。Data是指自身接口的IP地址,Link Type是指接口的链路类型,Metric是指路由器自己到达这条链路的Cost值,需要说明的是,OSPF协议会把Broadcast和NBMA这两种具有多路访问能力的网络都认为是TransNet网络。

实验目的:

理解OSPF中不同类型的LSA的作用

熟悉OSPF中不同类型的LSA的泛洪范围

熟悉LSA中重要字段的含义

实验拓扑:


路由基础之OSPF LSA详细讲解_链路

基础配置:

R1:

#
interface GigabitEthernet0/0/0
ip address 10.1.234.1 255.255.255.0
#
interface GigabitEthernet0/0/1
#
interface NULL0
#
interface LoopBack0
ip address 10.0.1.1 255.255.255.0
ospf network-type broadcast
#
ospf 1 router-id 10.0.1.1
area 0.0.0.0
network 10.1.234.1 0.0.0.0
area 0.0.0.2
network 10.0.1.1 0.0.0.0


路由基础之OSPF LSA详细讲解_泛洪_02

路由基础之OSPF LSA详细讲解_序列号_03

R2:

#
interface GigabitEthernet0/0/0
ip address 10.1.234.2 255.255.255.0
ospf dr-priority 254
#
interface GigabitEthernet0/0/1
#
interface NULL0
#
interface LoopBack0
ip address 10.0.2.2 255.255.255.0
ospf network-type broadcast
#
ospf 1 router-id 10.0.2.2
area 0.0.0.0
network 10.0.2.2 0.0.0.0
network 10.1.234.2 0.0.0.0


路由基础之OSPF LSA详细讲解_OSPF_04

路由基础之OSPF LSA详细讲解_OSPF_05

R3:

#
interface GigabitEthernet0/0/0
ip address 10.1.234.3 255.255.255.0
ospf dr-priority 255
#
interface GigabitEthernet0/0/1
#
interface NULL0
#
interface LoopBack0
ip address 10.0.3.3 255.255.255.0
ospf network-type broadcast
#
ospf 1 router-id 10.0.3.3
area 0.0.0.0
network 10.0.3.3 0.0.0.0
network 10.1.234.3 0.0.0.0
area 0.0.0.1
network 10.0.35.3 0.0.0.0


路由基础之OSPF LSA详细讲解_链路_06

路由基础之OSPF LSA详细讲解_序列号_07

R4:

#
interface GigabitEthernet0/0/0
ip address 10.1.234.4 255.255.255.0
ospf dr-priority 0
#
interface GigabitEthernet0/0/1
#
interface NULL0
#
interface LoopBack0
ip address 10.0.4.4 255.255.255.0
ospf network-type broadcast
#
ospf 1 router-id 10.0.4.4
area 0.0.0.0
network 10.0.4.4 0.0.0.0
network 10.1.234.4 0.0.0.0


路由基础之OSPF LSA详细讲解_LSA_08

路由基础之OSPF LSA详细讲解_链路_09

R5:

#
interface Serial2/0/0
link-protocol ppp
ip address 10.0.35.5 255.255.255.0
#
interface Serial2/0/1
link-protocol ppp
#
interface GigabitEthernet0/0/0
#
interface GigabitEthernet0/0/1
#
interface NULL0
#
interface LoopBack0
ip address 10.0.5.5 255.255.255.0
#
ospf 1 router-id 10.0.5.5
import-route direct
area 0.0.0.1
network 10.0.35.5 0.0.0.0


路由基础之OSPF LSA详细讲解_序列号_10

路由基础之OSPF LSA详细讲解_OSPF_11

查看你各个路由器的LSDB:

R1:

路由基础之OSPF LSA详细讲解_泛洪_12

R2:路由基础之OSPF LSA详细讲解_序列号_13

R3:

路由基础之OSPF LSA详细讲解_LSA_14

R4:

路由基础之OSPF LSA详细讲解_LSA_15

R5:

路由基础之OSPF LSA详细讲解_LSA_16


1类Lsa:

(1)主要描述的是与该路由的直连接口的链路信息;

(2)每个路由器都会生成一条1类Lsa条目;

(3)1类Lsa的类型有四种,分别为p2p、stubnet、transnet、virtual;

  1. Lsa内部各要素的含义:

路由基础之OSPF LSA详细讲解_泛洪_17

各个参数的解释:

type:表示Lsa的类型,router表示1类Lsa;


Ls id:表示该lsa的名称;


adv rtr:表示产生该lsa的路由器;


Ls age:表示老化时间,初始为0,3600为老化;


Len:表示Lsa的报文长度;


seq:序列号,用于比较Lsa的新旧;


Checksum:校验和


Link count:链路信息的数量


Link id:表示伪节点的信息


Data:表示自身连接伪节点的IP


link type:描述1类Lsa的类型,transnet表示为广播或NBMA类型


Metric:开销值

2类Lsa:

(1)主要在广播或者NBMA网络类型中,用于描述伪节点的信息;

(2)Lsa内部各要素如下图:

路由基础之OSPF LSA详细讲解_LSA_18

type:表示lsa类型,network表示为2类Lsa;

Attached router:表示邻居路由

3类Lsa:

(1)主要是将不同区域内的1类Lsa和2类Lsa进行转换,以便于其在不同区域中进行传递。

(2)只有ABR路由才能进行转换,且3类Lsa在本区域内泛洪。

(3)3类Lsa各要素的含义:

路由基础之OSPF LSA详细讲解_泛洪_19

实验结束;

备注:如有错误,请谅解!

此文章为本人学习笔记,仅供参考!如有重复!!!请联系本人