交换机配置

1:原理概述:​

  • 二层交换机工作在数据链路层,三层交换机工作在网络层;
  • 二层交换机基于MAC地址访问,只做数据的转发,并且不能配置IP地址,而三层交换机将二层交换技术和三层转发功能结合在一起。

二层交换机工作于OSI模型的第2层(数据链路层),故而称为二层交换机。

三层交换机就是具有部分路由器功能的交换机,三层交换机的最重要目的是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的,能够做到一次路由,多次转发。

1、工作层级不同:

二层交换机工作在数据链路层,三层交换机工作在网络层,三层交换机不仅实现了数据包的高速转发,还可以根据不同网络状况达到最优网络性能。

2、原理不同:

二层交换机的原理是当交换机从某个端口收到一个数据包,它会先读取包中的源MAC地址,再去读取包中的目的MAC地址,并在地址表中查找对应的端口,如表中有和目的MAC地址对应的端口,就把数据包直接复制到这个端口上。三层交换机的原理比较简单,就是一次路由多次交换,通俗来说就是第一次进行源到目的的路由,三层交换机会将此数据转到二层,那么下次无论是目的到源还是源到目的都可以进行快速交换。

3、功能不同:

二层交换机基于MAC地址访问,只做数据的转发,并且不能配置IP地址,而三层交换机将二层交换技术和三层转发功能结合在一起,也就是说三层交换机在二层交换机的基础上增加了路由功能,可配置不同vlan的IP地址,vlan之间可通过三层路由实现不同vlan之间通讯。

4、应用不同:

二层交换机主要用于网络接入层和汇聚层,而三层交换机主要用于网络核心层,但是也存在少部分三层交换机用于汇聚层的现象,下图是三层交换机的实际应用实例。

5、支持的协议不同:

二层交换机支持物理层和数据链路层协议,如以太网交换机、二层交换机,这集线器HUB的功能差不多,而三层交换机支持物理层、数据链路层及网络层协议。

2:实验目的:​

PC1、PC2划分为VLAN 10,PC3划分为VLAN 20,PC4划分为VLAN 30,PC5划分为VLAN 40,

三层交换与三层交换配置链路聚合,实现不同VLAN之间互通,从而实现全网互通;

3:实验拓扑:​

路由基础之思科交换机配置和DHCP全局地址池的配置_交换机

注意:PC与交换机之间连接的接口配置为access,交换机与交换机的接口配置为Trunk

SW1:

接口配置​

interface FastEthernet0/1​
switchport access vlan 10​
switchport mode access​
!​
interface FastEthernet0/2​
switchport access vlan 10​
switchport mode access​
!​
interface FastEthernet0/3​
switchport mode trunk​
!​
interface FastEthernet0/4​
switchport mode trunk

SW2:​

接口配置

interface FastEthernet0/1​
switchport access vlan 20​
switchport mode access​
!​
interface FastEthernet0/2​
switchport mode trunk​
!​
interface FastEthernet0/3​
switchport mode trunk

SW3:​

接口配置

interface FastEthernet0/1​
switchport access vlan 30​
switchport mode access​
!​
interface FastEthernet0/2​
switchport mode trunk​
!​
interface FastEthernet0/3​
switchport mode trunk

SW4:​

接口配置

interface FastEthernet0/1​
switchport access vlan 40​
switchport mode access​
!​
interface FastEthernet0/2​
switchport mode trunk​
!​
interface FastEthernet0/3​
switchport mode trunk

SW5:​

接口配置

interface Port-channel1
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk
!​
interface FastEthernet0/1​
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk​
!​
interface FastEthernet0/2​
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk​
!​
interface FastEthernet0/3​
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk​
!​
interface FastEthernet0/4​
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk​
!​
interface FastEthernet0/5​
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk​
channel-group 1 mode active
!​
interface FastEthernet0/6​
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk​
channel-group 1 mode active

SW6:

接口配置​

interface Port-channel1
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk
!​
interface FastEthernet0/1​
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk​
!​
interface FastEthernet0/2​
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk​
!​
interface FastEthernet0/3​
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk​
!​
interface FastEthernet0/4​
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk​
!​
interface FastEthernet0/5​
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk​
channel-group 1 mode active
!​
interface FastEthernet0/6​
switchport trunk allowed vlan 10,20,30,40,100,200​
switchport trunk encapsulation dot1q​
switchport mode trunk​
channel-group 1 mode active

注意:创建好vlan后,记得no shutdown

SW1-4同理:​

创建VLAN

conf t ​
Vlan 10​
No sh ​
Vlan 20​
No sh​
Vlan 30​
No sh​
Vlan 40​
No sh​
End​
Sh run

查看如下所示:

interface Vlan10​
mac-address 0001.6394.5a01​
no ip address​
!​
interface Vlan20​
mac-address 0001.6394.5a02​
no ip address​
!​
interface Vlan30​
mac-address 0001.6394.5a03​
no ip address​
!​
interface Vlan40​
mac-address 0001.6394.5a04​
no ip address

SW5:​

interface Vlan10​
mac-address 0009.7c03.8101​
ip address 192.168.10.251 255.255.255.0​
!​
interface Vlan20​
mac-address 0009.7c03.8102​
ip address 192.168.20.251 255.255.255.0​
ip helper-address 192.168.20.100​
!​
interface Vlan30​
mac-address 0009.7c03.8103​
ip address 192.168.30.251 255.255.255.0​
!​
interface Vlan40​
mac-address 0009.7c03.8104​
ip address 192.168.40.251 255.255.255.0

查看命令:

Show ip interface brief

路由基础之思科交换机配置和DHCP全局地址池的配置_路由_02

SW6:​

interface Vlan10​
mac-address 00d0.bae0.ba01​
ip address 192.168.10.250 255.255.255.0​
!​
interface Vlan20​
mac-address 00d0.bae0.ba02​
ip address 192.168.20.250 255.255.255.0​
!​
interface Vlan30​
mac-address 00d0.bae0.ba03​
ip address 192.168.30.250 255.255.255.0​
!​
interface Vlan40​
mac-address 00d0.bae0.ba04​
ip address 192.168.40.250 255.255.255.0

路由基础之思科交换机配置和DHCP全局地址池的配置_全局地址池·_03

三层交换机与三层交换机之间配置链路聚合

链路聚合:

指将多个物理端口汇聚在一起,形成一个逻辑端口,以实现出/入流量吞吐量在各成员端口的负荷分担,交换机根据用户配置的端口负荷分担策略决定网络封包从哪个成员端口发送到对端的交换机。当交换机检测到其中一个成员端口的链路发生故障时,就停止在此端口上发送封包,并根据负荷分担策略在剩下的链路中重新计算报文的发送端口,故障端口恢复后再次担任收发端口。链路聚合在增加链路带宽、实现链路传输弹性和工程冗余等方面是一项很重要的技术。

channel-group 建立链路聚合通道组
5 序号
mode 模式
active 链路聚合控制协议
一般都是这样来使用的

interface GigabitEthernet1/0/1
channel-group 1 mode active
interface GigabitEthernet1/0/2
channel-group 1 mode active
Interface port-channel 1
switchport mode trunk

DHCP全局地址池的配置​

1:原理概述:​

1、DHCP Client以广播的方式发出DHCP Discover报文。

2、所有的DHCP Server都能够接收到DHCP Client发送的DHCP Discover报文,所有的DHCP Server都会给出响应,向DHCP Client发送一个DHCP Offer报文。

DHCP Offer报文中“Your(Client) IP Address”字段就是DHCP Server能够提供给DHCP Client使用的IP地址,且DHCP Server会将自己的IP地址放在“option”字段中以便DHCP Client区分不同的DHCP Server。DHCP Server在发出此报文后会存在一个已分配IP地址的纪录。

3、DHCP Client只能处理其中的一个DHCP Offer报文,一般的原则是DHCP Client处理最先收到的DHCP Offer报文。

DHCP Client会发出一个广播的DHCP Request报文,在选项字段中会加入选中的DHCP Server的IP地址和需要的IP地址。

4、DHCP Server收到DHCP Request报文后,判断选项字段中的IP地址是否与自己的地址相同。如果不相同,DHCP Server不做任何处理只清除相应IP地址分配记录;如果相同,DHCP Server就会向DHCP Client响应一个DHCP ACK报文,并在选项字段中增加IP地址的使用租期信息。

5、DHCP Client接收到DHCP ACK报文后,检查DHCP Server分配的IP地址是否能够使用。如果可以使用,则DHCP Client成功获得IP地址并根据IP地址使用租期自动启动续延过程;如果DHCP Client发现分配的IP地址已经被使用,则DHCP Client向DHCPServer发出DHCP Decline报文,通知DHCP Server禁用这个IP地址,然后DHCP Client开始新的地址申请过程。

6、DHCP Client在成功获取IP地址后,随时可以通过发送DHCP Release报文释放自己的IP地址,DHCP Server收到DHCP Release报文后,会回收相应的IP地址并重新分配。

在使用租期超过50%时刻处,DHCP Client会以单播形式向DHCP Server发送DHCPRequest报文来续租IP地址。如果DHCP Client成功收到DHCP Server发送的DHCP ACK报文,则按相应时间延长IP地址租期;如果没有收到DHCP Server发送的DHCP ACK报文,则DHCP Client继续使用这个IP地址。

在使用租期超过87.5%时刻处,DHCP Client会以广播形式向DHCP Server发送DHCPRequest报文来续租IP地址。如果DHCP Client成功收到DHCP Server发送的DHCP ACK报文,则按相应时间延长IP地址租期;如果没有收到DHCP Server发送的DHCP ACK报文,则DHCP Client继续使用这个IP地址,直到IP地址使用租期到期时,DHCP Client才会向DHCP Server发送DHCP Release报文来释放这个IP地址,并开始新的IP地址申请过程。

需要说明的是:DHCP客户端可以接收到多个DHCP服务器的DHCPOFFER数据包,然后可能接受任何一个DHCPOFFER数据包,但客户端通常只接受收到的第一个DHCPOFFER数据包。另外,DHCP服务器DHCPOFFER中指定的地址不一定为最终分配的地址,通常情况下,DHCP服务器会保留该地址直到客户端发出正式请求。

正式请求DHCP服务器分配地址DHCPREQUEST采用广播包,是为了让其它所有发送DHCPOFFER数据包的DHCP服务器也能够接收到该数据包,然后释放已经OFFER(预分配)给客户端的IP地址。

如果发送给DHCP客户端的地址已经被其他DHCP客户端使用,客户端会向服务器发送DHCPDECLINE信息包拒绝接受已经分配的地址信息。

在协商过程中,如果DHCP客户端发送的REQUEST消息中的地址信息不正确,如客户端已经迁移到新的子网或者租约已经过期,DHCP服务器会发送DHCPNAK消息给DHCP客户 端,让客户端重新发起地址请求过程。

2:实验目的:​

实现局域网内所有PC都可以自动获取IP地址;

实现全网互通(不同VLAN之间也可通信);

3:实验拓扑:​

路由基础之思科交换机配置和DHCP全局地址池的配置_交换机_04

4:基础配置:​

R1:

interface FastEthernet0/1​
switchport access vlan 10​
switchport mode access​
!​
interface FastEthernet0/2​
switchport access vlan 10​
switchport mode access​
!​
interface FastEthernet0/3​
switchport mode trunk

R2:

interface FastEthernet0/1​
switchport access vlan 20​
switchport mode access​
!​
interface FastEthernet0/2​
switchport mode trunk

R3:

interface FastEthernet0/1​
switchport access vlan 30​
switchport mode access​
!​
interface FastEthernet0/2​
switchport mode trunk

R4:

interface FastEthernet0/1​
switchport access vlan 40​
switchport mode access​
!​
interface FastEthernet0/2​
switchport mode trunk

划分VLAN10,20,30,40,100

S1-S4同配置:

interface Vlan10​
mac-address 0005.5e02.8401​
no ip address​
!​
interface Vlan20​
mac-address 0005.5e02.8402​
no ip address​
!​
interface Vlan30​
mac-address 0005.5e02.8403​
no ip address​
!​
interface Vlan40​
mac-address 0005.5e02.8404​
no ip address​
!​
interface Vlan100​
mac-address 0005.5e02.8405​
no ip address

SW5:

interface FastEthernet0/1​
switchport trunk allowed vlan 10,20,30,40,100​
switchport trunk encapsulation dot1q​
switchport mode trunk​
switchport nonegotiate​
!​
interface FastEthernet0/2​
switchport trunk allowed vlan 10,20,30,40,100​
switchport trunk encapsulation dot1q​
switchport mode trunk​
switchport nonegotiate​
!​
interface FastEthernet0/3​
switchport trunk allowed vlan 10,20,30,40,100​
switchport trunk encapsulation dot1q​
switchport mode trunk​
switchport nonegotiate​
!​
interface FastEthernet0/4​
switchport trunk allowed vlan 10,20,30,40,100​
switchport trunk encapsulation dot1q​
switchport mode trunk​
switchport nonegotiate​
!​
interface FastEthernet0/5​
switchport access vlan 100​
switchport mode access​
switchport nonegotiate​
!​
interface Vlan10​
mac-address 000c.85dd.1001​
ip address 192.168.10.254 255.255.255.0​
ip helper-address 192.168.100.1​
!​
interface Vlan20​
mac-address 000c.85dd.1002​
ip address 192.168.20.254 255.255.255.0​
ip helper-address 192.168.100.1​
!​
interface Vlan30​
mac-address 000c.85dd.1003​
ip address 192.168.30.254 255.255.255.0​
ip helper-address 192.168.100.1​
!​
interface Vlan40​
mac-address 000c.85dd.1004​
ip address 192.168.40.254 255.255.255.0​
ip helper-address 192.168.100.1​
!​
interface Vlan100​
mac-address 000c.85dd.1005​
ip address 192.168.100.254 255.255.255.0

配置OSPF路由协议

router ospf 1​
log-adjacency-changes​
network 192.168.100.0 0.0.0.255 area 0​
network 192.168.10.0 0.0.0.255 area 0​
network 192.168.20.0 0.0.0.255 area 0​
network 192.168.30.0 0.0.0.255 area 0​
network 192.168.40.0 0.0.0.255 area 0

查看SW5 VLAN 的配置情况:

路由基础之思科交换机配置和DHCP全局地址池的配置_DHCP_05

R1:

ip dhcp excluded-address 192.168.10.254​
ip dhcp excluded-address 192.168.20.254​
ip dhcp excluded-address 192.168.30.254​
ip dhcp excluded-address 192.168.40.254​
ip dhcp excluded-address 192.168.100.254​

配置DHCP地址池:

ip dhcp pool vlan30​
network 192.168.30.0 255.255.255.0​
default-router 192.168.30.254​
dns-server 8.8.8.8​
ip dhcp pool vlan10​
network 192.168.10.0 255.255.255.0​
default-router 192.168.10.254​
dns-server 8.8.8.8​
ip dhcp pool vlan20​
network 192.168.20.0 255.255.255.0​
default-router 192.168.20.254​
dns-server 8.8.8.8​
ip dhcp pool vlan40​
network 192.168.40.0 255.255.255.0​
default-router 192.168.40.254​
dns-server 8.8.8.8​
ip dhcp pool vlan100​
network 192.168.100.0 255.255.255.0​
default-router 192.168.100.254​
dns-server 8.8.8.8​
interface FastEthernet0/0​
ip address 192.168.100.1 255.255.255.0​
duplex auto​
speed auto​

配置OSPF路由协议

router ospf 1​
log-adjacency-changes​
network 192.168.100.0 0.0.0.255 area 0

所有的配置都完成后:

查看R1和SW5的路由表:

路由基础之思科交换机配置和DHCP全局地址池的配置_路由_06

路由基础之思科交换机配置和DHCP全局地址池的配置_思科_07

查看PC获取IP的情况:

路由基础之思科交换机配置和DHCP全局地址池的配置_DHCP_08

路由基础之思科交换机配置和DHCP全局地址池的配置_路由_09

路由基础之思科交换机配置和DHCP全局地址池的配置_全局地址池·_10

路由基础之思科交换机配置和DHCP全局地址池的配置_路由_11

路由基础之思科交换机配置和DHCP全局地址池的配置_思科_12

可以看到所有PC都获取到了IP地址

路由基础之思科交换机配置和DHCP全局地址池的配置_思科_13

不同VLAN之间也可以实现互通;

实验结束;

备注:如有错误,请谅解!

此文章为本人学习笔记,仅供参考!如有重复!!!请联系本人