OSPF开销值、协议优先级及计时器的修改

1:原理概述:

由于路由器上可能同时运行多种动态路由协议,就存在各个路由协议之间路由信息共享和选择的问题。系统为每一种路由协议设置了不同的默认优先级,当在不同协议中发现同一条路由时,协议优先级高的将被优选;

如果没有直接配置OSPF接口的开销值,OSPF会根据该接口的带宽自动计算其开销值,计算公式为:接口开销=带宽参考值/接口带宽;取计算结果的整数部分作为接口开销值(当结果小于1时取1)。通过改变带宽参考值可以间接改变接口的开销值。

OSPF常见的计时器包括Hello timer 和 Dead timer,分别决定了OSPF发送Hello报文的间隔和保持邻居关系的计时器、默认情况下,P2P、Broadcast 类型接口发送Hello报文的时间间隔为10s,邻居失效时间为40s,P2MP、NBMA类型接口发送Hello报文的时间间隔为30s,邻居失效时间为120s;

 

2:实验目的:

掌握配置OSPF协议优先级的方法

掌握配置OSPF开销值的方法

掌握配置OSPF Hello timer的方法

掌握配置OSPF Dead timer的方法

3:实验拓扑:

路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_协议优先级

4:我们首先做好基础配置,使网络互通,在AR1、AR2、AR4、AR5上配置OSPF;通告网段属于区域0;

AR1:

#
interface Serial2/0/0
link-protocol ppp
ip address 10.0.12.254 255.255.255.0
#
interface Serial2/0/1
link-protocol ppp
#
interface GigabitEthernet0/0/0
ip address 10.0.1.254 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 10.0.13.1 255.255.255.0
#
interface NULL0
#
ospf 1
area 0.0.0.0
network 10.0.1.0 0.0.0.255
network 10.0.12.0 0.0.0.255

AR2:

#
interface Serial2/0/0
link-protocol ppp
ip address 10.0.12.1 255.255.255.0
#
interface Serial2/0/1
link-protocol ppp
ip address 10.0.24.1 255.255.255.0
#
interface GigabitEthernet0/0/0
#
interface GigabitEthernet0/0/1
#
interface NULL0
#
ospf 1
area 0.0.0.0
network 10.0.12.0 0.0.0.255
network 10.0.24.0 0.0.0.255

AR4:

#
interface Serial2/0/0
link-protocol ppp
ip address 10.0.24.254 255.255.255.0
#
interface Serial2/0/1
link-protocol ppp
#
interface GigabitEthernet0/0/0
ip address 10.0.45.1 255.255.255.0
#
interface GigabitEthernet0/0/1
#
interface NULL0
#
ospf 1
area 0.0.0.0
network 10.0.24.0 0.0.0.255
network 10.0.45.0 0.0.0.255
AR5:
#
interface GigabitEthernet0/0/0
ip address 10.0.2.254 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 10.0.45.254 255.255.255.0
#
interface NULL0
#
ospf 1
area 0.0.0.0
network 10.0.2.0 0.0.0.255
network 10.0.45.0 0.0.0.255

这些都配置完成后,我们查看可否ping通;

 路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_默认路由_02

5:我们开始实施网络升级方案,部署使用经过AR3的线路,运行RIP协议

AR1:

#
rip 1
undo summary
version 2
network 10.0.0.0
AR3:
#
rip 1
undo summary
version 2
network 10.0.0.0

AR4:

#
rip 1
undo summary
version 2
network 10.0.0.0
AR5:
#
rip 1
undo summary
version 2
network 10.0.0.0

配置完成后,在AR1上检查路由条目:

 路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_计时器_03

我们tracert PC2发现:

 路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_默认路由_04

依旧是通过OSPF协议获得,即PC1与PC2之间的数据依然通过AR2转发,新接入的AR3,带宽更大的路径没有参加数据转发,升级不成功。

导致不成功的原因是该路由条目可以同时从OSPF协议和RIP协议获得,当同一路由条目可以通过不同的路由协议获得时,首先比较两协议的优先级,路由器将优选优先级高的路由协议。OSPF的默认协议优先级为10,而RIP为100,优先级值越低表示优先级越高,故而选择了从OSPF协议获得的路由条目。

但是根据实际需求,经过AR2使用的OSPF线路是广域网线路,带宽很低,而经过AR3使用的RIP线路是以太网线路,带宽高,所以现在一定要选择RIP条目进行转发,通过修改OSPF协议优先级即可。

在AR1、AR4、AR5的进程下修改OSPF协议优先级的值为110,大于RIP的100。

AR1:

[Huawei-ospf-1]preference 110

其他两台同理;

配置完成后,查看路由条目:

路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_协议优先级_05

路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_协议优先级_06

配置OSPF开销值:

AR3:

ospf 1
area 0
network 10.0.13.0 0.0.0.255
etwork 10.0.34.0 0.0.0.255o

其他俩台路由器同理;

路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_开销值_07

可以观察到现在使用的是AR3的线路;

下面我们开始配置OSPF开销值:

由于网络中运行不同路由协议将会导致管理不便,现需更改AR3的配置,使其运行OSPF协议。

在网络调整过程中最重要的是就是尽量确保能够使其用户通信所造成的影响程度降至最小;

配置完成后,在分支左区域的网关AR1上查看路由表关于分支右区域网段的10.0.2.0的条目;

路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_计时器_08

在AR1上G0/0/1接口上运行OSPF协议所需的开销值;

 路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_协议优先级_09

配置OSPF计时器:

 路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_协议优先级_10

配置完成后,查看AR1的邻居状态;

 路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_默认路由_11

可以观察到,数据恢复正常;实验结束;


使用RIP、OSPF发布默认路由

1:原理概述:

默认路由是指目的地址和掩码都是0的路由条目。当路由器无精确匹配的路由时,就可以通过默认路由进行转发。

合理使用默认路由,可以很大程度上减小本地路由表的大小,节约设备资源、默认路由可以在路由器上手工配置,也可以由路由协议自动发布。

RIP和OSPF这两种路由议都可以通过配置使路由器对协议邻居发布默认路由,并且可以设置该路由的度量值。

       一条路由的开销是指到达这条路由的目的地/掩码需要付出的代价值。

       在路由表中,每一行就是一条路由条目。一条路由的信息有三个要素:

       1、出接口(Interface)

       2、下一跳IP地址(NextHop)

       3、目的地/掩码(Destination/Mask)

      默认路由(Default route),是对IP数据包中的目的地址找不到存在的其他路由时,路由器所选择的路由。目的地不在路由器的路由表里的所有数据包都会使用默认路由。这条路由一般会连去另一个路由器,而这个路由器也同样处理数据包: 如果知道应该怎么路由这个数据包,则数据包会被转发到已知的路由;否则,数据包会被转发到默认路由,从而到达另一个路由器。每次转发,路由都增加了一跳的距离。

2:实验目的:

理解默认路由的应用场景

掌握RIP发布默认路由的配置

掌握OSPF发布默认路由的配置

3:实验拓扑:

 路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_协议优先级_12

4:基础配置:

AR2:

#
interface GigabitEthernet0/0/0
ip address 172.16.1.254 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 172.16.2.254 255.255.255.0
#
interface NULL0
#
rip 1
undo summary
version 2
network 172.16.0.0

AR1:

#
interface GigabitEthernet0/0/0
ip address 172.16.2.1 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 192.168.2.1 255.255.255.0
#
interface NULL0
#
ospf 1
area 0.0.0.0
network 192.168.2.0 0.0.0.255
#
rip 1
undo summary
version 2
network 172.16.0.0

AR3:

#
interface GigabitEthernet0/0/0
ip address 192.168.1.254 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 192.168.2.254 255.255.255.0
#
interface NULL0
#
ospf 1
area 0.0.0.0
network 192.168.1.0 0.0.0.255
network 192.168.2.0 0.0.0.255

查看的路由表:

AR1:路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_计时器_13

AR2:

 路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_协议优先级_14

AR3:

 路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_协议优先级_15

可以观察到,此时AR2和AR3上都只拥有本公司的路由信息

测试PC1与PC2间的连通性;

 路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_协议优先级_16

可以观察到,此时无法ping通;

5:配置RIP发布默认路由

在AR1的RIP进程中,配置发布默认路由

[Huawei-rip-1]default-route originate

 路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_开销值_17

可以观察到AR2上有一条从RIP协议获取来的默认路由,通过这条默认路由,PC1可以访问PC2的网络;

6:配置OSPF发布默认路由

为了能够实现通信,PC2也需要访问PC1的网络,而PC1同样为了保护自身网络私密性,不希望PC2获知自身内部网络的明确路由。这时可以在AR1的OSPF协议进程中发布默认路由,使PC2能在没有PC1的明确路由的情况下能够访问PC1的网络

在AR1上配置:

 

[Huawei]ospf
[Huawei-ospf-1]de
[Huawei-ospf-1]default-route-advertise a
[Huawei-ospf-1]default-route-advertise always

 路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_协议优先级_18

可以观察到AR3上有一条通过OSPF协议获得的默认路由,通过这条默认路由,PC2可以访问PC1的网络;

再次验证:

路由基础之OSPF开销值、协议优先级及计时器的修改和使用RIP、OSPF发布默认路由_计时器_19

可以ping通;

实验结束; 

备注:如有错误,请谅解!

此文章为本人学习笔记,仅供参考!如有重复!!!请联系本人!