本文为博主原创,未经允许不得转载

      在用spring tool suite创建spring boot项目时,报一下异常:

用spring tool suite插件创建spring boot_tools

查阅很多资料之后发现是因为装的spring tool suite的版本与eclipse版本不匹配。

我安装的eclipse版本是4.6.2,spring tool suite版本是3.9.2.在创建springboot项目时就遇到了这个问题。

解决方法:

进入spring tool suite官网:http://spring.io/tools/sts

用spring tool suite插件创建spring boot_解决方法_02

点击红框就可以进入查看eclipse版本对应的spring tool suite。

用spring tool suite插件创建spring boot_spring_03

 

 然后重新安装,启动之后就可以用了