本实验模拟高校网络建设。高校校园网的信息化建设一直走在各个行业前列,其网络建设相对比较复杂,涉及到多种网元,如交换机,路由器,无线设备及安全设备等。本实验模拟某高校园区网络,GL 校区为研究生部,XL 校区为本科部。GL、XL 校区网络都需重新建设,现需对网络进行规划与配置,涉及两部分的网络建设。

实验拓扑

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维

1.基本配置

根据实验编址表、规划表进行相应的配置。交换机 VLAN 规划表如下。

模拟高校 中小型企业网络搭建配置案例_路由器_02

设备接口IPv4地址规划表如下。

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_03

1.1 配置Eth-Trunk

在 Agg1—Agg2 之间的链路,通过 LACP 模式实现链路聚合,成员接口为 GE0/0/5 和 GE0/0/6。该逻辑接口编号为 0。

1.1.1 配置Agg1的Eth-Trunk

<Huawei>system-view
[Huawei]sysname Agg1
[Agg1]interface Eth-Trunk0
[Agg1-Eth-Trunk0]mode lacp-static
[Agg1-Eth-Trunk0]trunkport GigabitEthernet 0/0/5 0/0/6
[Agg1-Eth-Trunk0]quit

模拟高校 中小型企业网络搭建配置案例_网络搭建_04

拷贝代码system-view 
sysname Agg1
interface Eth-Trunk0
mode lacp-static
trunkport GigabitEthernet 0/0/5 0/0/6
quit
1.1.2 配置Agg2的Eth-Trunk

<Huawei>system-view
[Huawei]sysname Agg2
[Agg2]interface Eth-Trunk0
[Agg2-Eth-Trunk0]mode lacp-static
[Agg2-Eth-Trunk0]trunkport GigabitEthernet 0/0/5 0/0/6
[Agg2-Eth-Trunk0]quit

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_05

拷贝代码system-view 
sysname Agg2
interface Eth-Trunk0
mode lacp-static
trunkport GigabitEthernet 0/0/5 0/0/6
quit

1.2 配置VLAN

参照VLAN 规划表完成全网设备 VLAN的配置和接口划分。

1.2.1 配置Acc1的VLAN

<Huawei>system-view
[Huawei]sysname Acc1
[Acc1]vlan batch 30 40
[Acc1]interface GigabitEthernet0/0/1
[Acc1-GigabitEthernet0/0/1] port link-type trunk
[Acc1-GigabitEthernet0/0/1] port trunk pvid vlan 30
[Acc1-GigabitEthernet0/0/1] port trunk allow-pass vlan 30 40
[Acc1-GigabitEthernet0/0/1]quit
[Acc1]interface GigabitEthernet0/0/2
[Acc1-GigabitEthernet0/0/2] port link-type trunk
[Acc1-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 to 4094
[Acc1-GigabitEthernet0/0/2]quit
[Acc1]interface GigabitEthernet0/0/3
[Acc1-GigabitEthernet0/0/3] port link-type trunk
[Acc1-GigabitEthernet0/0/3] port trunk allow-pass vlan 2 to 4094
[Acc1-GigabitEthernet0/0/3]quit

模拟高校 中小型企业网络搭建配置案例_路由器_06

拷贝代码system-view 
sysname Acc1
vlan batch 30 40
interface GigabitEthernet0/0/1
port link-type trunk
port trunk pvid vlan 30
port trunk allow-pass vlan 30 40
quit
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 4094
quit
interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 2 to 4094
quit
1.2.2 配置Acc2的VLAN

<Huawei>system-view
[Huawei]sysname Acc2
[Acc2]vlan batch 10
[Acc2]interface GigabitEthernet0/0/3
[Acc2-GigabitEthernet0/0/3]port link-type trunk
[Acc2-GigabitEthernet0/0/3]port trunk allow-pass vlan 2 to 4094
[Acc2-GigabitEthernet0/0/3]quit
[Acc2]interface GigabitEthernet0/0/2
[Acc2-GigabitEthernet0/0/2]port link-type trunk
[Acc2-GigabitEthernet0/0/2]port trunk allow-pass vlan 2 to 4094
[Acc2-GigabitEthernet0/0/2]quit
[Acc2]interface GigabitEthernet0/0/1
[Acc2-GigabitEthernet0/0/1]port link-type access
[Acc2-GigabitEthernet0/0/1]port default vlan 10
[Acc2-GigabitEthernet0/0/1]quit

模拟高校 中小型企业网络搭建配置案例_交换机_07

拷贝代码system-view 
sysname Acc2
vlan batch 10
interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 2 to 4094
quit
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 4094
quit
interface GigabitEthernet0/0/1
port link-type access
port default vlan 10
quit
1.2.3 配置Agg1的VLAN

[Agg1]vlan batch 10 30 40 105
[Agg1]interface GigabitEthernet0/0/1
[Agg1-GigabitEthernet0/0/1]port link-type trunk
[Agg1-GigabitEthernet0/0/1]port trunk allow-pass vlan 30
[Agg1-GigabitEthernet0/0/1]quit
[Agg1]interface GigabitEthernet0/0/2
[Agg1-GigabitEthernet0/0/2]port link-type trunk
[Agg1-GigabitEthernet0/0/2]port trunk allow-pass vlan 2 to 4094
[Agg1-GigabitEthernet0/0/2]quit
[Agg1]interface GigabitEthernet0/0/3
[Agg1-GigabitEthernet0/0/3]port link-type trunk
[Agg1-GigabitEthernet0/0/3]port trunk allow-pass vlan 2 to 4094
[Agg1-GigabitEthernet0/0/3]quit
[Agg1]interface GigabitEthernet0/0/4
[Agg1-GigabitEthernet0/0/4]port link-type access
[Agg1-GigabitEthernet0/0/4]port default vlan 105
[Agg1-GigabitEthernet0/0/4]quit
[Agg1]interface Eth-Trunk0
[Agg1-Eth-Trunk0]port link-type trunk
[Agg1-Eth-Trunk0]port trunk allow-pass vlan 2 to 4094

模拟高校 中小型企业网络搭建配置案例_网络搭建_08

拷贝代码vlan batch 10 30 40 105
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 30
quit
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 4094
quit
interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 2 to 4094
quit
interface GigabitEthernet0/0/4
port link-type access
port default vlan 105
quit
interface Eth-Trunk0
port link-type trunk
port trunk allow-pass vlan 2 to 4094
1.2.4 配置Agg2的VLAN

[Agg2]vlan batch 10 106
[Agg2]interface GigabitEthernet0/0/2
[Agg2-GigabitEthernet0/0/2]port link-type trunk
[Agg2-GigabitEthernet0/0/2]port trunk allow-pass vlan 2 to 4094
[Agg2-GigabitEthernet0/0/2]quit
[Agg2]interface GigabitEthernet0/0/3
[Agg2-GigabitEthernet0/0/3]port link-type trunk
[Agg2-GigabitEthernet0/0/3]port trunk allow-pass vlan 2 to 4094
[Agg2-GigabitEthernet0/0/3]quit
[Agg2]interface GigabitEthernet0/0/4
[Agg2-GigabitEthernet0/0/4]port link-type access
[Agg2-GigabitEthernet0/0/4]port default vlan 106
[Agg2-GigabitEthernet0/0/4]quit
[Agg2]interface Eth-Trunk0
[Agg2-Eth-Trunk0]port link-type trunk
[Agg2-Eth-Trunk0]port trunk allow-pass vlan 2 to 4094

模拟高校 中小型企业网络搭建配置案例_路由器_09

拷贝代码vlan batch 10 106
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 4094
quit
interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 2 to 4094
quit
interface GigabitEthernet0/0/4
port link-type access
port default vlan 106
quit
interface Eth-Trunk0
port link-type trunk
port trunk allow-pass vlan 2 to 4094
1.2.5 配置AC1的VLAN

<AC6605>system-view
[AC6605]sysname AC1
[AC1]vlan 30
[AC1-vlan30]interface GigabitEthernet0/0/1
[AC1-GigabitEthernet0/0/1]port link-type trunk
[AC1-GigabitEthernet0/0/1]port trunk allow-pass vlan 30
[AC1-GigabitEthernet0/0/1]quit

模拟高校 中小型企业网络搭建配置案例_交换机_10

拷贝代码system-view 
sysname AC1
vlan 30
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 30
quit
1.2.6 配置Agg3的VLAN

<Huawei>system-view
[Huawei]sysname Agg3
[Agg3]vlan batch 50 108
[Agg3]interface GigabitEthernet0/0/1
[Agg3-GigabitEthernet0/0/1] port link-type access
[Agg3-GigabitEthernet0/0/1] port default vlan 108
[Agg3-GigabitEthernet0/0/1]quit
[Agg3]interface GigabitEthernet0/0/2
[Agg3-GigabitEthernet0/0/2] port link-type trunk
[Agg3-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 to 4094
[Agg3-GigabitEthernet0/0/2]quit

模拟高校 中小型企业网络搭建配置案例_路由器_11

拷贝代码system-view 
sysname Agg3
vlan batch 50 108
interface GigabitEthernet0/0/1
port link-type access
port default vlan 108
quit
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 4094
quit
1.2.7 配置Acc3的VLAN

<Huawei>system-view
[Huawei]sysname Acc3
[Acc3]vlan batch 50
[Acc3]interface GigabitEthernet0/0/1
[Acc3-GigabitEthernet0/0/1] port link-type access
[Acc3-GigabitEthernet0/0/1] port default vlan 50
[Acc3-GigabitEthernet0/0/1]quit
[Acc3]interface GigabitEthernet0/0/2
[Acc3-GigabitEthernet0/0/2] port link-type trunk
[Acc3-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 to 4094
[Acc3-GigabitEthernet0/0/2]quit

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_12

拷贝代码system-view 
sysname Acc3
vlan batch 50
interface GigabitEthernet0/0/1
port link-type access
port default vlan 50
quit
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 4094
quit
1.2.8 配置DC1的VLAN

<Huawei>system-view
[Huawei]sysname DC1
[DC1]vlan batch 201
[DC1]interface GigabitEthernet0/0/2
[DC1-GigabitEthernet0/0/2] port link-type access
[DC1-GigabitEthernet0/0/2] port default vlan 201
[DC1-GigabitEthernet0/0/2]quit

模拟高校 中小型企业网络搭建配置案例_路由器_13

拷贝代码system-view 
sysname DC1
vlan batch 201
interface GigabitEthernet0/0/2
port link-type access
port default vlan 201
quit

1.3 配置IP地址

根据IP地址规划表进行设备IP地址的配置。

1.3.1 进行AC1的地址配置

[AC1]interface Vlanif30
[AC1-Vlanif30] ip address 192.168.30.254 255.255.255.0
[AC1-Vlanif30]quit

模拟高校 中小型企业网络搭建配置案例_网络搭建_14

拷贝代码interface Vlanif30
ip address 192.168.30.254 255.255.255.0
quit
1.3.2 进行Agg1的地址配置

[Agg1-Eth-Trunk0]quit
[Agg1]interface Vlanif10
[Agg1-Vlanif10] ip address 192.168.10.1 255.255.255.0
[Agg1-Vlanif10]quit
[Agg1]interface Vlanif40
[Agg1-Vlanif40] ip address 192.168.40.254 255.255.255.0
[Agg1-Vlanif40]quit
[Agg1]interface Vlanif105
[Agg1-Vlanif105] ip address 10.1.79.7 255.255.255.0
[Agg1-Vlanif105]quit
[Agg1]interface LoopBack0
[Agg1-LoopBack0] ip address 10.1.7.7 255.255.255.255
[Agg1-LoopBack0]quit

模拟高校 中小型企业网络搭建配置案例_网络搭建_15

拷贝代码quit
interface Vlanif10
ip address 192.168.10.1 255.255.255.0
quit
interface Vlanif40
ip address 192.168.40.254 255.255.255.0
quit
interface Vlanif105
ip address 10.1.79.7 255.255.255.0
quit
interface LoopBack0
ip address 10.1.7.7 255.255.255.255
quit
1.3.3 进行Agg2的地址配置

[Agg2-Eth-Trunk0]quit
[Agg2]interface Vlanif10
[Agg2-Vlanif10] ip address 192.168.10.2 255.255.255.0
[Agg2-Vlanif10]quit
[Agg2]interface Vlanif106
[Agg2-Vlanif106] ip address 10.1.89.8 255.255.255.0
[Agg2-Vlanif106]quit
[Agg2]interface LoopBack0
[Agg2-LoopBack0] ip address 10.1.8.8 255.255.255.255
[Agg2-LoopBack0]quit

模拟高校 中小型企业网络搭建配置案例_交换机_16

拷贝代码quit
interface Vlanif10
ip address 192.168.10.2 255.255.255.0
quit
interface Vlanif106
ip address 10.1.89.8 255.255.255.0
quit
interface LoopBack0
ip address 10.1.8.8 255.255.255.255
quit
1.3.4 进行Core1的地址配置

<Huawei>system-view
[Huawei]sysname Core1
[Core1]interface GigabitEthernet0/0/0
[Core1-GigabitEthernet0/0/0] ip address 210.28.1.2 255.255.255.224
[Core1-GigabitEthernet0/0/0]quit
[Core1]interface GigabitEthernet0/0/1
[Core1-GigabitEthernet0/0/1] ip address 10.1.79.9 255.255.255.0
[Core1-GigabitEthernet0/0/1]quit
[Core1]interface GigabitEthernet0/0/2
[Core1-GigabitEthernet0/0/2] ip address 10.1.89.9 255.255.255.0
[Core1-GigabitEthernet0/0/2]quit
[Core1]interface GigabitEthernet2/0/0
[Core1-GigabitEthernet2/0/0] ip address 10.3.69.9 255.255.255.0
[Core1-GigabitEthernet2/0/0]quit
[Core1]interface GigabitEthernet2/0/2
[Core1-GigabitEthernet2/0/2] ip address 10.2.69.9 255.255.255.0
[Core1-GigabitEthernet2/0/2]quit
[Core1]interface LoopBack0
[Core1-LoopBack0] ip address 10.1.9.9 255.255.255.255
[Core1-LoopBack0]quit

模拟高校 中小型企业网络搭建配置案例_路由器_17

拷贝代码system-view 
sysname Core1
interface GigabitEthernet0/0/0
ip address 210.28.1.2 255.255.255.224
quit
interface GigabitEthernet0/0/1
ip address 10.1.79.9 255.255.255.0
quit
interface GigabitEthernet0/0/2
ip address 10.1.89.9 255.255.255.0
quit
interface GigabitEthernet2/0/0
ip address 10.3.69.9 255.255.255.0
quit
interface GigabitEthernet2/0/2
ip address 10.2.69.9 255.255.255.0
quit
interface LoopBack0
ip address 10.1.9.9 255.255.255.255
quit
1.3.5 进行Core3的地址配置

<Huawei>system-view
[Huawei]sysname Core3
[Core3]interface GigabitEthernet0/0/0
[Core3-GigabitEthernet0/0/0] ip address 223.2.1.2 255.255.255.192
[Core3-GigabitEthernet0/0/0]quit
[Core3]interface GigabitEthernet0/0/1
[Core3-GigabitEthernet0/0/1] ip address 10.1.56.6 255.255.255.0
[Core3-GigabitEthernet0/0/1]quit
[Core3]interface GigabitEthernet0/0/2
[Core3-GigabitEthernet0/0/2] ip address 10.1.201.6 255.255.255.0
[Core3-GigabitEthernet0/0/2]quit
[Core3]interface GigabitEthernet2/0/0
[Core3-GigabitEthernet2/0/0] ip address 10.3.69.6 255.255.255.0
[Core3-GigabitEthernet2/0/0]quit
[Core3]interface GigabitEthernet2/0/2
[Core3-GigabitEthernet2/0/2] ip address 10.2.69.6 255.255.255.0
[Core3-GigabitEthernet2/0/2]quit
[Core3]interface LoopBack0
[Core3-LoopBack0] ip address 10.1.128.6 255.255.255.255
[Core3-LoopBack0]quit

模拟高校 中小型企业网络搭建配置案例_交换机_18

拷贝代码system-view 
sysname Core3
interface GigabitEthernet0/0/0
ip address 223.2.1.2 255.255.255.192
quit
interface GigabitEthernet0/0/1
ip address 10.1.56.6 255.255.255.0
quit
interface GigabitEthernet0/0/2
ip address 10.1.201.6 255.255.255.0
quit
interface GigabitEthernet2/0/0
ip address 10.3.69.6 255.255.255.0
quit
interface GigabitEthernet2/0/2
ip address 10.2.69.6 255.255.255.0
quit
interface LoopBack0
ip address 10.1.128.6 255.255.255.255
quit
1.3.6 进行Agg3的地址配置

[Agg3]interface Vlanif50
[Agg3-Vlanif50] ip address 192.168.50.254 255.255.255.0
[Agg3-Vlanif50]quit
[Agg3]interface Vlanif108
[Agg3-Vlanif108] ip address 10.1.56.5 255.255.255.0
[Agg3-Vlanif108]quit
[Agg3]interface LoopBack0
[Agg3-LoopBack0] ip address 10.1.128.5 255.255.255.255
[Agg3-LoopBack0]quit

模拟高校 中小型企业网络搭建配置案例_网络搭建_19

拷贝代码interface Vlanif50
ip address 192.168.50.254 255.255.255.0
quit
interface Vlanif108
ip address 10.1.56.5 255.255.255.0
quit
interface LoopBack0
ip address 10.1.128.5 255.255.255.255
quit
1.3.7 进行DC1的地址配置

[DC1]interface Vlanif201
[DC1-Vlanif201] ip address 10.1.201.5 255.255.255.0
[DC1-Vlanif201]quit

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_20

拷贝代码interface Vlanif201
ip address 10.1.201.5 255.255.255.0
quit
1.3.8 进行SR1的地址配置

<Huawei>system-view
[Huawei]sysname SR1
[SR1]interface GigabitEthernet0/0/0
[SR1-GigabitEthernet0/0/0] ip address 210.28.1.1 255.255.255.224
[SR1-GigabitEthernet0/0/0]quit
[SR1]interface GigabitEthernet0/0/1
[SR1-GigabitEthernet0/0/1] ip address 223.2.1.1 255.255.255.192
[SR1-GigabitEthernet0/0/1]quit
[SR1]interface GigabitEthernet0/0/2
[SR1-GigabitEthernet0/0/2] ip address 14.1.1.2 255.255.255.252
[SR1-GigabitEthernet0/0/2]quit

模拟高校 中小型企业网络搭建配置案例_交换机_21

拷贝代码system-view 
sysname SR1
interface GigabitEthernet0/0/0
ip address 210.28.1.1 255.255.255.224
quit
interface GigabitEthernet0/0/1
ip address 223.2.1.1 255.255.255.192
quit
interface GigabitEthernet0/0/2
ip address 14.1.1.2 255.255.255.252
quit
1.3.9 进行Taobao1的地址配置

<Huawei>system-view
[Huawei]sysname Taobao1
[Taobao1]interface GigabitEthernet0/0/2
[Taobao1-GigabitEthernet0/0/2] ip address 14.1.1.1 255.255.255.252
[Taobao1-GigabitEthernet0/0/2]quit
[Taobao1]interface LoopBack0
[Taobao1-LoopBack0] ip address 14.4.4.4 255.255.255.255
[Taobao1-LoopBack0]quit

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_22

拷贝代码system-view 
sysname Taobao1
interface GigabitEthernet0/0/2
ip address 14.1.1.1 255.255.255.252
quit
interface LoopBack0
ip address 14.4.4.4 255.255.255.255
quit

1.4 配置MSTP

为了防止 Acc1、Acc2、Agg1、Agg2 之间出现环路,使用设备默认支持的 MSTP。
Agg1 为 instance 0 的根桥, Agg2 为 instance 0 的备份根桥。
通过配置桥优先级值来明确根桥(桥优先级为 0)、备份根桥(桥优先级为 4096) 的角色。

1.4.1 进行Agg1的STP优先级配置

[Agg1]stp priority 0

模拟高校 中小型企业网络搭建配置案例_路由器_23

拷贝代码stp priority 0 
1.4.2 进行Agg2的STP优先级配置

[Agg2]stp priority 4096

模拟高校 中小型企业网络搭建配置案例_交换机_24

拷贝代码stp priority 4096

1.5 VRRP

Agg1 和 Agg2 作为研究生教学的网关,为了保证业务网段的可靠性和连续性,要求在Agg1 和 Agg2 上配置 VRRP 来实现网关的备份。
1. VLAN 10 使用 VRRP 备份组 1,VRRP 备份组 1 虚拟 IP 地址为 192.168.10.254。
2. VRRP 备份组 1 以 Agg1 为主网关(优先级为 200),Agg2 作为备份网关(优先级为缺省)。

1.5.1 进行Agg1的VRRP配置

[Agg1]interface Vlanif10
[Agg1-Vlanif10]vrrp vrid 1 virtual-ip 192.168.10.254
[Agg1-Vlanif10]vrrp vrid 1 priority 200

模拟高校 中小型企业网络搭建配置案例_路由器_25

拷贝代码interface Vlanif10
vrrp vrid 1 virtual-ip 192.168.10.254
vrrp vrid 1 priority 200
1.5.2 进行Agg2的VRRP配置

[Agg2]interface Vlanif10
[Agg2-Vlanif10]vrrp vrid 1 virtual-ip 192.168.10.254

模拟高校 中小型企业网络搭建配置案例_交换机_26

拷贝代码interface Vlanif10
vrrp vrid 1 virtual-ip 192.168.10.254

1.6 DHCP

在大型网络中,一般使用 DHCP 来为终端分配 IP 地址。
本科生教学 1 主机通过 DHCP 获取 IP 地址,Agg3 作为 VLAN 50 的 DHCP 服务器,采用 VLANif50 的接口地址池。

[Agg3]dhcp enable
[Agg3]interface Vlanif50
[Agg3-Vlanif50] dhcp select interface

模拟高校 中小型企业网络搭建配置案例_网络搭建_27

拷贝代码dhcp enable
interface Vlanif50
dhcp select interface

1.7 WLAN

在 NJUPT-GL 校区,使用 Fit AP+AC 的组网方式,为研究生宿舍提供 WLAN 接入。
请根据以下参数进行组网。

模拟高校 中小型企业网络搭建配置案例_交换机_28

1.7.1 配置AP和客户端的DHCP服务器

配置AP在AC1上的DHCP服务器

[AC1]dhcp enable
[AC1]interface Vlanif30
[AC1-Vlanif30] dhcp select interface
[AC1-Vlanif30] dhcp server gateway-list 192.168.30.254
[AC1-Vlanif30]quit

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_29

拷贝代码dhcp enable
interface Vlanif30
dhcp select interface
dhcp server gateway-list 192.168.30.254
quit

配置客户端在Agg1上的DHCP服务器

[Agg1-Vlanif10]quit
[Agg1]dhcp enable
[Agg1]interface Vlanif40
[Agg1-Vlanif40] dhcp select interface

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_30

拷贝代码quit
dhcp enable
interface Vlanif40
dhcp select interface
1.7.2 配置AC源接口地址

[AC1]capwap source interface vlanif30

模拟高校 中小型企业网络搭建配置案例_网络搭建_31

拷贝代码capwap source interface vlanif30
1.7.3 配置SSID模板

[AC1]wlan
[AC1-wlan-view]ssid-profile name NJUPT
[AC1-wlan-ssid-prof-NJUPT] ssid NJUPT
[AC1-wlan-ssid-prof-NJUPT]quit

模拟高校 中小型企业网络搭建配置案例_网络搭建_32

拷贝代码wlan
ssid-profile name NJUPT
ssid NJUPT
quit
1.7.4 配置Security模板

[AC1-wlan-view]quit
[AC1]wlan
[AC1-wlan-view]
[AC1-wlan-view] traffic-profile name default
[AC1-wlan-traffic-prof-default]
[AC1-wlan-traffic-prof-default] security-profile name NJUPT
[AC1-wlan-sec-prof-NJUPT]
[AC1-wlan-sec-prof-NJUPT] security wpa-wpa2 psk pass-phrase huawei@123 aes
[AC1-wlan-sec-prof-NJUPT]quit

模拟高校 中小型企业网络搭建配置案例_路由器_33

拷贝代码quit
wlan
traffic-profile name default
security-profile name NJUPT
security wpa-wpa2 psk pass-phrase huawei@123 aes
quit
1.7.5 配置VAP模板

[AC1-wlan-view]quit
[AC1]wlan
[AC1-wlan-view] vap-profile name NJUPT
[AC1-wlan-vap-prof-NJUPT] service-vlan vlan-id 40
[AC1-wlan-vap-prof-NJUPT] ssid-profile NJUPT
[AC1-wlan-vap-prof-NJUPT]quit

模拟高校 中小型企业网络搭建配置案例_交换机_34

拷贝代码wlan
vap-profile name NJUPT
service-vlan vlan-id 40
ssid-profile NJUPT
security-profile NJUPT
quit
1.7.6 配置AP组

[AC1-wlan-view]quit
[AC1]wlan
[AC1-wlan-view]ap-group name g1
[AC1-wlan-ap-group-g1]quit

模拟高校 中小型企业网络搭建配置案例_网络搭建_35

拷贝代码wlan 
ap-group name g1
quit
1.7.7 配置AP上线

[AC1-wlan-view]quit
[AC1]wlan
[AC1-wlan-view] ap-id 0 type-id 69 ap-mac 00e0-fc0f-72c0 ap-sn 210235448310094D735A
[AC1-wlan-ap-0] ap-name AP1
[AC1-wlan-ap-0] ap-group g1
Warning: This operation may cause AP reset. If the country code changes, it will clear channel,power and antenna gain configurations of the radio, Whether to continue? [Y/N]:y
[AC1-wlan-ap-0]quit

模拟高校 中小型企业网络搭建配置案例_华为_36

拷贝代码wlan
ap-id 0 type-id 69 ap-mac 00e0-fc0f-72c0 ap-sn 210235448310094D735A
ap-name AP1
ap-group g1
拷贝代码y
quit
1.7.8 配置射频口

[AC1-wlan-view]quit
[AC1]wlan
[AC1-wlan-view]
[AC1-wlan-view]ap-group name g1
[AC1-wlan-ap-group-g1]
[AC1-wlan-ap-group-g1]vap-profile NJUPT wlan 1 radio all
[AC1-wlan-ap-group-g1]
[AC1-wlan-ap-group-g1]quit
[AC1-wlan-view]

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_37

拷贝代码wlan
ap-group name g1
vap-profile NJUPT wlan 1 radio all
quit

1.8 配置OSPF

1.8.1 局域网OSPF配置

1. 在 GL 校区内部,使用 OSPF 协议进行网络互联。Agg1—Core1 之间运行 OSPF,互连网段为 10.1.79.0/24;在 Agg2—Core1 之间运行 OSPF,互连网段为10.1.89.0/24。OSPF 进程号为 1,区域号为 0。
2. 在 XL 校区内部,使用 OSPF 协议进行网络互联。Agg3—Core3 之间运行 OSPF,互连网段为10.1.56.0/24。OSPF 进程号为 1,区域号为 0。
3. DC1—Core3 之间运行 OSPF,互连网段为 10.1.201.0/24。OSPF 进程号为 1,区域号为 0。
4. 在 Agg1、Agg2,将 VLANif10、VLANif40 的直连网段通告入 OSPF 区域 0。
5. 在 Agg3,将 VLANif50 的直连网段通告入 OSPF 区域 0。OSPF 通告时,主机所在的直连网段,整网段宣告;互连网段精确宣告。比如Agg1 的 VLANif10 接口网段,通过 network 192.168.10.0 0.0.0.255 整网段通告;在Agg1 上,与 Core1 互连的 VLANif105 接口网段,通过 network 10.1.79.7 0.0.0.0 精 确通告。

在Agg1上配置OSPF

[Agg1-Vlanif40]quit
[Agg1]ospf 1 router-id 10.1.7.7
[Agg1-ospf-1]area 0.0.0.0
[Agg1-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255
[Agg1-ospf-1-area-0.0.0.0]network 192.168.40.0 0.0.0.255
[Agg1-ospf-1-area-0.0.0.0]network 10.1.79.7 0.0.0.0
[Agg1-ospf-1-area-0.0.0.0]quit
[Agg1-ospf-1]quit

模拟高校 中小型企业网络搭建配置案例_交换机_38

拷贝代码quit
ospf 1 router-id 10.1.7.7
area 0.0.0.0
network 192.168.10.0 0.0.0.255
network 192.168.40.0 0.0.0.255
network 10.1.79.7 0.0.0.0
quit
quit

在Core1上配置OSPF

[Core1]ospf 1 router-id 10.1.9.9
[Core1-ospf-1] area 0.0.0.0
[Core1-ospf-1-area-0.0.0.0] network 10.1.79.9 0.0.0.0
[Core1-ospf-1-area-0.0.0.0] network 10.1.89.9 0.0.0.0
[Core1-ospf-1-area-0.0.0.0]quit
[Core1-ospf-1]quit

模拟高校 中小型企业网络搭建配置案例_网络搭建_39

拷贝代码sys
ospf 1 router-id 10.1.9.9
area 0.0.0.0
network 10.1.79.9 0.0.0.0
network 10.1.89.9 0.0.0.0
quit
quit

在Agg2上配置OSPF

[Agg2-Vlanif10]quit
[Agg2]ospf 1 router-id 10.1.8.8
[Agg2-ospf-1] area 0.0.0.0
[Agg2-ospf-1-area-0.0.0.0] network 10.1.89.8 0.0.0.0
[Agg2-ospf-1-area-0.0.0.0] network 192.168.10.0 0.0.0.255
[Agg2-ospf-1-area-0.0.0.0]quit
[Agg2-ospf-1]quit

模拟高校 中小型企业网络搭建配置案例_华为_40

拷贝代码quit
ospf 1 router-id 10.1.8.8
area 0.0.0.0
network 10.1.89.8 0.0.0.0
network 192.168.10.0 0.0.0.255
quit
quit

在Core3上配置OSPF

[Core3]ospf 1 router-id 10.1.128.6
[Core3-ospf-1] area 0.0.0.0
[Core3-ospf-1-area-0.0.0.0] network 10.1.56.6 0.0.0.0
[Core3-ospf-1-area-0.0.0.0] network 10.1.201.6 0.0.0.0
[Core3-ospf-1-area-0.0.0.0]quit
[Core3-ospf-1]quit

模拟高校 中小型企业网络搭建配置案例_网络搭建_41

拷贝代码sys
ospf 1 router-id 10.1.128.6
area 0.0.0.0
network 10.1.56.6 0.0.0.0
network 10.1.201.6 0.0.0.0
quit
quit

在DC1上配置OSPF

[DC1]ospf 1
[DC1-ospf-1] area 0.0.0.0
[DC1-ospf-1-area-0.0.0.0] network 10.1.201.5 0.0.0.0
[DC1-ospf-1-area-0.0.0.0]quit
[DC1-ospf-1]quit

模拟高校 中小型企业网络搭建配置案例_网络搭建_42

拷贝代码ospf 1
area 0.0.0.0
network 10.1.201.5 0.0.0.0
quit
quit

在Agg3上配置OSPF

[Agg3-Vlanif50]quit
[Agg3]ospf 1 router-id 10.1.128.5
[Agg3-ospf-1] area 0.0.0.0
[Agg3-ospf-1-area-0.0.0.0] network 192.168.50.0 0.0.0.255
[Agg3-ospf-1-area-0.0.0.0] network 10.1.56.5 0.0.0.0
[Agg3-ospf-1-area-0.0.0.0]quit
[Agg3-ospf-1]quit

模拟高校 中小型企业网络搭建配置案例_华为_43

拷贝代码quit
ospf 1 router-id 10.1.128.5
area 0.0.0.0
network 192.168.50.0 0.0.0.255
network 10.1.56.5 0.0.0.0
quit
quit
1.8.2 OSPF选路配置

在 GL—XL 校区间,从 2 个运营商,分别租了 1 条 WAN 链路:从运营商 ISP1 租用裸光纤(命名为WAN1);从运营商 ISP2 租用 WDM 电路(命名为 WAN2。在实验中,采用S57 模拟 WDM 设备 T1、T2)。
1. 通过 WAN1、WAN2,Core1—Core3 建立 2 对 OSPF 邻居。
2. GL—XL 校区间互通优选 WAN2:WAN1 的 OSPF 链路 cost=3,WAN2 的 OSPF 链路cost=1。cost 已预配
3. 研究生宿舍 1、研究生教学 1、本科生教学 1,可以互相 ping 通。

在Core1上做OSPF的配置并修改G2/0/0口的开销为3

[Core1-ospf-1]ospf 1 router-id 10.1.9.9
[Core1-ospf-1] area 0
[Core1-ospf-1-area-0.0.0.0] network 10.2.69.9 0.0.0.0
[Core1-ospf-1-area-0.0.0.0] network 10.3.69.9 0.0.0.0
[Core1-ospf-1-area-0.0.0.0]interface GigabitEthernet2/0/0
[Core1-GigabitEthernet2/0/0] ospf cost 3
[Core1-GigabitEthernet2/0/0]quit

模拟高校 中小型企业网络搭建配置案例_交换机_44

拷贝代码ospf 1 router-id 10.1.9.9  
area 0
network 10.2.69.9 0.0.0.0
network 10.3.69.9 0.0.0.0
interface GigabitEthernet2/0/0
ospf cost 3
quit

在Core3上做OSPF的配置并修改G2/0/0口的开销为3

[Core3]ospf 1 router-id 10.1.128.6
[Core3-ospf-1] area 0
[Core3-ospf-1-area-0.0.0.0] network 10.2.69.6 0.0.0.0
[Core3-ospf-1-area-0.0.0.0] network 10.3.69.6 0.0.0.0
[Core3-ospf-1-area-0.0.0.0]interface GigabitEthernet2/0/0
[Core3-GigabitEthernet2/0/0]ospf cost 3

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_45

拷贝代码ospf 1 router-id 10.1.128.6  
area 0
network 10.2.69.6 0.0.0.0
network 10.3.69.6 0.0.0.0
interface GigabitEthernet2/0/0
ospf cost 3
1.8.3 OSPF和BFD联动配置

T1—T2 之间的光缆被挖断后,Core1、Core3 需要 40s(OSPF 的 dead-interval)才能感知该故障。
为了缩短该段光缆故障的感知时间,在 Core1、Core3 配置 OSPF 与 BFD 联动:BFD 的最小发送、接收间隔,都设为 30ms。
这样,T1—T2 之间的光缆被挖断后,Core1、Core3 仅需要 90ms 就能够感知该故障。

在Core1上配置BFD,并修改BFD报文发送的时间间隔

[Core1]bfd
[Core1-bfd]quit
[Core1]ospf 1
[Core1-ospf-1] bfd all-interfaces enable
[Core1-ospf-1]quit
[Core1]interface GigabitEthernet2/0/0
[Core1-GigabitEthernet2/0/0] ospf bfd enable
[Core1-GigabitEthernet2/0/0] ospf bfd min-tx-interval 30 min-rx-interval 30
[Core1-GigabitEthernet2/0/0]quit
[Core1]interface GigabitEthernet2/0/2
[Core1-GigabitEthernet2/0/2] ospf bfd enable
[Core1-GigabitEthernet2/0/2] ospf bfd min-tx-interval 30 min-rx-interval 30
[Core1-GigabitEthernet2/0/2]quit

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_46

拷贝代码bfd
quit
ospf 1
bfd all-interfaces enable
quit
interface GigabitEthernet2/0/0
ospf bfd enable
ospf bfd min-tx-interval 30 min-rx-interval 30
quit
interface GigabitEthernet2/0/2
ospf bfd enable
ospf bfd min-tx-interval 30 min-rx-interval 30
quit

在Core3上配置BFD,并修改BFD报文发送的时间间隔

[Core3-GigabitEthernet2/0/0]quit
[Core3]ospf 1
[Core3-ospf-1] bfd all-interfaces enable
[Core3-ospf-1]quit
[Core3]interface GigabitEthernet2/0/0
[Core3-GigabitEthernet2/0/0] ospf bfd enable
[Core3-GigabitEthernet2/0/0] ospf bfd min-tx-interval 30 min-rx-interval 30
[Core3-GigabitEthernet2/0/0]quit
[Core3]interface GigabitEthernet2/0/2
[Core3-GigabitEthernet2/0/2] ospf bfd enable
[Core3-GigabitEthernet2/0/2] ospf bfd min-tx-interval 30 min-rx-interval 30

模拟高校 中小型企业网络搭建配置案例_网络搭建_47

拷贝代码quit
bfd
ospf 1
bfd all-interfaces enable
quit
interface GigabitEthernet2/0/0
ospf bfd enable
ospf bfd min-tx-interval 30 min-rx-interval 30
quit
interface GigabitEthernet2/0/2
ospf bfd enable
ospf bfd min-tx-interval 30 min-rx-interval 30

1.9 BGP

跨组织间的路由学习,必须通过 EBGP 协议。本实验中,某网上购物 ICP 的 Taobao1路由器与教育网的 SR1 路由器之间,通过 EBGP 互通。
1. Taobao1—SR1 通过互连接口建立 EBGP 邻居。
2. Taobao1 在 AS 24429,将业务地址 14.4.4.4/32,通过 network 通告到 BGP。
3. SR1 在 AS 4538,将直连网段 210.28.1.0/27、223.2.1.0/26,通过 network 通告到BGP。
Taobao1 学习到 210.28.1.0/27、223.2.1.0/26,SR1 学习到 14.4.4.4/32。

在Taobao1上配置BGP

[Taobao1]bgp 24429
[Taobao1-bgp] peer 14.1.1.2 as-number 4538
[Taobao1-bgp] network 14.4.4.4 255.255.255.255
[Taobao1-bgp]quit

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_48

拷贝代码sys
bgp 24429
peer 14.1.1.2 as-number 4538
network 14.4.4.4 255.255.255.255
quit

在SR1上配置BGP

[SR1]bgp 4538
[SR1-bgp] peer 14.1.1.1 as-number 24429
[SR1-bgp] network 210.28.1.0 255.255.255.224
[SR1-bgp] network 223.2.1.0 255.255.255.192
[SR1-bgp]quit

模拟高校 中小型企业网络搭建配置案例_华为_49

拷贝代码sys
bgp 4538
peer 14.1.1.1 as-number 24429
network 210.28.1.0 255.255.255.224
network 223.2.1.0 255.255.255.192
quit

1.10 静态路由

Core1 通过静态默认路由访问 Internet,下一跳为 210.28.1.1。
Core3 通过静态默认路由访问 Internet,下一跳为 223.2.1.1。

在Core1上配置静态路由

[Core1]ip route-static 0.0.0.0 0.0.0.0 210.28.1.1

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_50

拷贝代码ip route-static 0.0.0.0 0.0.0.0 210.28.1.1

在Core3上配置静态路由

[Core3-GigabitEthernet2/0/2]quit
[Core3]ip route-static 0.0.0.0 0.0.0.0 223.2.1.1

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_51

拷贝代码quit
ip route-static 0.0.0.0 0.0.0.0 223.2.1.1

1.11 OSPF引入路由

在 Core1,将静态默认路由引入 OSPF。

[Core1]ospf 1
[Core1-ospf-1] default-route-advertise always
[Core1-ospf-1] import-route static
[Core1-ospf-1]quit

模拟高校 中小型企业网络搭建配置案例_网络搭建_52

拷贝代码ospf 1
default-route-advertise always
import-route static
quit

在 Core3,将静态默认路由引入 OSPF。

[Core3]ospf 1
[Core3-ospf-1] default-route-advertise always
[Core3-ospf-1] import-route static

模拟高校 中小型企业网络搭建配置案例_网络搭建_53

拷贝代码ospf 1
default-route-advertise always
import-route static

1.12 NAT配置

1. 在 Core1 的 GE0/0/0,通过 NAPT,将 192.168.0.0/16 的私网地址,转换为210.28.1.3—210.28.1.30 的公网地址。
2. 在 Core3 的 GE0/0/0,通过 NAPT,将 192.168.0.0/16 的私网地址,转换为223.2.1.3—223.2.1.30 的公网地址。
以上 ACL 均使用基本 ACL,编号 2000,rule 编号从 5 开始,采用默认步长。NAT address-group 的编号为 1。
研究生宿舍 1、研究生教学 1、本科生教学 1,都能够 ping 通 Taobao1 的业务地址14.4.4.4,实现网上购物的网络层可达。

1.12.1 在Core1上配置NAT

在Core1上配置ACL 2000

[Core1]acl number 2000
[Core1-acl-basic-2000] rule 5 permit source 192.168.10.0 0.0.0.255
[Core1-acl-basic-2000] rule 10 permit source 192.168.40.0 0.0.0.255
[Core1-acl-basic-2000]quit

模拟高校 中小型企业网络搭建配置案例_路由器_54

拷贝代码acl number 2000  
rule 5 permit source 192.168.10.0 0.0.0.255
rule 10 permit source 192.168.40.0 0.0.0.255
quit

在Core1上配置地址池

[Core1]nat address-group 1 210.28.1.3 210.28.1.30

模拟高校 中小型企业网络搭建配置案例_华为_55

拷贝代码nat address-group 1 210.28.1.3 210.28.1.30

在Core1上配置nat

[Core1]interface GigabitEthernet0/0/0
[Core1-GigabitEthernet0/0/0] nat outbound 2000 address-group 1

模拟高校 中小型企业网络搭建配置案例_华为_56

拷贝代码interface GigabitEthernet0/0/0
nat outbound 2000 address-group 1
1.12.2 在Core3上配置NAT

在Core3上配置ACL 2000

[Core3-ospf-1]quit
[Core3]acl number 2000
[Core3-acl-basic-2000] rule 5 permit source 192.168.50.0 0.0.0.255
[Core3-acl-basic-2000]quit

模拟高校 中小型企业网络搭建配置案例_路由器_57

拷贝代码quit
acl number 2000
rule 5 permit source 192.168.50.0 0.0.0.255
quit

在Core3上配置地址池

[Core3] nat address-group 1 223.2.1.3 223.2.1.30

模拟高校 中小型企业网络搭建配置案例_交换机_58

拷贝代码 nat address-group 1 223.2.1.3 223.2.1.30

在Core3上配置NAT

[Core3]interface GigabitEthernet0/0/0
[Core3-GigabitEthernet0/0/0] nat outbound 2000 address-group 1
[Core3-GigabitEthernet0/0/0]quit

模拟高校 中小型企业网络搭建配置案例_华为_59

拷贝代码interface GigabitEthernet0/0/0
nat outbound 2000 address-group 1
quit

2.实验验证

2.1 查看OSPF邻居表

查看Core1的OSPF邻居表

<Core1>display ospf peer brief

模拟高校 中小型企业网络搭建配置案例_华为_60

拷贝代码display ospf peer brief

查看Core3的OSPF邻居表

<Core3>display ospf peer brief

模拟高校 中小型企业网络搭建配置案例_华为_61

拷贝代码display ospf peer brief 
2.2 查看BGP邻居表

查看Taobao1的BGP邻居表
<Taobao1>display bgp peer

模拟高校 中小型企业网络搭建配置案例_网络搭建_62

拷贝代码display bgp peer
2.3 查看网关设备的路由表

查看Agg1的路由表
<Agg1>display ip routing-table

模拟高校 中小型企业网络搭建配置案例_路由器_63

拷贝代码display ip routing-table 

查看Agg2的路由表

<Agg2>display ip routing-table

模拟高校 中小型企业网络搭建配置案例_华为_64

拷贝代码display ip routing-table 

查看Agg3的路由表

<Agg3>display ip routing-table

模拟高校 中小型企业网络搭建配置案例_交换机_65

拷贝代码display ip routing-table 

查看Taobao1的路由表
<Taobao1>display ip routing-table

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_66

拷贝代码display ip routing-table 

查看SR1的路由
<SR1>display ip routing-table

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_67

拷贝代码display ip routing-table 
2.4 查看AP的状态

<AC1>display ap all

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_68

拷贝代码display ap all
2.5 查看终端地址获取情况

点击无线终端研究生宿舍1 连接无线信号,选择其中一个SSID,输入密码huawei@123。输入完成后,点击确定。

模拟高校 中小型企业网络搭建配置案例_华为_69

查看无线终端地址获取情况

STA>ipconfig

模拟高校 中小型企业网络搭建配置案例_路由器_70

拷贝代码ipconfig

查看有线终端本科生教学1的地址获取情况

PC>ipconfig

模拟高校 中小型企业网络搭建配置案例_交换机_71

拷贝代码ipconfig
2.6 查看终端业务互通性

从终端本课程教学1ping测研究生教学1和研究生宿舍1

PC>ping 192.168.10.10
PC>ping 192.168.40.253

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_72

拷贝代码ping 192.168.10.10
拷贝代码ping 192.168.40.253

从研究生教学1ping测研究生宿舍1

PC>ping 192.168.40.253

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_73

拷贝代码ping 192.168.40.253
2.7 查看是否可上网

从所有终端分别ping测14.4.4.4

PC>ping 14.4.4.4

模拟高校 中小型企业网络搭建配置案例_中小型企业网络搭建及运维_74

拷贝代码ping 14.4.4.4

模拟高校 中小型企业网络搭建配置案例_华为_75

拷贝代码ping 14.4.4.4

模拟高校 中小型企业网络搭建配置案例_路由器_76

拷贝代码ping 14.4.4.4