今天想安装一个MYSQL Migration Toolkit,在网上下载了mysql-workbench-gpl-5.2.36-win32.msi和mysql-gui-tools-5.0-r17-win32.msi,并安装成功,但是每次启动MySQLMigrationTool.exe的时候都报错误:

MySQL Generic Runtime Environment 2.0.12 Type 'help' or '?' for help. Type 'quit' to exit the shell.Lua Shell initialized.Registered 12 struct definition files.Initializing native loader...Initializing Java loader...ERROR: The JRE 1.4 or newer cannot be found.Please make sure the Sun JRE 1.4 or newer is installed correctly.Verify the following registry key:HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.4\RuntimeLib Error initializing Java module loader (10012). Please check the .\java and .\java\lib directories.Initializing Lua loader...Initializing Python loader...Registered 5 builtin modules.Registered 13 Lua modules. /

后来按照网上的教程修给了注册表:[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.4]"RuntimeLib",导入注册表的文件内容如下:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.4]

"RuntimeLib"="D:\\Program Files (x86)\\Java\\jre6\\bin\\client\\jvm.dll"

但是依然不能解决问题。最后突然想到,我当前系统安装的MYSQL Migration Toolkit是i586也就是32位的,而当前系统的JRE是x64也就是64位的,我想可能是因为这两者之间存在不兼容。后来我在网上下载了32位的JRE:jre-6u30-windows-i586.exe。最后问题就解决了。

 


 


作者:xwdreamer