​LINUX动态库(.SO)搜索路径(目录)设置方法​

 

[root@VM_0_11_centos ld.so.conf.d]# cat /etc/ld.so.conf

include ld.so.conf.d/*.conf

[root@VM_0_11_centos ld.so.conf.d]# ll -as /etc/ld.so.conf.d/

total 36

4 drwxr-xr-x. 2 root root 4096 Mar 6 21:39 .

12 drwxr-xr-x. 99 root root 12288 Mar 9 20:50 ..

4 -rw-r--r-- 1 root root 26 Aug 8 2019 bind-export-x86_64.conf

4 -rw-r--r-- 1 root root 19 Aug 9 2019 dyninst-x86_64.conf

4 -r--r--r-- 1 root root 63 Feb 5 07:07 kernel-3.10.0-1062.12.1.el7.x86_64.conf

4 -r--r--r-- 1 root root 63 Dec 6 23:53 kernel-3.10.0-1062.9.1.el7.x86_64.conf

4 -rw-r--r-- 1 root root 17 Aug 8 2019 mariadb-x86_64.conf

[root@VM_0_11_centos ld.so.conf.d]# cat mariadb-x86_64.conf

/usr/lib64/mysql

[root@VM_0_11_centos ld.so.conf.d]# cat dyninst-x86_64.conf

/usr/lib64/dyninst

 

编辑

/etc/ld.so.conf

 

[root@VM_0_11_centos bin]# openssl

openssl: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory

[root@VM_0_11_centos bin]# ln -s /usr/local/openssl-1.1.1d/libssl.so.1.1 /usr/lib64/libssl.so.1.1

[root@VM_0_11_centos bin]# openssl

openssl: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory

[root@VM_0_11_centos bin]# ln -s /usr/local/openssl-1.1.1d/libcrypto.so.1.1 /usr/lib64/libcrypto.so.1.1

[root@VM_0_11_centos bin]# openssl

OpenSSL> ^C

 

checking for openssl/ssl.h in /usr/local/bin/openssl... no

 

LibreSSL is lacking host and IP verify parameters · Issue #381 · libressl-portable/portable https://github.com/libressl-portable/portable/issues/381

 

The following modules found by detect_modules() in setup.py, have been

built by the Makefile instead, as configured by the Setup files:

_abc atexit pwd

time

Failed to build these modules:

_ctypes

Following modules built successfully but were removed because they could not be imported:

_hashlib _ssl

Could not build the ssl module!

Python requires an OpenSSL 1.0.2 or 1.1 compatible libssl with X509_VERIFY_PARAM_set1_host().

LibreSSL 2.6.4 and earlier do not provide the necessary APIs, https://github.com/libressl-portable/portable/issues/381

 

 

更新  编译安装 openssl版本

 


LINUX动态库(.SO)搜索路径(目录)设置方法_github

 

 

 

checking whether compiling and linking against OpenSSL works... yes

checking for X509_VERIFY_PARAM_set1_host in libssl... yes