我是用的是LINUX,版本信息

Linux bogon 2.6.9-67.ELsmp #1 SMP Wed Nov 7 13:58:04 EST 2007 i686 i686 i386 GNU/Linux
[root@bogon jdk]# lsb_release -a
LSB Version: :core-3.0-ia32:core-3.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch
Distributor ID: RedHatEnterpriseAS
Description: Red Hat Enterprise Linux AS release 4 (Nahant Update 6)
Release: 4
Codename: NahantUpdate6

执行过程:

invoke jdk1.8 报错 “/lib/tls/libc.so.6: version `GLIBC_2.4

在安装配置完成后,验证java版本时出错;

invoke jdk1.8 报错 “/lib/tls/libc.so.6: version `GLIBC_2.4

就是找不到GLIBC_2.4这个版本,于是我查看自己OS拥有的GLIBC的版本。

invoke jdk1.8 报错 “/lib/tls/libc.so.6: version `GLIBC_2.4

确实没有GLIBC_2.4

于是查了各种资料

invoke jdk1.8 报错 “/lib/tls/libc.so.6: version `GLIBC_2.4

invoke jdk1.8 报错 “/lib/tls/libc.so.6: version `GLIBC_2.4

结论就是我的系统太旧了,不支持1.6以上的版本了;