hdu 3782 xxx定律
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2220    Accepted Submission(s): 1721


Problem Description
对于一个数n,如果是偶数,就把n砍掉一半;如果是奇数,把n变成 3*n+ 1后砍掉一半,直到该数变为1为止。
请计算需要经过几步才能将n变到1,具体可见样例。
 

Input
测试包含多个用例,每个用例包含一个整数n,当n为0 时表示输入结束。(1<=n<=10000)
 

Output
对于每组测试用例请输出一个数,表示需要经过的步数,每组输出占一行。


Sample Input
3
1
0
 


Sample Output
5
0
 
/*题解:
    水题,注意用位运算 
    */


#include<cstdio>
int main()
{
    int n,t;
    while(scanf("%d",&n),n)
    {
        t=0;
        while(n!=1)
        {
            if(n&1)   //n%2 
            {
                n=3*n+1;
                n>>=1;    //n除以2 
            }
            else
            {
                n>>=1;
            }
            t++;
        }
        printf("%d\n",t);
    }
    return 0;
}