In a computer network a link L, which interconnects two servers, is considered critical if there are at
least two servers A and B such that all network interconnection paths between A and B pass through L.
Removing a critical link generates two disjoint sub–networks such that any two servers of a sub–network
are interconnected. For example, the network shown in figure 1 has three critical links that are marked
bold: 0 -1, 3 - 4 and 6 - 7.
Figure 1: Critical links
It is known that:
1. the connection links are bi–directional;
2. a server is not directly connected to itself;
3. two servers are interconnected if they are directly connected or if they are interconnected with
the same server;
4. the network can have stand–alone sub–networks.
Write a program that finds all critical links of a given computer network.
Input
The program reads sets of data from a text file. Each data set specifies the structure of a network and
has the format:
no of servers
server0 (no of direct connections) connected server . . . connected server
. . .
serverno of servers (no of direct connections) connected server . . . connected server
The first line contains a positive integer no of servers(possibly 0) which is the number of network
servers. The next no of servers lines, one for each server in the network, are randomly ordered and
show the way servers are connected. The line corresponding to serverk, 0 ≤ k ≤ no of servers − 1,
specifies the number of direct connections of serverk and the servers which are directly connected to
serverk. Servers are represented by integers from 0 to no of servers − 1. Input data are correct. The
first data set from sample input below corresponds to the network in figure 1, while the second data
set specifies an empty network.
Output
The result of the program is on standard output. For each data set the program prints the number of
critical links and the critical links, one link per line, starting from the beginning of the line, as shown
in the sample output below. The links are listed in ascending order according to their first element.
The output for the data set is followed by an empty line.
Sample Input
8
0 (1) 1
1 (3) 2 0 3
2 (2) 1 3
3 (3) 1 2 4
4 (1) 3
7 (1) 6
6 (1) 7
5 (0)
0
Sample Output
3 critical links
0 - 1
3 - 4
6 - 7
0 critical links


求桥模板

输入的时候处理一下就ok

///tarjan算法求无向图(可有重边)的桥、边双连通分量并缩点
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
using namespace std;
const int SIZE = 1000010;
int head[SIZE], ver[SIZE * 2], Next[SIZE * 2];
///head[i]=x表示以i起点的数组下标,ver[x]表示以i起点的终点编号
///next[x]=y下一个表示以i起点的数组下标 ,ver[y]表示另一个以i起点的终点编号
int dfn[SIZE], low[SIZE];
///dfn表示时间戳
///low表示追溯值,c[x]表示结点x属于边连通分量的编号
int n, m, tot,num;
bool bridge[SIZE * 2]; ///是否是桥
struct node
{
int u,v;
node(int x,int y)
{
u=x;v=y;
}
};
vector<node>ans;
void add(int x, int y) {
ver[++tot] = y, Next[tot] = head[x], head[x] = tot;
}
void init()
{
tot=1;
num=0;
memset(dfn,0,sizeof(dfn));
memset(low,0,sizeof(low));
memset(head,0,sizeof(head));
memset(bridge,0,sizeof(bridge));
ans.clear();
}
void tarjan(int x, int in_edge)
{
dfn[x] = low[x] = ++num;
for (int i = head[x]; i; i = Next[i]) {///遍历每一个结点
int y = ver[i];
if (!dfn[y]) {
tarjan(y, i);
low[x] = min(low[x], low[y]);
if (low[y] > dfn[x]) ///找到桥
{
bridge[i] = bridge[i ^ 1] = true;
}
}
else if (i != (in_edge ^ 1)) ///利用异或性质解决重边
///防止x结点到父亲结点
low[x] = min(low[x], dfn[y]);
}
}
bool cmp(node x,node y)
{
if(x.u==y.u)
return x.v<y.v;
return x.u<y.u;
}
int main()
{
int n,m,u,v;
char c;
while(scanf("%d",&n)!=-1)
{
init();
for(int i=1; i<=n; i++)
{
scanf("%d (%d)",&u,&m);
u++;
for(int i=1; i<=m; i++)
{
scanf("%d",&v);
v++;
if(v<=u) continue;
//cout<<u<<" "<<v<<endl;
add(u,v);
add(v,u);
}
}
for(int i=1; i<=n; i++)
if(!dfn[i]) tarjan(i,0);
for(int i=2;i<tot;i+=2)
{
if(bridge[i])
{
//cout<<ver[i^1]<<" "<<ver[i]<<endl;
ans.push_back(node(ver[i^1],ver[i]));
}
}
sort(ans.begin(),ans.end(),cmp);
printf("%d critical links\n",ans.size());
for(int i=0; i<ans.size(); i++)
printf("%d - %d\n",ans[i].u-1,ans[i].v-1);
printf("\n");
}
return 0;
}