RIP-路由信息协议 V1/V2/NG(IPV6)

– 使用范围:IGP
– 邻居间直接共享路由表;周期更新(30s)和触发更新,使用跳数作为度量;
– 基于UDP520端口工作;
– 支持等开销负载均衡,默认4条,最大6条;
– IOS版本12.4以上支持16条;管理距离120;
– 周期更新的原因:

  1. 没有确认机制
  2. 没有保活机制

1、V1和V2的区别:
V1有类别,V2无类别;
V1无法支持子网划分和汇总,支持连续子网;
V2支持子网划分和CIDR,不支持超网;
V1广播更新–255.255.255.255
V2组播更新–224.0.0.9
V2支持认证

2、计时器:更新计时器,无效计时器,刷新计时器,抑制计时器,触发计时器。

计时器

解释

更新计时器

指运行RIP协议的路由器向所有接口广播自己的全部路由表的时间间隔。在CISCO的IOS软体中缺省时间是30s。为了避免在MA网络中由于系统时延引起的更新同步,在CISCO中的实际更新时间间隔为25.5-30s之间,即30s减去一个在4.5s内的随机值。

无效计时器

针对路由表中的特定路由条目的计时器。路由器每收到一次路由条目就把无效计时器置0,也就是说路由条目每隔无效计时器规定的时间内必须收到该路由条目更新报文。如果没有收到相关条目的跟新报文那么无效计时器超时,路由器就认为该目的不可达,并向所有接口广播不可达的更新报文。无效计时器在IOS中缺省是180s。

刷新计时器

指路由器条目的刷新时间。刷新存在2种意思:1、如果在刷新时间内没有收到更新报文,那么该目的的路由条目将被直接删除;2、在刷新时间内收到更新报文,那么该条目的路由条目的刷新计时器被刷新置0,CISCO中刷新计时器的缺省时间是240s,也就是比无效计时器多了60s。意味着在一条路由条目在180s内没有收到更新报文时,刷新计时器超时。路由条目中该路由被标志位x.x.x.x is possibly down,知道刷新新计时器也超时了该路由条目才删除。在RIP中真正删除路由条目的是刷新计时器超时。

抑制计时器

如果一条路由更新的跳数大于路由表已经记录该路由的跳数,那么将会引起该路由进入长达180S的抑制计时器

触发更新计时器

使用在触发更新中的一种计时器,触发更新计时器使用1-5s的随机值来避免触发更新风暴。

3、防环机制:

机制

解释

水平分割

从此口进不从此口出:仅用于直线拓扑防环,用于减少MA网络的重复更新

最大跳数

15跳,16跳不可达

毒性逆转水平分割

发更新:当网络稳定之后存在断开网络 时,将立即产生跳数为16跳的毒性更新包并发送到邻居路由器来告知邻居该路径不可达,收到该毒性更新包的邻居将立即删除与之有关的路由条目,之后邻居打破水平分割机制将信息再次发出,来标记确认;分为主动发送和超时发送

抑制计时器

路由器如果在相同的接口上收到某个路由条目的距离比原先收到的距离大,那么将启动一个抑制计时器。在抑制计时器的时间内该目的不可到达。抑制计时器主要是在RIP协议中用来防止路由环路,该计时器的原理是引用一个怀疑量,不管是真的还是假的消息,路由器先认为是假消息来避免路由环路。如果在抑制计时器超时时还能接受到该消息,那么这时路由器就认为条消息是真的。

4、配置:
RIPV1

r1(config)#router rip   启动rip
r1(config-router)#version 1 //选择版本1,若不选版本,默认为升级版本1;
宣告:激活 路由
r1(config-router)#network 12.0.0.0
r1(config-router)#network 1.0.0.0

RIPV2

r1(config)#router rip
r1(config-router)#version 2
r1(config-router)#no auto-summary
r1(config-router)#network 12.0.0.0
r1(config-router)#network 1.0.0.0

5、扩展配置:
V2的认证–用于邻居间身份的核实,保障更新的安全性

r1(config)#key chain xx  //先定义秘钥
r1(config-keychain)#key 1
r1(config-keychain-key)#key-string cisco123
r1(config-keychain-key)#exit
r1(config-keychain)#exit
r1(config)#interface s1/1 //再在连接邻居的接口上调用
r1(config-if)#ip rip authentication key-chain xx
r1(config-if)#ip rip authentication mode md5

V2的手工汇总:在更新源路由器上所有更新发出的接口上配置

r2(config)#int s1/0         
r2(config-if)#ip summary-address rip 2.2.2.0 255.255.254.0

被动接口:只接收不发送路由协议信息,只能用于连接用户pc的接口,不得用于连接邻居的接口,否则邻居间无法收发路由信息
只适用与组播或者广播,对单播不影响
单播邻局----周期性的以单播向邻居发送信息,RIP不影响周期性的组播,OSPF EIGRP中会抑制组播更新。

r1(config)#router rip  
r1(config-router)#passive-interface fastEthernet 0/0
r1(config-router)#neighbor 12.1.1.2

加快收敛:修改计时器 30s更新 180s失效 180s抑制 240s刷新 20s睡眠时间
按比例修改计时器可以加快收敛速度,但不易修改过小

r1#show ip protocols 
r1(config)#router rip
r1(config-router)#timers basic 15 90 90 120 //全网设备修改一致

缺省路由–边界路由器上配置命令后,将向内网所有设备发送缺省路由条目;之后本地需要管理员
【1】手工配置静态缺省指向ISP

r3(config)#router rip
r3(config-router)#default-information originate

【2】手工汇总产生缺省路由(汇总产生缺省的路由器不会再发送其他明细路由)

r1(config)#int s1/1
r1(config-if)#ip summary-address rip 0.0.0.0 0.0.0.0

【3】.重发布缺省

【4】.network产生缺省路由(本地存在静态出接口写法的缺省路由,network通告换会不能做)

r1(config)#router rip
r1(config-router)#network 0.0.0.0

可以把静态路由出接口写法network到路由协议中(只支持DV型协议)
相当于

r1(config)#ip route 0.0.0.0 0.0.0.0 null 0

然后network到协议中

【5】.通告default-network定义成默认网络
(存在主类路由,将该主类路由定义为default-network,然后通告进入RIP)

r1(config)#ip default-network

Network通告进入到路由协议中RIP不需要network就会产生缺省EIGRP需要network

干涉选路 ---- 偏移列表
1)修改AD值

r1(config-router)#distance 121 //表示所有的路由AD值全部改为121

还可以和单个邻居修改,后面跟更新源地址和反掩码
2)修改metric值
在控制层面流量进或出的接口上,人为的加大度量值,可以叠加,来干涉选路;

r2(config)#access-list 1 permit 3.3.3.0   使用ACL抓取路由
r2(config)#router rip
r2(config-router)#offset-list 1 out 1 serial 1/0
// ACL 方向 增加的度量 对应的接口

过滤路由
(使用分发列表distribute-list),分发列表自身没有过滤功能,依靠ACL或者prefix-list进行过滤(在使用扩展ACL时,可以使用源(过滤路由所在的路由器的更新源地址)匹配更新源(要过滤的路由),使目标定义过滤的路由,建议使用prefix-list)
注意:使用扩展ACL可以使用源控制网络号,使用目标地址控制网络掩码,但在被distribute-list调用时不生效。
在接口调用时in out方向都可以(但OSPF协议接口调用必须在in方向,重发布必须在out方向)
可以在同种路由器协议传递过程中使用,重发布中使用,适用于DV型

V1和V2兼容
默认V1设备仅收发V1路由,V2设备仅收发V2路由;升级版本1设备,接收1/2,发1;
无论设备此时使用什么版本,均可修改接口收发的版本标准

r1(config)#interface s1/1
r1(config-if)#ip rip receive version 1 2
r1(config-if)#ip rip send version 1 2

V2的设备被修改为发送版本1时,路由将和普通V1路由一致;
V1的设备倍修改为发送版本2时,可以使用目标ip224.0.0.9来发路由,但依然不能携带掩码;

V1的连续子网问题
连续子网—母网相同,掩码一致;可以被汇总
在V1协议中,若本地将发送给邻居的路由条目,与邻居间直连网段是连续子网,那么将携带主机位发送;邻居接收到后,将使用直连网段的掩码来作为这条路由的掩码;

若不能修改接口地址,可以使用第二地址来实现连续子网;

r1(config)#interface s1/1
r1(config-if)#ip address 1.1.3.1 255.255.255.0 secondary

更新源检测
若关闭了更新源检测,直连双方不在同一网段,无法递归路由,导致能学习的路由无法使用,可以在直连之间使用PPP链路(通过学习对方的主机路由来完成递归查找任务)

r1(config)#router rip
r1(config-router)#no validate-update-source

开启V1触发更新
(仅仅在非MA接口上生效,以太网接口(无此命令),FR物理接口,FR多点子接口不生效—有命令但是不生效)— 两端都要开启在低速丙炔点到点网络中有触发更新。

r1(config)#int serial 1/0
r1(config-if)#ip rip triggered

创作者:Eric· Charles