1.修改EIGRP路由条目的AD值

Cisco(config)#access-list 1 permit 2.2.2.2

Cisco(config)#router eigrp 90

Cisco(config-router)#distance 130 12.1.1.2 0.0.0.0 1  

Cisco(config-router)#distance eigrp 130 150

2.修改OSPF路由条目的AD值

Cisco(config)#router ospf 110

Cisco(config-router)#distance 80 2.2.2.2 0.0.0.0 1

Cisco(config-router)#distance ospf external 100 inter-area 80 intra-area 80

3.route-map配置命令

Cisco(config)#route-map rm1 permit 10

Cisco(config-route-map)#match ip address 10.1.1.2

Cisco(config-route-map)#match interface f0/1

Cisco(config-route-map)#match ip next-hop 10.1.1.2

Cisco(config-route-map)#match metric 1

Cisco(config-route-map)#match tag 1

Cisco(config-route-map)#set metric 1

Cisco(config-route-map)#set metric-type type-1

Cisco(config-route-map)#set interface f0/1

Cisco(config-route-map)#set default interface  

Cisco(config-route-map)#set ip next-hop 10.1.1.2

Cisco(config-route-map)#set ip default next-hop 10.1.1.2  

Cisco(config-route-map)#set local-preference 10

Cisco(config-route-map)#set tag 10

Cisco(config)#router eigrp 90

Cisco(config-router)#redistribute ospf 1 route-map rm1 metric 1 10 255 1 1500

Cisco(config)#router ospf 110

Cisco(config-router)#redistribute eigrp 90 subnets

4.分发列表distribute-list配置命令

Cisco(config)#access-list 1 permit 10.1.1.0  

Cisco(config)#router ospf 110

Cisco(config-router)#distribute-list 1 out eigrp  90

Cisco(config-router)#distribute-list 1 in f0/1

5. 前缀列表prefix-list配置命令

Cisco(config)#ip prefix-list 1 permit 10.1.1.0/24  //匹配某条特定路由

Cisco(config)#ip prefix-list 1 permit 0.0.0.0/0   //匹配默认路由

Cisco(config)#ip prefix-list 1 permit 0.0.0.0/0 ge 32  //匹配所有主机路由

Cisco(config)#ip prefix-list 1 permit 0.0.0.0/0 le 32  //匹配所有路由