华为设备配置中型网络WLAN基本业务_网络

1. 配置LAW1和AC1,使AP与AC1之间能够传输CAPWAP报文

[LSW1]vlan batch 10

[LSW1-GigabitEthernet0/0/1port link-type trunk                

[LSW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10  

[LSW1-GigabitEthernet0/0/2]port link-type trunk                

[LSW1-GigabitEthernet0/0/2]port trunk allow-pass vlan 10  

[LSW1-GigabitEthernet0/0/2]port trunk pvid vlan 10

[LSW1-GigabitEthernet0/0/3]port link-type trunk  

[LSW1-GigabitEthernet0/0/3]port trunk pvid vlan 10      

[LSW1-GigabitEthernet0/0/3]port trunk allow-pass vlan 10

[AC1]vlan batch 10

[AC1-GigabitEthernet0/0/2]port link-type trunk  

[AC1-GigabitEthernet0/0/2]port trunk allow-pass vlan 10

2. 配置AC1与上层网络设备互通:配置VLANIF11、12(业务VLAN)和VLANIF20

[AC1]vlan batch 11 12 20

[AC1]int Vlanif 11

[AC1-Vlanif11]ip add 10.1.11.1 24

[AC1-Vlanif11]int Vlanif 12      

[AC1-Vlanif12]ip add 10.1.12.1 24

[AC1-Vlanif12]int Vlanif 20      

[AC1-Vlanif20]ip add 10.1.2.1 24

[AC1]ip route-static 0.0.0.0 0.0.0.0 10.1.2.3  //配置AC的缺省路由

[AC1-GigabitEthernet0/0/1]port link-type access  

[AC1-GigabitEthernet0/0/1]port default vlan 20

3. 配置AC给AP分配IP地址,AR给STA分配IP地址

[AC1]dhcp enable  

[AC1]int Vlanif 10

[AC1-Vlanif10]ip add 10.1.1.1 24

[AC1-Vlanif10]dhcp select interface  //配置AC通过接口地址池为AP分配IP地址

[AC1]int Vlanif 11

[AC1-Vlanif11]dhcp select relay   //AC作为DHCP中继

[AC1-Vlanif11]dhcp relay server-ip 10.1.2.3  //使能DHCP中继探测用户表项功能

[AC1-Vlanif11]int Vlanif 12                

[AC1-Vlanif12]dhcp select relay            

[AC1-Vlanif12]dhcp relay server-ip 10.1.2.3

[AR1]dhcp enable  

[AR1]ip pool sta_pool1

[AR1-ip-pool-sta_pool1]gateway-list 10.1.11.1

[AR1-ip-pool-sta_pool1]network 10.1.11.0 mask 24

[AR1]ip pool sta_pool2

[AR1-ip-pool-sta_pool2]gateway-list 10.1.12.1

[AR1-ip-pool-sta_pool2]network 10.1.12.0 mask 24

[AR1-GigabitEthernet0/0/0]ip add 10.1.2.3 24

[AR1-GigabitEthernet0/0/0]dhcp select global

[AR1]ip route-static 10.1.11.0 24 10.1.2.1

[AR1]ip route-static 10.1.12.0 24 10.1.2.1

4. 配置VLAN pool,用于作为业务VLAN

[AC1]vlan pool sta_pool

[AC1-vlan-pool-sta_pool]vlan 11 12

[AC1-vlan-pool-sta_pool]assignment hash

5. 配置AP上线

[AC1]wlan  

[AC1-wlan-view]ap-group name ap-g1  //创建AP组

[AC1-wlan-view]regulatory-domain-profile name domain1  //创建域管理模板

[AC1-wlan-regulate-domain-domain1]country-code cn  //配置AC的国家码

[AC1-wlan-view]ap-group name ap-g1

[AC1-wlan-ap-group-ap-g1]regulatory-domain-profile domain1  //在AP组下引用域管理模板

[AC1]capwap source interface Vlanif 10  //配置AC的源接口

[AC1]wlan  

[AC1-wlan-view]ap auth-mode mac-auth  

[AC1-wlan-view]ap-id 0 ap-mac 00e0-fc80-2e10

[AC1-wlan-ap-0]ap-name ap1

[AC1-wlan-ap-0]ap-group ap-g1

[AC1-wlan-view]ap-id 1 ap-mac 00e0-fc65-68e0

[AC1-wlan-ap-1]ap-name ap2

[AC1-wlan-ap-1]ap-group ap-g1

 华为设备配置中型网络WLAN基本业务_WLAN_02

6. 配置WLAN业务参数

[AC1]wlan  

[AC1-wlan-view]security-profile name wlan-sec  //创建安全模板

[AC1-wlan-sec-prof-wlan-sec]security wpa2 psk pass-phrase abc@1234 aes  //配置安全策略

[AC1-wlan-view]ssid-profile name wlan-ssid  // 创建SSID模板

[AC1-wlan-ssid-prof-wlan-ssid]ssid wlan-net  //配置SSID名称

[AC1-wlan-view]vap-profile name wlan-vap  //创建VAP模板

[AC1-wlan-vap-prof-wlan-vap]forward-mode tunnel  //配置业务数据转发模式

[AC1-wlan-vap-prof-wlan-vap]service-vlan vlan-pool sta_pool  //配置业务VLAN

[AC1-wlan-vap-prof-wlan-vap]security-profile wlan-sec  //引用安全模板

[AC1-wlan-vap-prof-wlan-vap]ssid-profile wlan-ssid  //引用SSID模板

[AC1-wlan-view]ap-group name ap-g1

[AC1-wlan-ap-group-ap-g1]vap-profile wlan-vap wlan 1 radio all  //配置AP组引用VAP模板

7. 配置AP射频的信道和功率

[AC1-wlan-view]ap-id 0

[AC1-wlan-ap-0]radio 0  //配置AP射频0的信道和功率

[AC1-wlan-radio-0/0]channel 20mhz 6

[AC1-wlan-radio-0/0]eirp 127

[AC1-wlan-radio-0/0]radio 1  //配置AP射频1的信道和功率

[AC1-wlan-radio-0/1]channel 20mhz 149

[AC1-wlan-radio-0/1]eirp 127

8. 验证配置

 华为设备配置中型网络WLAN基本业务_网络_03

 华为设备配置中型网络WLAN基本业务_华为_04