我用的是centos7系统
安装超级简单,一条命令就解决了

yum install -y qt5-default qtcreator

可以看到在安装

[root@localhost 文档]# yum install -y qt5-default qtcreator
已加载插件:fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: mirrors.163.com
* epel: ftp.riken.jp
* extras: mirrors.aliyun.com
* updates: ftp.riken.jp
没有可用软件包 qt5-default。
正在解决依赖关系
--> 正在检查事务
---> 软件包 qt-creator.x86_64.0.4.1.0-5.el7 将被 安装
--> 正在处理依赖关系 qt-creator-data = 4.1.0-5.el7,它被软件包 qt-creator-4.1.0-5.el7.x86_64 需要
--> 正在处理依赖关系 gcc-c++,它被软件包 qt-creator-4.1.0-5.el7.x86_64 需要
--> 正在处理依赖关系 libQt5Designer.so.5(Qt_5)(64bit),它被软件包 qt-creator-4.1.0-5.el7.x86_64 需要
--> 正在处理依赖关系 libQt5DesignerComponents.so.5(Qt_5_PRIVATE_API)(64bit),它被软件包 qt-creator-4.1.0-5.el7.x86_64 需要...

等待安装完成,可以看到qt creator已经安装好了
linux 安装qt5和qtcreator开发工具_依赖关系