Face The Right Way

 POJ - 3276 

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer: N 
Lines 2.. N+1: Line i+1 contains a single character, F or B, indicating whether cowi is facing forward or backward.

Output

Line 1: Two space-separated integers: K and M

Sample Input


7 B B F B F B B


Sample Output


3 3


Hint

For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

题目大意:

给定一个序列,有连个状态,向前和向后如:BFBFBFBFF

F 表示向前,B表示向后

给定一个操作,能够使得连续的K个元素都转换状态,如B变成F,F变成B,

求出最小的K和最小的操作次数M

代码:

#include<iostream>
#include<cstring> 
#include<stdio.h>
using namespace std;
const int MAXN = 5*1e3;
const int INF =0x3f3f3f3f;
int Arr[MAXN];
int f[MAXN];
int N;
	
int cal(int k){
	int res= 0;
	
	memset(f,0,sizeof(int)*MAXN);
	
	int sum =0;
	for(int i=0;i+k<=N;i++){
	
		if((sum+Arr[i])%2!=0){
			f[i] = 1;
			res++;
		}
		sum+=f[i];
		if(i-k+1>=0){
			sum-=f[i-k+1];
		}
	}
		
	for(int i = N-k+1;i<N;i++){
		if((sum+Arr[i])%2!=0){
			return -1;
		}
		
		if(i-k+1>=0){
			sum-=f[i-k+1];
		}
	}
	
	return res;
}

int main(){
	scanf("%d",&N);
	char temp;
	
	for(int i=0;i<N;i++){
		cin>>temp;
		if(temp=='B'){
			Arr[i] = 1;
		}else{
			Arr[i] = 0;
		}
	}
	
	int M =N;
	int mink =1;
	for(int k=1;k<=N;k++){
		
		int m = cal(k);
		
		if(m>=0&&m<M){
			M = m;
			mink = k;
		}
		
	}
	printf("%d %d\n",mink,M);
	return 0;
}