本文简略描述一下在windows环境下安装Flutter。

安装前提

为了安装和运行 Flutter,你的设备必须满足以下条件

  1. 操作系统:Windows 7 或更高版本 (64 位)
  2. 硬盘空间:400MB (不包括Android Studio所占的硬盘空间)
  3. Git工具

获取Flutter SDK

  1. 使用git从github仓库中克隆,然后添加flutter命令行工具到你的PATH环境变量中。
  2. 运行flutter doctor,其运行结果会展示你未安装的依赖。

从git仓库中克隆

​如果这是你第一次在你的设备中安装 Flutter,运行以下命令:

$ git clone -b beta https://github.com/flutter/flutter.git

运行flutter doctor

​在Windows的命令提示符下,运行以下命令来检查你还需要安装哪些依赖:


$ flutter doctor

注:请在Windows命令提示符或PowerShell中运行这个命令,Flutter暂时不支持第三方shell工具,如Git Bash。

这个命令检查你的环境,然后在Windows终端中显示检查结果。Dart SDK与Flutter捆绑在一起了,不需要单独安装Dart SDK。仔细检查其运行输出,获取其未安装的依赖软件(粗体形式),然后根据其提示信息安装。