由于自己的 RHEL 没有注册,因此不能使用自带的 yum 来升级系统或者安装软件。
因为 CentOS RHEL 的完整重新编译版本(当然要相互对应一样的版本号),所以 RHEL 是一定可以用 CentOS yum 源的。
------------------------------------------------------------------------------------------------------------------------------------
一/【删除 RHEL 自带的 yum
# rpm -aq|grep yum|xargs rpm -e --nodeps
------------------------------------------------------------------------------------------------------------------------------------
二/【下载】以下四个文件:
# wget http://mirrors.163.com/centos/5/os/i386/CentOS/yum-3.2.19-18.el5.centos.noarch.rpm
# wget http://mirrors.163.com/centos/5/os/i386/CentOS/yum-metadata-parser-1.1.2-2.el5.i386.rpm
# wget http://mirrors.163.com/centos/5/os/i386/CentOS/python-iniparse-0.2.3-4.el5.noarch.rpm
# wget http://mirrors.163.com/centos/5/os/i386/CentOS/yum-fastestmirror-1.1.16-13.el5.centos.noarch.rpm
------------------------------------------------------------------------------------------------------------------------------------
三/【安装】
# rpm -ivh python-iniparse-0.2.3-4.el5.noarch.rpm
# rpm -ivh yum-metadata-parser-1.1.2-2.el5.i386.rpm
# rpm -ivh yum-3.2.19-18.el5.centos.noarch.rpm
warning: yum-3.2.19-18.el5.centos.noarch.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
error: Failed dependencies:
yum-fastestmirror is needed by yum-3.2.19-18.el5.centos.noarch
# wget ftp://ftp.muug.mb.ca/mirror/centos/5.3/os/x86_64/CentOS/yum-fastestmirror-1.1.16-13.el5.centos.noarch.rpm
# rpm -ivh yum-fastestmirror-1.1.16-13.el5.centos.noarch.rpm
warning: yum-fastestmirror-1.1.16-13.el5.centos.noarch.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
error: Failed dependencies:
yum >= 3.0 is needed by yum-fastestmirror-1.1.16-13.el5.centos.noarch
注意:安装的时候最好几个同时安装,如果单个安装的话可能会出现依赖问题。
出现了相互依赖的问题。

四/# rpm -ivh yum-3.2.19-18.el5.centos.noarch.rpm yum-fastestmirror-1.1.16-13.el5.centos.noarch.rpm

------------------------------------------------------------------------------------------------------------------------------------
五/最后,下载配置文件:
# wget http://sudone.com/download/CentOS-Base.repo -O /etc/yum.repos.d/CentOS-Base.repo
这样就可以用 CentOS yum 源来更新系统和安装软件了。

因为默认的配置文件中服务器地址用的版本号是变量$releasever,所以需要将其替换为实际的版本号,否则是无法连接到服务器的,当前CentOS最新版是5.3,所以我们修改CentOS-Base.repo
vi CentOS-Base.repo
 
在vi编辑器中进行全文件替换
:%s/$releasever/5.3/
 
最后保存退出即可。


------------------------------------------------------------------------------------------------------------------------------------
另外,附上 x86_64 系统使用 CentOS yum 源需要下载的四个包:
wget http://mirrors.163.com/centos/5/os/x86_64/CentOS/yum-3.2.19-18.el5.centos.noarch.rpm
wget http://mirrors.163.com/centos/5/os/x86_64/CentOS/yum-metadata-parser-1.1.2-2.el5.x86_64.rpm
wget http://mirrors.163.com/centos/5/os/x86_64/CentOS/python-iniparse-0.2.3-4.el5.noarch.rpm
wget http://mirrors.163.com/centos/5/os/x86_64/CentOS/yum-fastestmirror-1.1.16-13.el5.centos.noarch.rpm
------------------------------------------------------------------------------------------------------------------------------------
【自动运行 yum
# chkconfig --list yum
# chkconfig --level 3 yum on

控制脚本 /etc/rc.d/init.d/yum,这个控制脚本激活了 /etc/cron.daily/yum.cron,而它又会使 cron 服务来在每日凌晨四点时进行自动的系统更新。