在eclipse上面安装adt来开发android时,打开myeclipse会报错如下:

[2015-05-30 10:14:35 - Android SDK] Error when loading the SDK:
Error: Error parsing D:\android-sdks\system-p_w_picpaths\android-22\android-wear\armeabi-v7a\devices.xml
cvc-complex-type.2.4.d: 发现了以元素 'd:skin' 开头的无效内容。此处不应含有子元素。
Error: Error parsing D:\android-sdks\system-p_w_picpaths\android-22\android-wear\x86\devices.xml
cvc-complex-type.2.4.d: 发现了以元素 'd:skin' 开头的无效内容。此处不应含有子元素

-------------------------------------------------------------------------------------------------------------------------------------------------------

进入sdk目录下,把sdk里面D:\android-sdks\tools\lib\下的devices.xml拷贝到

D:\android-sdks\system-p_w_picpaths\android-22\android-wear\armeabi-v7a\devices.xml

和D:\android-sdks\system-p_w_picpaths\android-22\android-wear\x86\devices.xml进行覆盖后,重启eclipse