出现这个错误的主要原因是,gcc和g++ 版本不兼容


apt-get install gcc-4.4

apt-get install g++-4.4


update-alternatives --install  /usr/bin/g++  g++ /usr/bin/g++-4.4 40

update-alternatives --install  /usr/bin/g++  g++ /usr/bin/g++-4.7 40

update-alternatives --config g++


配置即可