This phenomenon,in which a route is advertised in the wrong direction across a redistributing router,is called route feedback.
Any time a router is performing multual redistribution-the multual sharing of routes between two or more routing protocols-route filters should be used to ensure that routes are advertised in only one direction.
Route filters work by regulating the routes that are entered into,or advertised out of ,the route table.It have no effect on link state advertisements or the link state database.
Case Study: Filtering Specific Routes
router rip
 version 2
 network 192.168.75.0
 distribute-list 1 in serial1
 distirbute-list 2 out serial1
!
ip classless
access-list 1 permit 192.168.73.0
access-list 2 deny 0.0.0.0
access-list 2 permit any
 
When the distribute-list command is configured under link state protocols such as OSPF,the ‘out’ keyword cnanot be used in association with an interface.Because link state protocols do not advertise routes from their routing table as do distance vector prococols,ther are no updates to filter.
Case Study: Route Filtering and Redistribution
Any time a router performs mutual redistribution,the potencial for route feedback exists.
At redistribution points we can fileter by route process or by interface.
When filtering by route process,only the ‘out’ keyword is allowed.After all,it makes no sense to specify something like distribute-list 10 in rip under OSPF.The route has already been entered into the route table by RIP,and OSPF either advertises it (‘out’) or it does not.
Filter by interface:
router ospf 25
 redistribute rip metric 100
 network 172.16.1.254 0.0.0.0 area 25
 network 172.16.8.254 0.0.0.0 area 25
 network 172.16.50.254 0.0.0.0 area 25
 distribute-list 3 in e0/0
 distribute-list 3 in e0/1
 distribute-list 3 in e0/2
!
router rip
 redistribute ospf 25 metric 5
 passive-interface e0/0
 passive-interface e0/1
 passive-interface e0/2
 network 172.16.0.0
 distribute-list 1 in e0/3
 distribute-list 1 in e2/0
 distribute-list 1 in e2/1
!
ip classless
access-list 1 permit 172.16.128.0 0.0.127.255
access-list 3 permit 172.16.0.0 0.0.127.255
Filter by route process.
router ospf 25
 redistribute rip metric 100
 network 172.16.1.254 0.0.0.0 area 25
 network 172.16.50.254 0.0.0.0 area 25
 distribute-list 1 out rip
!
router rip
 redistribute ospf 25 metric 5
 passive-interface e0/3
 passive-interface e2/0
 passive-interface e2/1
 network 172.16.0.0
 distribute-list 3 out ospf 25
!
ip classless
access-list 1 permit 172.16.128.0 0.0.127.255
access-list 3 permit 172.16.0.0 0.0.127.255
Note:
To prevent route feedback,routes must be filtered as they are incoming on an interface,before they are entered into the route tale.
Case Study: A Protocol Migration
(1) Lower the administrative distance of the old routing protocol on all routers.
(2) Add the new routing protocol, and make sure its administrative distance is higher than old
one.Then because of the AD,so no routers will prefer the new routing protocol.
   This approach gives the network administrator time to re-examine the new configurations in each router for accuracy before the conversion.
(3) When the new routing protocol had finished its conversion,changing the old routing protocol back to the higher one.After the old routing protocol’s all timers expired,the new routing protocol will instead of it.
(4) Migration finished.
One final note on using the dual-protocol procedure to migrate to a new routing protocol:
Be Sure you understand the behavior of both protocols.
For example,some protocols,such as EIGRP,do not age out their route entries.Therefore,if EIGRP is being replaced,an additional step of the conversion process is to clear the route tables with the clear ip route * command after the distances have been changed.
Case Study: Multiple Redistribution Points
Method -- 1
Router-1
router ospf 1
 redistribute rip metric 100
 network 192.168.3.1 0.0.0.0 area 0
 distance 130
 distance 110 0.0.255.255 1                //wildcard mask and acl number
!
router rip
 redistribute ospf 1 metric 2
 network 192.168.2.0
 distance 130
 distance 120 192.168.2.1 0.0.0.2
!
ip classless
access-list 1 permit 192.168.4.0
access-list 1 permit 192.168.5.0
access-list 2 permit 192.168.1.0
access-list 2 permit 192.168.6.0
Router-2
router ospf 1
 redistribute rip metric 100
 network 192.168.5.1 0.0.0.0 area 0
 distance 130
 distance 110 0.0.0.0 255.255.255.255 1          //wildcard mask and acl number
!
router rip
 redistribute ospf 1 metric 2
 network 192.168.6.0
 distance 120 192.168.6.1 0.0.0.2
!
ip classless
access-list 1 permit 192.168.3.0
access-list 1 permit 192.168.4.0
access-list 2 permit 192.168.1.0
access-list 2 permit 192.168.2.0
Method --- 2
Router 1
router ospf 1
 redistribute rip metric 100 route-map rip_ospf
 network 192.168.3.1 0.0.0.0 area 0
!
router rip
 redistribute ospf 1 metric 2 route-map ospf_rip
 network 192.168.2.0
!
ip classless
route-map rip_ospf deny 10
 match tag 1
route-map rip_ospf permit 20
 set tag 2
route-map ospf_rip deny 10
 match tag 2
route-map ospf_rip permit 20
 set tag 1
Router-2
router ospf 1
 redistribute rip metric 100 route-map rip_ospf
 network 192.168.5.1 0.0.0.0 area 0
!
router rip
 redistribute ospf 1 metric 2 route-map ospf_rip
 network 192.168.6.0
!
ip classless
route-map rip_ospf deny 10
 match tag 1
route-map rip_ospf permit 20
 set tag 2
route-map ospf_rip deny 10
 match tag 2
route-map ospf_rip permit 20
 set tag 1