ubuntu 18.04 安装opencv3.4.5+opencv_contrib

Ubuntu18.04安装opencv-3.4.5及opencv-contrib

自己也已经安装过很多遍opencv了,自己总结一下吧


安装包下载

注意 opencv与opencv-contrib的版本应该一致

opencv 下载 opencv官网

opencv_contrib 下载 github

ubuntu 18.04 安装opencv3.4.5+opencv_contrib_ubuntuubuntu 18.04 安装opencv3.4.5+opencv_contrib_2d_02这里需要下载opencv的source,opencv_contrib可以下载zip或者tar.gz,但本文下载的是zip

安装依赖包

sudo apt-get update
sudo apt-get upgrade
//依赖包
sudo apt-get install build-essential
sudo apt-get install cmake git libgtk2.0-dev pkg-config libavcodec-dev libavformat-dev libswscale-dev
sudo apt-get install python-dev python-numpy libtbb2 libtbb-dev libjpeg-dev libpng-dev libtiff-dev libjasper-dev libdc1394-22-dev
sudo apt-get install qt5-default ccache libv4l-dev libavresample-dev libgphoto2-dev libopenblas-base libopenblas-dev doxygen openjdk-8-jdk pylint libvtk6-dev
sudo apt-get install pkg-config

在上述依赖库安装完成之后才能开始后续操作。在对上述代码复制时最好一次一句地复制,否则无法安装,终端中会直接跳过,在选择Y/n时无法选择Yes。

可能遇到的问题

其中可能遇见无法安装libjasper-dev的问题,类似下面的页面

XXX@XXX:~/Files/opencv-3.1.0$ sudo apt-get install libjasper-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libjasper-dev

解决方案

sudo add-apt-repository "deb http://security.ubuntu.com/ubuntu xenial-security main"
sudo apt update
sudo apt install libjasper1 libjasper-dev

其中libjasper1是libjasper-dev的依赖包,然后再次安装

sudo apt install libjasper1 libjasper-dev

安装opencv和opencv_contrib

先解压下载的opencv和opencv_contrib包,建议直接将下载下来的包直接放至home地址下,这样,zip格式的解压代码如下:

sudo unzip opencv-3.4.5.zip
sudo unzip opencv_contrib-3.4.5.zip

tar.gz格式解压代码:

sudo tar zxvf opencv_contrib-3.4.5.tar.gz

然后将解压后的contrib文件移动至opencv-3.4.5文件下

sudo cp -r opencv_contrib-3.4.5 opencv-3.4.5

并在opencv-3.4.5文件夹中新建build文件夹用于后续编译和生成。

cd opencv-3.4.5                               #进入opencv文件夹
sudo mkdir build #建立build文件夹方便后续操作

进入bulid文件夹并进行第一次cmake

cd build
sudo cmake -D CMAKE_BUILD_TYPE=Release -D CMAKE_INSTALL_PREFIX=/usr/local -D OPENCV_EXTRA_MODULES_PATH=~/opencv-3.4.5/opencv_contrib-3.4.5/modules/ -D OPENCV_ENABLE_NONFREE=True ..

注意**-DOPENCV_ENABLE_NONFREE=True**别把-D与OPENCV_ENABLE_NONFREE=True分开,这句就是使用nonfree模块,包括sift等有专利权的模块。

注意后面的两点不可省略,代表其他参数默认。

注意 OPENCV_EXTRA_MODULES_PATH 代表你放置opencv_contrib的modules文件夹的真实地址,如果直接将opencv放在home下那地址与上述参数相同,只需要注意版本号即可。

可能遇到的问题

ippicv和face_landmark_model.dat下载失败的解决方案

1 先下载文件

,文件的下载地址可以在提示文件//中找到,直接去该地址下载。或者用百度云下载,链接

链接:ippcv 提取码:wjl1

链接:fippicv和face_landmark_model.dat提取码:wjl1

2 修改相应的文件

打开

自己的地址/opencv-3.4.5/3rdparty/ippicv/ippicv.cmake

做以下修改。 将ippicv.cmake文件下的第47行替换为本地路径

"改为相应地址"           #本地路径,与你自己下载存放的地址相关
#"https://raw.githubusercontent.com/opencv/opencv_3rdparty/${IPPICV_COMMIT}/ippicv/" #原下载地址
#记得改为本地ippcv的地址

更改完ippicv之后,再更改face_landmark_model配置文件,方法大致相同

同样打开

/本地地址/opencv-3.4.5/opencv_contrib-3.4.5/modules/face/CMakeLists.txt

然后将CMakeLists.txt文件的第19行修改为本地路径,即将原来的网址修改为下载的文件保存的路径。这个行数不定,与文件相关,主要是找到网址地址。

"本地地址"     #本地路径,与你自己下载存放的地址相关
#"https://raw.githubusercontent.com/opencv/opencv_3rdparty/${__commit_hash}/" #原下载地址
# 记得改为本地face_landmark_model.dat的地址

这样, ippicv和face_landmark_model.dat下载失败的问题就得以解决。

生成完毕后会生成如下的类似界面

--   Install path:                  /usr/local
--
-- cvconfig.h is in: /home/files/opencv-3.4.5/build
-- -----------------------------------------------------------------
--
-- Configuring done
-- Generating done
-- Build files have been written to: /home/files/opencv-3.4.5/build

然后进行make

sudo make -j8   #j后面的数字代表用几个线程编译,此为8线程

然后大概率会出现以下错误

fatal error: boostdesc_bgm.i: vgg_generated_80. vgg_generated_120.i没有那个文件或目录

这个问题是一堆文件的缺失,包括

boostdesc_bgm.i

boostdesc_bgm_bi.i

boostdesc_bgm_hd.i

boostdesc_lbgm.i

boostdesc_binboost_064.i

boostdesc_binboost_128.i

boostdesc_binboost_256.i

vgg_generated_120.i

vgg_generated_64.i

vgg_generated_80.i

vgg_generated_48.i

所以只需要将这些文件下载然后放置到opencv_contrib/modules/xfeatures2d/src/ 路径下即可。

当然,这些文件的下载路径可以在cmake//日志中查看,直接复制其下载地址到网页可以看该到文件的源码,直接拷贝源码并生成同名文件然后放置到opencv_contrib/modules/xfeatures2d/src/ 路径下即可。

或者从百度网盘中下载,然后解压并将这些文件放置到opencv_contrib/modules/xfeatures2d/src/ 路径下即可。

链接

密码: a2c1

这些问题解决之后,还会遇见最后一个问题,就是opencv的stitiching模块中对xfeatures2d的调用地址问题。

ubuntu 18.04 安装opencv3.4.5+opencv_contrib_2d_03opencv安装opencv_contrib出现无法打开包括文件: “opencv2/xfeatures2d/cuda.hpp”的解决方法:

这里比较简单的就是直接改掉头文件

解决办法: 在CMakeLists.txt增加以下内容: INCLUDE_DIRECTORIES("/works/opencv-3.4.0/opencv_contrib-3.4.0/modules/xfeatures2d/include") 
CMakeLists.txt文件所在路径为: <你的路径>/opencv-3.4.0/modules/stitching/ CMakeLists.txt

解决完这些错误,可以继续

sudo make -j8

ubuntu 18.04 安装opencv3.4.5+opencv_contrib_下载地址_04只要成功到达100即为成功

sudo make install

到达这一步opencv安装成功

配置环境变量

打开文件

sudo gedit /etc/ld.so.conf.d/opencv.conf

在空白文档中添加

/usr/local/lib

接下来配置库

sudo ldconfig

更改环境变量

sudo gedit /etc/bash.bashrc

在文件的最后添加

export PKG_CONFIG_PATH=/usr/local/opencv/lib/pkgconfig 
export LD_LIBRARY_PATH=/usr/local/opencv/lib

测试

使用qt ,这个比较简单,也方便

如图,需要注意以下pro文件的写法。

ubuntu 18.04 安装opencv3.4.5+opencv_contrib_ubuntu_05运行成功打开摄像头即为成功

更多内容详见微信公众号:Python研究所

ubuntu 18.04 安装opencv3.4.5+opencv_contrib_下载地址_06