今天做了一个Eigrp的实验,故贴把过程出来供大家分享,如果有什么不对的地方希望大
 
家指出来,共同学习一下.
 
本实验是通过小凡的DynamipsGUI摸拟出4个路由器实现的
 
接口情况如下:
 
Router1 S0/0 <----> Router2 S0/0
Router2 S0/1 <----> Router3 S0/1
Router3 S0/2 <----> Router4 S0/2
Router4 F1/0 <----> Router1 F1/0
 
拓扑图:
 
下面是命令部分:
 
R1部分
 
Router> enable
Router#conf terminal
Router(config)#hostname r1
r1(config)#line console 0
r1(config-line)#logging synchronous
r1(config-line)#exec-timeout 0 0
r1(config-line)#exit
r1(config)#no ip domain-lookup
 
r1(config)#interface loopback 0
r1(config-if)#ip address 1.1.1.1 255.0.0.0               //注意发布的IP及掩码
r1(config-if)#exit
 
r1(config)#interface serial 0/0
r1(config-if)#ip address 192.168.12.1 255.255.255.0
r1(config-if)#no shutdown
r1(config-if)#exit
 
r1(config)#interface fastEthernet 1/0
r1(config-if)#ip address 192.168.1.1 255.255.255.0
r1(config-if)#no shutdown
r1(config-if)#exit
 
r1(config)#router eigrp 1
r1(config-router)#no auto-summary
r1(config-router)#network 1.0.0.0 0.255.255.255 
//注意IP及掩码,可以使用反掩码
r1(config-router)#network 192.168.12.0            //主网类只需输入IP地址
r1(config-router)#network 192.168.1.0
r1(config-router)#exit
 
r1(config)#key chain ccna                                 //定义钥匙链
r1(config-keychain)#key 1
r1(config-keychain-key)#key-string cisco          //定义密码
r1(config-keychain-key)#exit
r1(config-keychain)#exit
 
r1(config)#interface serial 0/0
r1(config-if)#ip authentication mode eigrp 1 md5         //认证模式为md5
r1(config-if)#ip authentication key-chain eigrp 1 ccna  //调用钥匙链
//认证模式是对端口使用的,所以每个要认证的端口均要设置
r1(config-if)#exit
 
r1(config)#interface fastEthernet 1/0
r1(config-if)#ip authentication mode eigrp 1 md5
r1(config-if)#ip authentication key-chain eigrp 1 ccna
r1(config-if)#exit
 
r1(config)#ip default-network 1.0.0.0           //发布默认路由,注意IP
 
R2部分
 
Router> enable
Router#conf terminal
Router(config)#hostname r2
r2(config)#line console 0
r2(config-line)#logging synchronous
r2(config-line)#exec-timeout 0 0
r2(config-line)#exit
r2(config)#no ip domain-lookup
 
r2(config)#interface loopback 0
r2(config-if)#ip address 2.2.2.2 255.255.255.0
r2(config-if)#exit
 
r2(config)#interface serial 0/0
r2(config-if)#ip address 192.168.12.2 255.255.255.0
r2(config-if)#no shutdown
r2(config-if)#exit
 
r2(config)#interface serial 0/1
r2(config-if)#ip address 192.168.23.2 255.255.255.0
r2(config-if)#no shutdown
r2(config-if)#exit
 
r2(config)#router eigrp 1
r2(config-router)#no auto-summary
r2(config-router)#network 2.2.2.0 0.0.0.255
r2(config-router)#network 192.168.12.0
r2(config-router)#network 192.168.23.0
r2(config-router)#exit
 
r2(config)#key chain ccna
r2(config-keychain)#key 1
r2(config-keychain-key)#key-string cisco
r2(config-keychain-key)#exit
r2(config-keychain)#exit
 
r2(config)#interface serial 0/0
r2(config-if)#ip authentication mode eigrp 1 md5
r2(config-if)#ip authentication key-chain eigrp 1 ccna
r2(config-if)#exit
 
r2(config)#interface serial 0/1
r2(config-if)#ip authentication mode eigrp 1 md5
r2(config-if)#ip authentication key-chain eigrp 1 ccna
r2(config-if)#exit
 
R3部分
 
Router> enable
Router#conf terminal
Router(config)#hostname r3
r3(config)#line console 0
r3(config-line)#logging synchronous
r3(config-line)#exec-timeout 0 0
r3(config-line)#exit
r3(config)#no ip domain-lookup
 
r3(config)#interface loopback 0
r3(config-if)#ip address 3.3.3.3 255.255.255.0
r3(config-if)#exit
 
r3(config)#interface loopback 1
r3(config-if)#ip address 3.3.4.3 255.255.255.0
r3(config-if)#exit
 
r3(config)#interface loopback 2
r3(config-if)#ip address 3.3.5.3 255.255.255.0
r3(config-if)#exit
 
r3(config)#interface loopback 3
r3(config-if)#ip address 3.3.6.3 255.255.255.0
r3(config-if)#exit
 
r3(config)#interface serial 0/1
r3(config-if)#ip address 192.168.23.3 255.255.255.0
r3(config-if)#no shutdown
r3(config-if)#exit
 
r3(config)#interface serial 0/2
r3(config-if)#ip address 192.168.34.3 255.255.255.0
r3(config-if)#no shutdown
r3(config-if)#exit
 
r3(config)#router eigrp 1
r3(config-router)#no auto-summary
r3(config-router)#network 3.3.0.0 255.255.248.0   //注意发布的IP及掩码
r3(config-router)#network 192.168.23.0
r3(config-router)#network 192.168.34.0
r3(config-router)#exit
 
r3(config)#key chain ccna
r3(config-keychain)#key 1
r3(config-keychain-key)#key-string cisco
r3(config-keychain-key)#exit
r3(config-keychain)#exit
 
r3(config)#interface serial 0/1
r3(config-if)#ip authentication mode eigrp 1 md5
r3(config-if)#ip authentication key-chain eigrp 1 ccna
r3(config-if)#ip summary-address eigrp 1 3.3.0.0 255.255.248.0
//路由汇总应该设置在端口上
r3(config-if)#exit
 
r3(config)#interface serial 0/2
r3(config-if)#ip authentication mode eigrp 1 md5
r3(config-if)#ip authentication key-chain eigrp 1 ccna
r3(config-if)#ip summary-address eigrp 1 3.3.0.0 255.255.248.0
//路由汇总应该设置在端口上
r3(config-if)#exit
 
R4部分
 
Router> enable
Router#conf terminal
Router(config)#hostname r4
r4(config)#line console 0
r4(config-line)#logging synchronous
r4(config-line)#exec-timeout 0 0
r4(config-line)#exit
r4(config)#no ip domain-lookup
 
r4(config)#interface loopback 0
r4(config-if)#ip address 4.4.4.4 255.255.255.0
r4(config-if)#exit
 
r4(config)#interface serial 0/2
r4(config-if)#ip address 192.168.34.4 255.255.255.0
r4(config-if)#no shutdown
r4(config-if)#exit
 
r4(config)#interface fastEthernet 1/0
r4(config-if)#ip address 192.168.1.2 255.255.255.0
r4(config-if)#no shutdown
r4(config-if)#exit
 
r4(config)#router eigrp 1
r4(config-router)#no auto-summary
r4(config-router)#network 4.4.4.0 0.0.0.255
r4(config-router)#network 192.168.34.0
r4(config-router)#network 192.168.1.0
r4(config-router)#exit
 
r4(config)#key chain ccna
r4(config-keychain)#key 1
r4(config-keychain-key)#key-string cisco
r4(config-keychain-key)#exit
r4(config-keychain)#exit
 
r4(config)#interface serial 0/2
r4(config-if)#ip authentication mode eigrp 1 md5
r4(config-if)#ip authentication key-chain eigrp 1 ccna
r4(config-if)#exit
 
r4(config)#interface fastEthernet 1/0
r4(config-if)#ip authentication mode eigrp 1 md5
r4(config-if)#ip authentication key-chain eigrp 1 ccna
r4(config-if)#exit
 
R4到R2做等价负载均衡
 
r4(config)#interface fastEthernet 1/0
r4(config-if)#delay 2000                                //设置该接口的延迟
r4(config-if)#exit
 
//另外可以通过修改带宽值达到等价负载均衡
 
R4到R2做非等价负载均衡
 
r4(config)#interface fastEthernet 1/0
r4(config-if)#no delay                                     //恢复该接口的延迟
r4(config-if)#exit
 
r4(config)#router eigrp 1
r4(config-router)#variance 2                           //设置非等价负载
//variance 值的范围是1-128.这个参数代表了可以接受的不等价路
径的度量值的倍数,在这个范围内的链路都将被接受,并且被放入路由表中
r4(config-if)#exit
 
 
另外需要注意metric度量值的计算方法,这里附上公式:
 
metric计算公式=[(10000000/链路上的最小带宽)+sum(delay)/10]*256
 
延迟是取路由来的方向的入接口的延迟总和
 
设置延时要注意单位的换算
 
端口的带宽及延迟的查看方法(已省略部分信息):
 
r4#show interfaces fastEthernet 1/0
.....
Internet address is 192.168.1.2/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
......