受限于内网,无法使用pip install Flask直接安装。

    以Flask-0.12.2为例
    安装Flask需要以下的依赖性,在安装Flask离线版时可以看到依赖性要求。
    离线安装文件地址:
    https://pypi.python.org/pypi/
    登录后,页面右上角有一个 search的搜索框

        pytz-2018.3
        Babel-2.5.3
        Jinja2-2.10
        click-6.7           
        itsdangerous-0.24
        MarkupSafe-1.0
        Werkzeug-0.14.1

    注意:需要优先安装pytz-2018.3
    下载tar.gz包即可,解压后,使用命令进行安装。

    python setup.py install

    如果是下载的whl格式文件,则需要使用pip安装
    pip install XXX.whl

    待全部安装完成后,再安装Flask-0.12.2,成功安装信息如下:

    Using /usr/local/lib/python2.7/dist-packages/MarkupSafe-1.0-py2.7.egg
Finished processing dependencies for Flask==0.12.2

    安装完成后,执行命令

Python离线安装Flask

    此时可以使用Flask框架进行开发了。