实验拓扑图:


114738665.jpg

配置信息:

MSR1的配置如下:


[MSR1]dis cur

#

sysname MSR1

#

dhcp server ip-pooldhcplab

network 20.20.20.0 mask 255.255.255.0

gateway-list 20.20.20.2

#

interface Serial0/2/0

link-protocol ppp

ip address 10.10.10.1255.255.255.252

#

ip route-static 20.20.20.0 255.255.255.0 10.10.10.2

#

dhcp enable

#


MSR2的配置如下:


[MSR2]dis cur

#

sysname MSR2

#

dhcp relay server-group 1 ip 10.10.10.1

#

interface Ethernet0/1/0

port link-mode route

ip address 20.20.20.2 255.255.255.0

dhcp select relay

dhcp relay server-select1

#

interface Serial0/2/0

link-protocol ppp

ip address 10.10.10.2 255.255.255.252

#

dhcp enable

#


MSR3的配置如下:


[MSR3]dis cur

#

interface Ethernet0/1/0

port link-mode route

ip address dhcp-alloc

#


说明:为保证DHCPSERVER MSR3网关可以互通,需要配置到网关的静态路由。