在IOS的Enable状态下,敲入

config terminal 进入全局配置状态

Cdp run 启用CDP

snmp-server community gsunion ro 配置本路由器的只读字串为gsunion

snmp-server community gsunion rw 配置本路由器的读写字串为gsunion

s nmp-server enable traps 允许路由器将所有类型SNMP Trap发送出去

snmp-server host IP-address-server traps trapcomm 指定路由器SNMP Trap的接收者为10.238.18.17,发送Trap时采用trapcomm作为字串

snmp-server trap-source loopback0 将loopback接口的IP地址作为SNMP Trap的发送源地址

logging on 起动log机制

logging IP-address-server 将log记录发送到10.238.18.17 (CW2K安装机器的IP地址)上的syslog server

logging facility local7 将记录事件类型定义为local7

logging trap warning 将记录事件严重级别定义为从warningl开始,一直到最紧急级别的事件全部记录到前边指定的syslog server.

logging source-interface loopback0 指定记录事件的发送源地址为loopback0的IP地址

service timestamps log datetime 发送记录事件的时候包含时间标记

enable password ******

line tty 0 4

password ******

login local 设置Enable口令和Telnet口令

show running

copy running start或write terminal 显示并检查配置

保存配置

配置Cisco设备的SNMP代理

配置Cisco设备上的SNMP代理的步骤如下:

启用SNMP:

configure terminal

snmp-server community rw/ro (example: snmp-server community public ro)

end

copy running-configstartup-config

启用陷阱:

configure terminal

snmp-server enable traps snmp authentication

end

copy running-configstartup-config

配置snmp

#conf t

#snmp-server community cisco ro(只读) ;配置只读通信字符串

#snmp-server community secret rw(读写) ;配置读写通信字符串

#snmp-server enable traps ;配置网关SNMP TRAP

#snmp-server host 10.254.190.1 rw ;配置网关工作站地址

 

设置CatOS设备

在CatOS的Enable状态下,敲入

set interface sc0 VLAN ID IP address 配置交换机本地管理接口所在VLAN ID,IP地址,子网掩码

Set cdp enable all 启用CDP

set snmp community read-only gsunion 配置本交换机的只读字串为public

set snmp community read-write-all gsunion 配置本交换机的读写字串为private

set snmp trap server-ip gsunion

指定交换机SNMP Trap的接收者为网管服务器,发送Trap时采用gsunion作为字串

set snmp trap enable all 将全部类型的SNMP Trap发送出去

set snmp rmon enable 激活交换机的SNMP RMON功能

set logging server IP-address-server 将log记录发送到网管服务器的IP (CW2K安装机器的IP地址)上的syslog server

set logging level 6 将记录事件严重级别定义为从informational开始,一直到最紧急级别的事件全部记录到前边指定的syslog server

set logging server facility local7 将记录事件类型定义为local7

set logging timestamp 发送记录事件的时候包含时间标记

set logging enable 起动log机制

set password ******

set enablepass ******

设置Enable口令和Telnet口令

show running

write terminal 显示并检查配置

保存配置

配置PIX设备

Logging on 在PIX上面启用日志记录

Snmp-server community gsunion 为PIX设备配置共同体串gsunion

Snmp-server enable traps 配置PIX设备将SNMP消息发送到网管服务器

Snmp-server host server-ip 在PIX设备上面配置SNMP网管服务器

Logging history warning

为PIX设备SNMP系统日志消息设置warning级别。

配置SNMP管理   

    

   Router(config)#    access-list    num    permit    host    host-ip   

     定义访问控制表,限制路由器支持网管工作站   

      

   Router(config)#      snmp-server    community    community      RO    [access-list-num]   

     配置只读权限的community,与上面定义的访问控制表联系,限制网管工作站的IP地址   

      

   Router(config)#    snmp-server    community    community    RW    [access-list-num]   

     配置具有读写权限的community,与上面定义的访问控制表联系,限制网管工作站的IP地址   

      

   Router(config)#    snmp-server    enable    traps   

     允许发出Trap   

    

华为:

网管工作站(NMS)与路由器通过以太网相连,网管工作站IP地址为129.102.149.23,路由器以太网口IP地址为129.102.0.1。NMS接收trap的端口号为5000,SNMP的版本为V1。

<Quidway> system   
[Quidway] interface Ethernet 0/0   
[Quidway-Ethernet0/0] ip address 129.102.0.1 255.255.0.0   
[Quidway] snmp-agent 使能snmp服务
[Quidway] snmp-agent community read public 设置读团体名:public
[Quidway] snmp-agent community write private 设置写团体名:private
[Quidway] snmp-agent sys-info contact Mr.Wang-Tel:3306 设置联系方式
[Quidway] snmp-agent sys-info location telephone-closet,3rd-floor 设置设备位置
[Quidway] snmp-agent sys-info version all 选择snmp版本为all(默认只允许v3)
[Quidway] snmp-agent trap enable   
[Quidway] snmp-agent target-host trap address udp-domain 129.102.149.23 udp-port 5000 params securityname public 允许向网管工作站(NMS)129.102.149.23发送Trap报文,使用的团体名为public

 
  1. 设备默认的SNMP版本为V3,必须修改为和NMS上使用版本一致,或者设置为all
  2. 网管的community name应该与路由器上配置一致
  3. 缺省配置下community read name为public, community write name为private

【网管配置的简单测试】

在网管暂时没有安装调测完成之前,可以使用“AdventNetSNMPv3”的“MIB Browser”来进行简单的测试。

安装好“MIB Browser”程序后,

配置Host:129.102.0.1

Community:public

选中左边的”mgmt”---》“mib-2”----》“system”---》“sysLocation”,点击“Get SNMP Variable”获取路由器的相关网管信息。

日志主机的配置

VRP3.4

要求路由器将系统日志发往日志主机,并在其上以文件的形式保存起来,供随时查看。

[Quidway] interface LoopBack 0 配置loopback 0
[Quidway-LoopBack0] ip address 1.1.1.1 32   
[Quidway] info-center enable 开启信息中心
[Quidway] info-center loghost source LoopBack0 指定loopback0作为发送日志信息的源地址
[Quidway] info-center loghost 192.168.1.254 配置日志主机