以前学NA的时候不用过它。今天又拿起它来做一下无线实验,感觉还真不错呢?
拓扑图如下:
p_w_picpath
在ISP背后接了一台DNS服务器与一个WWW服务器,现在Router1模拟公司的路由器,在公司的路由器背后接了一台t300n的无线路由器,下面4台PC,通过添加了无线网卡,连接到无线路由器上,然后通过公司内部的路由器访问外面的WWW服务器。
那么我们现在来看看如何实现呢?
先把isp与Router1的配置好!
Server端的配置:
Router>en
Router#conf t
nter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain-lookup
Router(config)#host Server
Server(config)#line con 0
Server(config-line)#logg syn
Server (config-line)#exec-timeout 0 0
Server (config-line)#exit
Server (config)#int s0/0/0
Server (config-if)#ip add 202.1.1.1 255.255.255.0
Server(config-if)#ip nat outside
Server (config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Server (config-if)#int fa0/0
Server (config-if)#ip add 192.16.1.1 255.255.255.0
Server(config-if)#ip nat inside
Server (config-if)#no shut
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Server (config-if)#exit
Server(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Server(config)#ip nat inside source list 1 interface s0/0/0 overload
Server (config)#ip route 0.0.0.0 0.0.0.0 s0/0/0
Server (config)#exit
Server#
ISP端的配置:
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host ISP
ISP(config)#no ip domain-lookup
ISP(config)#line con 0
ISP(config-line)#logg syn
ISP(config-line)#exec-timeout 0 0
ISP(config-line)#exit
ISP(config)#int s0/0/0
ISP(config-if)#ip add 202.1.1.2 255.255.255.0
ISP(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
ISP(config-if)#clock rate 64000
ISP(config-if)#exit
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
ISP(config)#int fa0/0
ISP(config-if)#ip add 202.2.2.2 255.255.255.0
ISP(config-if)#no shut
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
ISP(config-if)#int fa0/1
ISP(config-if)#ip add 202.3.3.3 255.255.255.0
ISP(config-if)#no shut
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
ISP(config-if)#exit
ISP(config)#
现在我们将DNS服务器配置起来:
p_w_picpath
p_w_picpath
在这里做一个域名解析,以便我们等一会我们公司内部那4台PC通过这个域名去访问我们的WWW服务器。
配置WWW服务器:
p_w_picpath
p_w_picpath 
WWW服务默认是开启了的,所以不必我们再去开启一次。
现在ISP这边我们已经配置好了,我们现在来看看,如何配置无线路由器。我发觉这个无线路由器的模拟程序也真机基本上是一样的。
p_w_picpath
在上面那里我们可以有两个先项,一个是自动配置,通过DHCP获取得来,另一个就是手工配置的。在我们现实生活中,还可以设置一个PPPOE拨号。我们可以直接用它通过ADSL拨号上网使用。但是这里就没有这个了。
下图就是我们通过手工指定的配置。相信大家应该看得懂吧!这里就不多说了。(注意这个接中是Internet那个接口上的配置哦,真实机是WAN口,就是与上级路由器通信的接口)
p_w_picpath
下面这个图还是接在上面的那个图上的。下面这个图就是给通过无线或者有线接入进来的用户自动分配IP地址,说白了就是DHCP功能。
p_w_picpath
注意配置完了要点Save Setting(保存配置)。不然配置不生效哦。
进入“Wireless”无线配置:
p_w_picpath
Network Mode:网络模式     Mixed表示混合型,不管你是A/B/G那种类型都可以使用。
Network Name(SSID):表示无线网络显示SSID的名称:如下图的(SCCNC-MOT-SWDS-E):
p_w_picpath
设置好以后记住保存哦。
下面这个选项是设置无线网络加密的。在这里提供加密的方式有以下几种(默认是禁用了的)
p_w_picpath
而这里我们就先择一个WPA2
p_w_picpath
Encryption:使用AES来进行加密。
Passphraes:是加密密码。
在这里要注意的是,我们模拟器的PC上面只支持WEP安全模式。
p_w_picpath
所以我们这里将它改成WEP安全模式。
有人可能会问,那这里的这个无线安全可以不要吗?我的回答是:可以的。如果不设置的话,别人只的PC只有要无线网卡,再加上有又刚才在你无线网络覆盖区域内的话,那么别人就可以免费上网了!呵呵。(我有时候就经常免费上别人的网)。
Wireless MAC Filter
这项表示可以修改MAC地址,但是这个模拟器不能修改,在真机上面是可以修改的。
p_w_picpath
这一项里面它可以用来限制你那些PC能访问那些端口之类的,但是这个具体没有使用过。
p_w_picpath
这里上它某一台PC放在DMZ区域,以供外网来进行访问。
p_w_picpath
在这里面就是一些管理员密码,是否允许远程管理之类的。
p_w_picpath
这就是最后一个,查看当前状态信息。好了到此为止,我们的无线路由器就配置到这里。那么我们现在来看看我们的PC又该如何来配置呢?
在PC上默认只有一个“快速以太网”接口,而没有无线网卡的,那么我们先来看看如何给我们的PC添加无线网卡呢?
p_w_picpath
第一步:点击PC电源开关,将PC关机。
第二步:将PC下部的以太网卡拖到我剑头指的那个地方,将以太网卡删除掉
第三步:再将无线网卡拖到刚才以太网卡的那个位置。
第四步:再点击PC电源开关,将PC开机。
这四步就是给我们模拟器中的普通PC添加无线网卡。
那么现在我们无线网卡也添加了,那我们现在如果将这台PC添加到我们的无线中去呢?
p_w_picpath
进入“Desktop”里面点击如上图的“PC Wireless”无线网络。
p_w_picpath
而在这里,只有将我们连接进了我们无线路由器上以后,这两项才会显示。
p_w_picpath
而在“Wireless Network Name”这下面有一个无线网络,名称为“Default”,在右边的“Site Intormation”这里面显示了这个台线路由器的一些信息。如支持网络类型有“Mixed B/G/N”安全模式使用的是“WEP”还有MAC地址等。这时当我们先中“Default”点击右边的“connect”进行连接。
p_w_picpath
就会出现一个叫我们输入“WEP Key”我们在下面的“WEP Key 1”后面输入我们前面在路由器上面输入的密码。
p_w_picpath
从这里我们可以看到路由器上面的WEP key 1为“1234567890”。
p_w_picpath
输入好key以后,点击右下角的“Connect”连接。而这时候在我们第一页就会变成连接的图片,而且信号强度与质量强度这里都显示的是绿色的。
p_w_picpath
还有就是中间那个图片显示了一个广播的形式。这就表示我们已经无无线路由器连接起来了。我们可以去总图上面看看。
p_w_picpath
从上图我们可以看见PC4与PC0与无线路由器连接起来了,而PC2与PC3我们还没有进行设置都以没有连接起来!
那我们现在在PC0上来测试一下能不能访问WWW服务器呢?
p_w_picpath
从这里我们可以看见PC0从无线路由器处分配得到的IP地址以及网关、DNS等信息。
p_w_picpath
看看我们在PC0上面能够访问公网上面的WWW服务器,而且我们的DNS也生效了,我们直接输入“http://www.cisco.com”也能够解析过去。
好了到此为止了吧!剩下的时候,你们也好好的练习一下这个无线路由器的配置吧!
在这里顺便附带一个Cisco Packet Tracer5.2的下载地址。