一、实验内容:
CISCOCallmanager软件,IP端到端的呼叫处理,
    了解企业常见的语音业务需求有哪些
    熟悉思科ISR路由器产品线和相关语音模块
    熟悉思科IP电话相关常用配置,包括CCMEIP/硬电话的使用
    能够根据企业的需求做一定的语音方案规划和设计
    了解在PC机上安装IP软电话及配置
 
二、网络拓朴结构图
附件uu
 
三、配置思路步骤
基本前提条件——保证网络基本连通性
从简单到复杂,逐个击破,一个个功能模块去配置
工程阶段一:基本连通性
任务:先完成交换机、路由器的基本配置,并测试数据网络连通性,保证企业LANWAN的可用。
工程阶段二:模拟电话+语音网关
任务:企业为了保护设备投资,保留了传统的语音设备,并将其融合到企业数据网络中,所以采用模拟电话 语音网关的语音解决方案。采用原有的路由器安装相关语音模块并做相应的配置。
工程阶段三:CME IP Phone
任务:应部门业务需求,企业购买了部分思科7940G IP电话机需要安装使用。
工程阶段四:CME IP Communicator软电话
任务:企业采用CME IP Communicator成本最低的解决方案解决语音通信。
分别在用户的PC上安装IP Communicator软电话软件,在软件上做必要设置即可检验电话的通信情况。
工程阶段五:视频
任务:用户通过一段时间试用后感觉良好,现在又想实现视频通话,能够与同时进行面对面的交流。此时如果用户想利用安装在自己的PC上的摄像头进行视频通话,则还需要安装Cisco Unified Video Advantage软件,该软件可以把摄像头功能集成到思科IP软电话中去。注意,安装前如果IP电话软件打开了要先将其关闭。
工程阶段六:与PSTN的互通
任务:企业要合PSTN电话网中任意企业打电话,对于这种需求需要语音网关路由器有接口连接PSTN电话网,便宜的解决方案是在路由器上安装FXO模块提供PSTN电话线,但该方案的缺点是一个FXO接口同时只能让一个用户和外网通话,如果同时有很多员工要往企业外打电话,理想的方案是将接口升级到CE1。可同时满足30人通话的需求。
提示:实验室测试方法:PSTN公网上有个客户电话号码是88,他拨打企业电话的号码8586后自动转接到企业电话8001,摘机后便可通话。企业内部员工要想拨打该客户电话,先要拨打9,在拨88
工程阶段七:电话目录服务
任务,为了让用户在使用IP电话时方便查询同事电话号码,做目录服务(通讯录)配置。
工程阶段八:售后培训
任务:工程结束后,用户方需要你做技术支持和售后培训,主要面对的是他们IT部门主管和网管,内容是教他们如何使用和维护这个语音系统,用户后期可能会添加、修改电话号码,所以我们可以教他们使用QCTQuick Configuration Tool)工具进行简单点图形化配置管理。该软件下载地址是:
或者最简单的web配置方式,在PC上通过Web登陆来修改CME上的电话参数,地址格式如:
企业员工的IP电话号码等分配信息将更新在《员工通讯录》发放给员工。
 
小技巧提示——命令配置好后最后再将IP电话连入网内
 
 

四、工程配置与调试

工程阶段一:基本连通性

这一步解决网络的连通性。主要内容有交换机、路由器的技术知识,首先按照拓扑图将网络设备连接好,注意,IP电话先不连到网络,防止IP电话自动注册到CallManager。以下是各个网络设备的配置。
 
#######################################################################
基本前提条件——保证网络基本连通性
任务:先完成交换机、路由器的基本配置,并测试数据网络连通性,保证企业LANWAN的可用。可以事先配置好,方便telnet控制操作设备
 
长沙CS3640配置:
en
conf t
!**********Basic**********
hostname CS-C3640-1
no ip domain-lookup
line con 0
 logging synch
exit
line vty 0 4
pass cisco
login
exit
config t
enable password cisco
 
!**********Interface**********
int loopback 0
 no shut
 ip address 1.1.1.1 255.255.255.255
int e 1/0
 no shut
 duplex full
 ip address 192.168.1.254 255.255.255.0
int e 0/0
 no shut
 duplex full
 ip address 10.1.10.1 255.255.255.0
exit
!**********IGP**********
router ospf 1
 network 0.0.0.0 0.0.0.0 area 0
end
总部2811 CME配置:
en
conf t
!**********Basic**********
hostname CME-C2811-CS
no ip domain-lookup
line con 0
 logging synch
exit
line vty 0 4
pass cisco
login
exit
config t
enable password cisco
 
!**********Interface**********
int fa 0/0
 no shut
 ip address 192.168.1.100 255.255.255.0
exit
!**********IGP**********
no ip routing
ip default-gateway 192.168.1.254
end
湘潭分部3640配置:
en
conf t
!**********Basic**********
hostname RT-C3640-Beijing
no ip domain-lookup
line con 0
 logging synch
exit
line vty 0 4
pass cisco
login
exit
config t
enable password cisco
 
!**********Interface**********
int loopback 0
 no shut
 ip address 2.2.2.2 255.255.255.255
int e 3/0
 no shut
 duplex full
 ip address 10.1.10.2 255.255.255.0
exit
!**********IGP**********
router ospf 1
 network 0.0.0.0 0.0.0.0 area 0
end
 
 
 
测试连通性,由各个分部Ping总部f0/0接口,再Ping对端分布IP

工程阶段二:模拟电话+语音网关

该公司在总部,两个分部各有一台模拟电话,解决这些部门之间的模拟电话连接,可以借助于总部的3640。可以将总部的3640配置成GateKeeper
长沙CS3640配置:
conf t
!**********FXS **********
dial-peer voice 1 pots
 destination-pattern 3188
 port 2/0/0
exit
! **********Phone Routing**********
dial-peer voice 3 voip
 destination-pattern 32..
 session target ipv4:10.1.10.2
 codec g729r8
end
湘潭分部3640配置:
 
conf t
!**********FXS**********
dial-peer voice 1 pots
 destination-pattern 3201
 port 0/0/0
exit
! **********Phone Routing**********
dial-peer voice 2 voip
 destination-pattern 31..
 session target ipv4:10.1.10.1
codec g729r8
end
测试各个模拟电话直接的连通性。
注意模拟电话实施过程中不同厂商VoGW的默认编码格式。

工程阶段三:CME IP Phone

CME-C2811配置:
Clock set 12:00:00 april 6 2008
conf t
!**********DHCP Server**********
ip dhcp excluded-address 192.168.1.254
ip dhcp excluded-address 192.168.1.100
ip dhcp excluded-address 192.168.1.1
 
ip dhcp pool PHONECS
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.254
 option 150 ip 192.168.1.100
exit
 
 
ip dhcp excluded-address 192.168.2.254
ip dhcp excluded-address 192.168.2.100
ip dhcp excluded-address 192.168.2.1
 
ip dhcp pool PHONEXT
 network 192.168.2.0 255.255.255.0
 default-router 192.168.2.254
 option 150 ip 192.168.1.100
exit
 
!**********TFTP Server**********
tftp-server flash:P0030702T023.bin
tftp-server flash:P0030702T023.loads
tftp-server flash:P0030702T023.sb2
tftp-server flash:P0030702T023.sbn
! **********Telephony-Service**********
telephony-service
 max-ephones 10
 max-dn 10
 ip source-address 192.168.1.100 port 2000
 system message BLUEFOX-CISCO-EPHONE
 time-format 24
 date-format mm-dd-yy
 create cnf-files
!secondary-dialtone 9
 load 7960-7940 P0030702T023
exit
!**********Phone menu**********
!**********EPhone A**********
ephone-dn 1 dual-line
 number 31
 label Bluefox-3101
 name Bluefox-3101
 description Bluefox-3101
exit
ephone 1
 mac-address 000D.BC8E.DB08
 type 7940
 button 1:1
 codec g729r8
exit
ephone 3
 mac-address 0014.85d8.36cf
 type CIPC
 button 1:1
 codec g729r8
exit
!**********EPhone B**********
ephone-dn 2 dual-line
 number 3102
 label Bluefox-3102
 name Bluefox-3102
 description Bluefox-3102
exit
ephone 2
 mac-address 000D.BC7E.5DFD
 type 7940
 button 1:2
 codec g729r8
end
测试模拟电话之间的连通性。

工程阶段四:解决内部IP电话和模拟电话的通信

CME-C2811配置:
! **********Dial Routing **********
dial-peer voice 1 voip
 destination-pattern 31..
 session target ipv4:192.168.1.254
 codec g729r8
dial-peer voice 2 voip
 destination-pattern 32..
 session target ipv4:192.168.2.254
 codec g729r8
 
end
工程中没有加入一句codec g729r8IP电话和普通电话之间拨号响铃,但是不能通话。应该是与编码有关,但是具体原因和解决方法未知!
********************************************************

工程阶段五:视频

VoGW上配置视频:
conf t
voice service voip
 h323
 call start slow
exit
telephony-service
 service phone videoCapability 1
exit
ephone 3
 video
ephone 4
 video
end
这一部分内容没有由于实验室设备条件没有测试。

工程阶段六:与PSTN的互通

解决外部电话打内部,4415460时直接转接到3188而不进行二次拨号。
外面的同学打电话4415460进来,会自动转接3188电话,响铃
我们要企业内部打出去到PSTN用户,要先拨9,在拨被叫人的电话号码
 
CS-C3640-1连接的PSTN分配的号码是4415460
conf t
!**********Voice Port**********
voice-port 3/0/0
 connection plar opx 3188
end
解决内部IP电话要打外网要在号码前面加拨9
CS-C3640-HQ 连接了PSTN:
conf t
!**********Dial Routing**********
dial-peer voice 2 pots
 destination-pattern 9
 port 3/0/0
end
总部2811 CME配置:
conf t
!**********Tel Service**********
telephony-service
 secondary-dialtone 9
exit
!**********Dial Routing**********
dial-peer voice 2 voice
 destination-pattern 9T
 session target ipv4:1921681254
end
解决内部模拟电话打外部PSTN网络前面加拨9
 
此时其实都是打不通的,让学员思考并排错,分析呼叫原理,其实是没有写dial-peer voice voip的原因,所以补充的完整的配置是:
 
在各个GW上配置电话路由
!**********Dial Routing**********
dial-peer voice 2 voice
 destination-pattern 9T
 session target ipv4:1921681254
exit
这不是一个好的方法,可以采用技术前缀(暂时未成功)
gatekeeper
 gw-type-prefix 1# gw ipaddr 1.1.1.1
exit
 

工程阶段七:电话目录服务

CME上配置电话目录服务。电话号码目录服务——电话号码本通信录
任务:为了让用户在使用IP电话时方便查询同事的电话号码,做目录服务(通讯录)配置。
Telephony-service
telephony-service
directory entry 1 3101 name CS-Mary
directory entry 2 3102 name CS-7940_B
directory entry 3 3105 name CS-Kun ge
directory entry 4 3201 name Office
create cnf-files 
Exit
测试方法是按电话机上的目录按钮查看电话簿
 
、测试方案
测试项目表如下:
1. 分公司与总部之间PC PING连通性测试。
2. 同一地点的公司内部分机电话接通测试。
3. 不同分公司之间分机电话接通测试。
4. 企业内部与PSTN用户模拟电话接通测试。
5. 企业内部视频通话测试。
 
 
\\\工程总结
任务:工程结束后,用户方需要你做技术支持和售后培训,主要面对的是他们的IT部门主管和网管,内容是教他们如何使用并维护这个语音系统,用户后期可能会修改或添加新的电话号码,所以我们可以教他们用最简单的web方式的,在PC上可以通过Web登陆来修改CME上的电话配置参数,地址格式如: [url]http://192.168.1.1/ccme.html[/url]
之后企业员工的IP电话号码等分配信息将更新在《员工通讯录》发放给员工。
 
注意:确保几个基本文件已经拷贝到flash中了,3640上可以使用命令:
archive tar /xtract tftp://192.168.1.66/cme-basic-4.0.0.0.tar flash:
archive tar /xtract tftp://192.168.1.66/ cme-gui-124-11T.tar flash:
 
ISR 2811上直接拷贝到flash
 
ISR 2811路由器所需配置:
 
telephony-service
web admin system name admin password cisco
dn-webedit
create cnf-files 
exit
  通过本次的综合试验,使我们对这过IP语音网络的综合部署有了一个整体的了解。虽然在实验中有遇到了许多问题。