三层交换
 
三层交换具有二层的交换功能和三层的路由功能,三层交换机使用硬件转发技术,实现数据的快速转发。
三层交换是用来解决路由器和交换机之间的链路的瓶颈问题。学完本章你将完成以下要求:
* 配置三层交换机,实现vlan之间的通信。
* 配置三层交换机和路由器的连通性
* 在三层交换机上配置DHCP中继
 
一、vlan之间的路由
 
配置单臂路由,实现交换机上不同vlan的之间通信问题。
配置单臂路由,主要包含以下内容:
*配置路由的子接口
*在子接口上封装vlan trunk协议
*配置子接口的ip地址
 
配置命令如下:
Router(config)#interface f0/0
Router(config-if)#no shutdown
Router(config-if)#exit 
Router(config)#interface f0/0.1
Router(config-subif)#encapsulation dot1q 1
Router(config-subif)#ip address 10.1.1.1 255.0.0.0
Router(config-subig)#no shutdown 
Router(config)#interface f0/0.2
Router(config-subif)#encapsulation dot1q 2
Router(config-subif)#ip address 20.1.1.1 255.0.0.0
Router(config-subif)#no shutdown 
Router(config)#interface f0/0.3
Router(config-subif)#encapsulation dot1q 3
Router(config-subif)#ip address 30.1.1.1 255.0.0.0
Router(config-subif)#no shutdown
 
交换机与路由器连接的接口配置为trunk模式。配置单臂路由后,可以实现不同vlan之间的通信。
 
什么是三层交换技术呢?
简单的说三层交换技术就是:二层交换技术+三层转发技术 
 
三层交换机配置命令
A:在三层交换机上配置启动路由
  Switch(config)#ip routing
B:配置vlanIP地址
  Switch(config)#iinterface vlan vlan-id
  Switch(config-if)#ip address ip-address subnet-masknet
  Switcht(config)#no shutdown
C:查看FIB
  Switch(config)#show ip cef
D:查看邻接表
  Switch(config)#show adjacency detail
E:在三层交换机上配置路由接口
  Switch(config-if)#no switchport
F:配置DHCP中继转发
  Switch(config)#interface vlan vlan-id
  Switch(config-if)#ip helper-address dhcpserver-address
 
 
三层交换机实现vlan之间的通信
第一步 在二层交换机上配置vlantrunk
第二步 在三层交换机上配置vlantrunk
第三步 在三层交换机上配置平启用路由功能
       Switchconfig#ip routing
第四步 在三层交换机上配置个vlanIP地址
      Switch(config)#interface vlan 1
      Switch(config-if)#ip address 192.168.3.2 255.255.255.0
      Switch(config-if)#no shutdown 
      Switch(config)#interface vlan 2
      Switch(config-if)#ip address 192.168.3.2 255.255.255.0
      Switch(config-if)#no shutdown
第五步 验证配置
      Switch#show ip route
      Switch#show ip cef   查看FIB表的内容
      Switch#show adjacency detail   查看邻接关系表
在三层交换机上配置路由
第一步 在三层交换机上配置路由接口,并配置接口的IP地址
       Switch(config)#interface f0/3
       Switch(config-if)#no switchport
       Switch(config-if)#ip address 192.168.3.2 255.255.255.0
       Switch(config-if)#no shutdown
第二步 在三层交换机上配置路由
      Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.3.2
第三步 在路由器上配置路由
      Switch(config)#ip route 192.168.3.0 255.255.255.0 192.168.3.1
Switch(config)#ip route 192.168.3.0 255.255.255.0 192.168.3.1
Switch(config)#ip route 192.168.3.0 255.255.255.0 192.168.3.1
第四步 验证配置
      Switch# show ip route   查看路由表  
 
在三层交换机上配置DHCP中继
什么是DHCP
DHCP称为动态主机配置协议,这个协议的用途是动态的分配IP地址。
   DHCP中继
      默认的情况下,DHCP只能在vlan内部使用,要是其他vlan也要使用DHCP怎么半,这就需要配置DHCP中继。
       因此,解决这个问题就是在三层交换机上配置DHCP中继。让三层交换机能够将DHCP这种特殊的广播信息在不同的vlan之间进行转发,让其他vlan的客户端也能从DHCP服务器里获得IP地址。
    DHCP配置中继如下:
  Switch(config)#interface vlan 1
  Switch(config)#ip helper-address 192.168.2.100
 
Switch(config)#interface vlan 2
  Switch(config)#ip helper-address 192.168.2.100
     
在三层交换机上配置DHCP中继转发,是在三层交换机已经配置了各vlan互通的前提下,在不包含DHCP服务器的vlan上,命令是;ip helper-address DHCP-address,从而实现其他vlan的客户端也能从DHCP服务器上自动的获得IP地址。
 有一点需要注意,DHCP需要配置多个地址池,包含多少各vlan,就需要配置几个地址池。