1。编译courier-imap 出错

checking for courierauthconfig... no
configure: WARNING: === Courier authentication library not found.
configure: WARNING: === You need to download and install
configure: WARNING: === http://www.courier-mta.org/download.php#authlib first.
configure: WARNING: === If courier-authlib is installed in a non-default
configure: WARNING: === directory, set the COURIERAUTHCONFIG environment
configure: WARNING: === variable to the full path to the courierauthconfig
configure: WARNING: === binary and rerun this configure script.
configure: WARNING:
configure: error: courierauthconfig not found

解决方法:

[root@ivon courier-imap-4.8.0.20100628]# export COURIERAUTHCONFIG=/usr/local/authlib/bin/courierauthconfig

 

2。maildrop编译出错

configure: error: pcre.h not found - install PCRE from www.pcre.org

解决方法:

[root@ivon maildrop-2.5.0]# yum install pcre-devel

 

3。安装courier-imap时报错

安装courier-imap时报错,信息如下
checking for courierauthconfig... /usr/local/authlib/bin/courierauthconfig
configure: error: This option is no longer supported
You have new mail in /var/spool/mail/root

解决方法:

我用的4.8的  换成4.5时安装顺利完成。

courier-imap-4.5.1.tar.bz2

4。extman验证码不显示。

解决方法
支持范围:后台登陆和帐户注册模块。需要GD的支持,详细请到cpan上搜索GD并安装即可。注意的是默认webman.cf里打开了该功能的自持,如果需要关闭校验码,请将SYS_CAPTCHA_ON = 0即可关闭。

[root@ivon daemon]# perl -MCPAN -e shell
Terminal does not support AddHistory.

cpan shell -- CPAN exploration and modules installation (v1.7602)
ReadLine support available (try 'install Bundle::CPAN')

cpan> install GD

参数介绍:
SYS_CAPTCHA_ON = 1 | 0 如果为0则关闭此功能
SYS_CAPTCHA_KEY 该参数非常重要,设置的是您的校验key,强烈建议安装extman后修改此参数,否则非法分子可以利用默认的key来伪造请求!!请设置一个复杂、不易猜测的key值。
SYS_CAPTCHA_LEN 校验码的长度,默认是6位。

校验码使用了ttf字库,如果您的操作系统没有freetype等ttf库,请删除 extman/addon/font.ttf这个软链接,这样校验码就会用gd默认的字体来显示。

 

 5。启动postfix时报错

postfix: fatal: /etc/postfix/main.cf, line 50: missing '=' after attribute name: "reject_non_fqdn_hostname,"

解决方法:

修改/etc/postfix/main.cf  smtpd_recipient_restrictions = 后面的选项都不能有空格。

#====================SASL========================
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,reject_invalid_hostname,reject_non_fqdn_hostname,reject_unknown_sender_domain,reject_non_fqdn_sender,reject_non_fqdn_recipient,reject_unknown_recipient_domain,reject_unauth_pipelining,reject_unauth_destination,permit

 

 

6.extman后台管理不能登录了,提示如下

Can't open /tmp/extman//sid_26da75f9aec35f2cbc6b4fa425ab525e, No such file or directory

解决方法:

修改,/var/www/extsuite/extman/webmail.cf文件里面的配置

# sys_sess_dir, the session dir
SYS_SESS_DIR = /tmp/extman/

改为:SYS_SESS_DIR = /var//tmp/extman/还有一种常见错误就是提示

Can't open /tmp/extman//sid_89b33ec5ce0b5903f24035aa4ad76d15, Permission denied

这个是因为extman 那个临时目录的权限不对。

可以设置为777就ok了

 7.extman 后台显示 extman 系统信息 no such file or directory

 

[root@ivon daemon]# /var/www/extsuite/extman/daemon/cmdserver  --daemon
loaded ok

 

 8。点extman后台图像日志报错:

Can't locate RRDs.pm in @INC (@INC contains: /var/www/extsuite/extman/libs /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /var/www/extsuite/extman/libs/Ext/GraphLog.pm line 23. BEGIN failed--compilation aborted at /var/www/extsuite/extman/libs/Ext/GraphLog.pm line 23. Compilation failed in require at /var/www/extsuite/extman/libs/Ext/MgrApp/ViewLog.pm line 22. BEGIN failed--compilation aborted at /var/www/extsuite/extman/libs/Ext/MgrApp/ViewLog.pm line 22. Compilation failed in require at /var/www/extsuite/extman/cgi/viewlog.cgi line 18.

 解决方法:安装rrdtool包

一、使用yum安装:
/etc/yum.repos.d/下面新建dag.repo文件在文件中输入源地址:
[root@hmg2 yum.repos.d]# cat dag.repo
[dag]
name=Dag RPM Repository for Red Hat Enterprise Linux
baseurl=http://apt.sw.be/redhat/el$releasever/en/$basearch/dag
gpgcheck=1
gpgkey=http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt
enabled=1
[root@hmg2
yum.repos.d]#yum -y install rrdtool
这样就可以完成RRDTool安装……
二、软件包安装:
先yum安装所要的库文件:
[root@hmg2 yum.repos.d]#
yum install cairo-devel libxml2-devel pango-devel pango libpng-devel freetype freetype-devel libart_lgpl-devel
然后下载rrdtool包,安装:
[root@hmg2 src]#wget http://oss.oetiker.ch/rrdtool/pub/rrdtool-1.3.1.tar.gz
[root@hmg2 src]#tar -zxvf rrdtool-1.3.1.tar.gz
[root@hmg2 src]#
./configure --prefix=/usr/local/rrdtool && make && make install
运行rrdtool –v测试安装成功没有:
[root@hmg2 src]#rrdtool -v //可以看到RRDTool的用法以及版本信息
三、另一种yum安装
[root@hmg2 src]#wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.3.6-1.el5.rf.i386.rpm
[root@hmg2 src]#rpm -ivh rpmforge-release-0.3.6-1.el5.rf.i386.rpm
[root@hmg2 src]#yum -y install rrdtool*

 

8。extman后台图形日志红叉

解决方法:

[root@ivon lib]# wget http://cpan.wenzk.com/authors/id/M/MG/MGRABNAR/File-Tail-0.99.3.tar.gz

[root@ivon lib]# tar zxvf File-Tail-0.99.3.tar.gz

[root@ivon lib]# cd File-Tail-0.99.3
[root@ivon lib]# perl Makefile.PL
[root@ivon lib]# make
[root@ivon lib]# make install
[root@ivon lib]# /usr/local/mailgraph_ext/mailgraph-init start

引用:

 /usr/local/mailgraph_ext/mailgraph-init start
将这2句复制到/etc/rc.d/rc.local(linux)或/etc/rc.conf(bsd)便于系统重启动后自动启动相关进程。过一段时间看/var/lib下是否产生了mailgraph_**.rrd

 

9。编译httpd报错:


./configure --prefix=/usr/local/httpd --sysconfdir=/etc/httpd --enable-so --enable-ssl --enable-track-vars --enable-rewrite --with-zlib --enable-mods-shared=most --enable-suexec --with-suexec-caller=daemon --with-suexec-docroot=/var/www/

Configuring Apache Portable Runtime library ...

checking for APR... yes
  setting CC to "gcc"
  setting CPP to "gcc -E"
  setting CFLAGS to "  -pthread"
  setting CPPFLAGS to " -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SOURCE"
  setting LDFLAGS to " "

解决方法:yum install gcc*                     yum install apr*

 10。编译php出错:

/usr/kaifa/php-5.3.3/ext/iconv/iconv.c:2512: undefined reference to `libiconv'
/usr/kaifa/php-5.3.3/ext/iconv/iconv.c:2590: undefined reference to `libiconv'
/usr/kaifa/php-5.3.3/ext/iconv/iconv.c:2590: undefined reference to `libiconv'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1
排除路径及环境变量问题,发现主要是没有加编译选项-liconv所致,但是怎么在一个完整的工程里面加入这个参数呢?
这里提供几种方法:
1,在./configure后,修改Makefile文件,在 LDFLAGS 项中加上 -liconv 选项即可;
2,直接在make后带选项加入,比如 ZEND_EXTRA_LIBS='-liconv'即可;

 

解决[warn] _default_ VirtualHost overlap on port 80, the first has precedence问题
 

今天配置apache2,在httpd.conf里新增加了1个VirtualHost,域名是www.xx.com,此时,服务器总共2个VirtualHost ,apachectl restart的时候却出现了下面的警告提示:

[warn] _default_ VirtualHost overlap on port 80, the first has precedence

这个,大概意思就是后面新增加的这个个VirtualHost 由于端口被占用,不能生效,沿用第一个虚拟主机的配置。

检查了一下,发现,原来在httpd.conf里,我没有把#NameVirtualHost *:80前的注释去掉,导致这个没有生效。

 

检查其各日志,发现/var/log/httpd/error_log中有如下大量的错误信息,但并没有影响使用,如下方法可解决:
1.下载http://search.cpan.org/CPAN/authors/id/P/PM/PMAKHOLM/Encode-IMAPUTF7-1.04.tar.gz
2.解压后,编译此文件,将IMAPUTF7.pm复制到/var/www/extsuite/extman/libs/Encode/覆盖。(覆盖前建议先备份此文件)
[Mon Jun 14 09:46:51 2010] [error] [client 119.122.47.215] Prototype mismatch: sub Encode::IMAPUTF7::decode ($$;$) vs none at /var/www/extsuite/extman/libs/Encode/IMAPUTF7.pm line 76., referer: http://mail.test.com:8080/extman/cgi/sysinfo.cgi?sid=d72698f1d334a7838494b392ef7c84f4
[Mon Jun 14 09:46:56 2010] [error] [client 119.122.47.215] Prototype mismatch: sub Encode::IMAPUTF7::decode ($$;$) vs none at /var/www/extsuite/extman/libs/Encode/IMAPUTF7.pm line 76., referer: