本实验讲的如何配置三成交换以及DHCP技术,三层交换的工作原理没有涉及到主要一个原因还是太多,实验步骤配置详细,并带有说明。相信可以对于初学者来说还是有很大帮助的,如果大家需要PDF版本的实验可以留言,我会在后期制作完毕上传供大家下载。

:实验背景:

 

国立集团是北京一个从事科研开发的企业,公司有4个部门,每个部门大约20人,所以划分了4VLAN来为4个部门服务,VLAN之间的通信用3层交换机来实现,而且在外地还有一个办事处,为了和办事处的网络能够互联,公司的3层交换机连接了一个路由器,为了节省成本,路由器上担当了DHCP服务器的功能,来为公司内部的主机分配IP.

 

:实验目的:

1、 VLAN之间的通信通过3层交换机来实现

2、 路由器为4VLAN来分配IP地址

3、 PC1PC2分别属于2个部门,能够得到IP地址

4、 PC1PC2之间可以ping通。

实验拓扑:

张浩制作

  实验思路:

1首先先利用三层交换机的路由功能来实现内网络的通讯(VTP的配置可有可无)

2 然后实现内部网络能与路由相通(这里利用的RIP协议)

             3 在路由器上担当DHCP服务器的功能

             4 在三层交换机上做DHCP中继

             5 测试能否分配到IP

 

  实验配置:

        1 首先把交换机之间相连的线路改为trunk然后在SW3创建VTP 添加VLAN 信息

             SW1(config)#interface f0/1

SW1(config-if)#switchport mode trunk

SW1(config-if)#no shutdown

 

SW2(config)#interface f0/2

SW2(config-if)#switchport mode trunk

SW2(config-if)#no shutdown

 

SW3(config)#interface range f0/1 - 2

SW3(config-if-range)#switchport mode trunk

SW3(config-if-range)#no shutdown

 

SW3#vlan database

SW3(vlan)#vtp domain t33(创建VTP的域名)

SW3(vlan)#vlan 10(添加VLAN 信息)

SW3(vlan)#vlan 20

        查看其他交换机都学到了VLAN 信息,现在把相应的接口加入相应的VLAN

             SW1(config)#interface f0/0

SW1(config-if)#switchport access vlan 10

 

SW2(config)#interface f0/0

SW2(config-if)#switchport access vlan 20

 

    2

       PC1 属于VLAN 10 分配的IP地址为192.168.10.0/24  IP

192.168.10.100

       PC2 属于VLAN 20 分配的IP地址为192.168.20.0/24  IP192.168.20.100

       由于三层交换式利用VLAN  进行转发数据的,所以必须给每个VLAN配置IP,每个VLAN 配置的IP相当于PC机的默认网关,必须和相同的VLAN在同一网段

         SW3(config)#ip routing(开启路由功能)

         SW3(config)#interface vlan 10

         SW3(config-if)#ip address 192.168.10.1 255.255.255.0

         SW3(config)#interface vlan 20

         SW3(config-if)#ip address 192.168.20.1 255.255.255.0

 

    测试:完成以上配置后,把PC得网关指向给VLAN配置的 IP

PC1 ping PC2

        Pinging 192.168.20.100 with 32 bytes of data:

Reply from 192.168.20.100: bytes=32 time<1ms TTL=64

Reply from 192.168.20.100: bytes=32 time<1ms TTL=64

Reply from 192.168.20.100: bytes=32 time<1ms TTL=64

Reply from 192.168.20.100: bytes=32 time<1ms TTL=64

 

Ping statistics for 192.168.20.100:

         Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)

   三层交换已经实现了不同VLAN 之间的通讯,内部网络已经通了

 

3 :下面配置路由,实现内部网络到路由的全部互通

     SW3(config)#interface f0/0

     SW3(config-if)#no switchport (在三层交换上开启路由接口)

SW3(config-if)#ip address 192.168.30.1 255.255.255.0

 

R1(config)#interface f0/0

R1(config-if)#ip address 192.168.30.2 255.255.255.0

R1(config-if)#no shutdown

 

SW3(config)#router rip  RIP宣告)

SW3(config-router)#network 192.168.10.0

SW3(config-router)#network 192.168.20.0

SW3(config-router)#network 192.168.30.0

 

R1(config)#router rip  RIP宣告)

R1(config-router)#network 192.168.30.0

 

     查看路由表

       R1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

              D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

              N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

              E1 - OSPF external type 1, E2 - OSPF external type 2

              i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

              ia - IS-IS inter area, * - candidate default, U - per-user static route

              o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

C    192.168.30.0/24 is directly connected, FastEthernet0/0

R    192.168.10.0/24 [120/1] via 192.168.30.1, 00:00:06, FastEthernet0/0

R    192.168.20.0/24 [120/1] via 192.168.30.1, 00:00:06, FastEthernet0/0

     说明:路由器已经学到的路由表,测试网路连通性(用PCping 路由器可以通),在这里做这一步是因为要想让R1担当DHCP服务器,首先通讯时前提的保障,每做一步都验证一步,可以让我们很好的发现错误

 

  R1上配置DHCP服务器

       R1(config)#ip dhcp pool vlan10(分配给那个VLAN

R1(dhcp-config)#network 192.168.10.0 255.255.255.0(分配给VLAN的网段)

R1(dhcp-config)#default-router 192.168.10.1 (分配的网关,注意一定要指向三层交换VLANIP

R1(dhcp-config)#dns-server 1.1.1.1DNS服务器的IP,这里可以没有)

R1(dhcp-config)#lease 10(租用的期限)

 

       R1(config)#ip dhcp pool vlan20(分配给那个VLAN

R1(dhcp-config)#network 192.168.20.0 255.255.255.0(分配给VLAN的网段)

R1(dhcp-config)#default-router 192.168.20.1 (分配的网关,注意一定要指向三层交换VLANIP

R1(dhcp-config)#dns-server 1.1.1.1DNS服务器的IP,这里可以没有)

R1(dhcp-config)#lease 10(租用的期限)

 

R1(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.50(排除不分配的IP

       R1(config)#ip dhcp excluded-address 192.168.20.1 192.168.20.100(排除不分配的IP

      可以更好的看出效果

 

  4:在三层交换机上做DHCP中继,应为DHCP的获取的方式为广播,由于广播不能再不同的VLAN 之间进行广播

     所以需要做DHCP中继

         SW3(config)#interface vlan 10

SW3(config-if)#ip helper-address 192.168.30.2(指定DHCP的服务器的路由器的接口IP

 

        SW3(config)#interface vlan 20

SW3(config-if)#ip helper-address 192.168.30.2

 

  5:最终测试

     完成以上步骤之后,把PC机设为自动获取,便可以获得自动分配的IP

     实验比较简单,这里不给大家测试的结果了

 

推荐文章:CCIE是怎样炼成的?