NAT的配置:
步骤:
1.接口IP地址配置
2.做ACL指定哪些内部主机能做NAT
3.定义地址池(公网的),静态或地址池
4.指定地址转换映射(转换规则)
5.在内部和外部端口上启用NAT
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
静态NAT配置:
第一步: 设置外部端口并启用NAT
Router(config)#interface serial 0/0
Router(config-if)#ip address 61.159.62.129 255.255.255.248
Router(config-if)#ip nat outside
第二步 :设置内部端口并启用NAT
Router(config)#interface FastEthernet 0/0
Router(config-if)#ip address 192.168.100.1 255.255.255.0
Router(config-if)#ip nat inside
第三步: 在内部本地和内部合法地址之间建立静态地址转换
Router(config)#ip nat inside source static 192.168.100.2 61.159.62.130
Router(config)#ip nat inside source static 192.168.100.3 61.159.62.131

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
动态NAT配置:
第一步: 设置外部端口IP地址
Router(config)#interface serial 0/0
Router(config-if)#ip address 61.159.62.129 255.255.255.192
第二步: 设置内部端口IP地址
Router(config)#interface FastEthernet 0/0
Router(config-if)#ip address 172.168.100.1 255.255.255.0
第三步:定义内部网络中允许访问外部的访问控制列表
Router(config)#access-list 1 permit 172.168.100.0 0.0.0.255
第四步:定义合法IP地址池
Router(config)#ip nat pool test0 61.159.62.130 61.159.62.190 network 255.255.255.192
第五步:指定网络地址转换映射
Router(config)#ip nat inside source list 1 pool test0
第六步:在内部和外部端口上启用NAT
Router(config)#Interface serial 0/0
Router(config-if)#Ip nat outside
Router(config)#Interface fastethernet 0/0
Router(config-if)#Ip nat inside
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
PAT配置:
第一步: 设置外部端口IP地址
Router(config)#interface serial 0/0
Router(config-if)#ip address 61.159.62.129 255.255.255.192
第二步: 设置内部端口IP地址
Router(config)#interface FastEthernet 0/0
Router(config-if)#ip address 10.1.1.1 255.255.255.0
第三步:定义内部网络中允许访问外部的访问控制列表
Router(config)#access-list 1 permit 10.1.1.0 0.0.0.255
第四步:定义合法IP地址池
Router(config)#ip nat pool onlyone 61.159.62.130 61.159.62.130 netmask 255.255.255.248
也可以直接使用路由器的接口地址,不用定义地址池
第五步:指定网络地址转换映射
Router(config)#ip nat inside source list 1 pool onlyone overload
Router(config)#ip nat inside source list 1 interface serial0/0 overload //直接使用路由器的接
口地址(最好,不用指定地址池,可以节省掉第4步)
第六步:在内部和外部端口上启用NAT
Router(config)#interface serial 0/0
Router(config-if)#ip nat outside
Router(config)#interface fastethernet 0/0
Router(config-if)#ip nat inside
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
负载均衡配置:
第一步: 设置外部端口
Router(config)#interface serial0/0
Router(config-if)#ip address 172.20.7.1 255.255.255.224
第二步:设置内部端口
Router(config)#interface fastethernet0/0
Router(config-if)#ip address 10.1.1.254 255.255.255.0
第三步:为虚拟主机定义一个标准的IP访问控制列表
Router(config)#access-list 2 permit 10.1.1.127
第四步:给真实主机定义一个NAT地址集
Router(config)#ip nat pool real-host 10.1.1.1 10.1.1.3 prefix-length 24 type rotary
第五步:设置访问控制列表和NAT地址集之间的映射
Router(config)#ip nat inside destination list 2 pool real-host
第六步:在内部和外部端口上启用NAT
Router(config)#interface serial 0/0
Router(config-if)#ip nat outside
Router(config)#interface fastethernet 0/0
Router(config-if)#ip nat inside