一,HSRP:

1,基本概述:

  热备份路由器协议(HSRP)的设计目标是支持特定情况下 IP 流量失败转移不会引起混乱、并允许主机使用单路由器,以及即使在实际第一跳路由器使用失败的情形下仍能维护路由器间的连通性。换句话说,当源主机不能动态知道第一跳路由器的 IP 地址时,HSRP 协议能够保护第一跳路由器不出故障。

  HSRP:热备份路由器协议(HSRP:Hot Standby Router Protocol),是cisco平台一种特有的技术,是cisco的私有协议。

  该协议中含有多台路由器,对应一个HSRP组。该组中只有一个路由器承担转发用户流量的职责,这就是活动路由器。当活动路由器失效后,备份路由器将承担该职责,成为新的活动路由器。这就是热备份的原理。

2,工作原理:

  负责转发数据包的路由器称之为活动路由器(Active Router)。一旦主动路由器出现故障,HSRP 将激活备份路由器(Standby Routers)取代主动路由器。HSRP 协议提供了一种决定使用主动路由器还是备份路由器的机制,并指定一个虚拟的 IP 地址作为网络系统的缺省网关地址。如果主动路由器出现故障,备份路由器(Standby Routers)承接主动路由器的所有任务,并且不会导致主机连通中断现象。 HSRP 运行在 UDP 上,采用端口号1985。路由器转发协议数据包的源地址使用的是实际 IP 地址,而并非虚拟地址,正是基于这一点,HSRP 路由器间能相互识别.

  配置了HSRP协议的路由器交换以下三种多点广播消息:

Hello———hello消息通知其他路由器发送路由器的HSRP优先级和状态信息,HSRP路由器默认为每3秒钟发送一个hello消息;

Coup———当一个备用路由器变为一个主动路由器时发送一个coup消息;

Resign———当主动路由器要宕机或者当有优先级更高的路由器发送hello消息时,主动路由器发送一个resign消息。在任一时刻,配置了HSRP协议的路由器都将处于以下五种状态之一:

Initial———HSRP启动时的状态,HSRP还没有运行,一般是在改变配置或端口刚刚启动时进入该状态。

Listen———路由器已经得到了虚拟IP地址,但是它既不是活动路由器也不是等待路由器。它一直监听从活动路由器和等待路由器发来的HELLO报文。

Speak———在该状态下,路由器定期发送HELLO报文,并且积极参加活动路由器或等待路由器的竞选。

Standby———当主动路由器失效时路由器准备接管包传输功能。

Active———路由器执行包传输功能。

3,HSRP技术在网络中的应用:

  随着Internet的日益普及,人们对网络的依赖性也越来越强。这同时对网络的稳定性提出了更高的要求,人们自然想到了基于设备的备份结构,就像在服务器中为提高数据的安全性而采用双硬盘结构一样。路由器是整个网络的核心和心脏,如果路由器发生致命性的故障,将导致本地网络的瘫痪,如果是骨干路由器,影响的范围将更大,所造成的损失也是难以估计的。因此,对路由器采用热备份是提高网络可靠性的必然选择。在一个路由器完全不能工作的情况下,它的全部功能便被系统中的另一个备份路由器完全接管,直至出现问题的路由器恢复正常,这就是热备份路由协议(HotStandbyRouterProtocol),HSRP-RFC2281技术要解决的问题。

4,HSRP特点:

  1.高度的可靠性,两台路由器之间采用HSRP(热备份冗余协议)协议,来保证两台路由器中的任意一台down掉,或路由器的广域网口down,都会迅速切换到另外一台。

  2.有效的实现了负载均衡,在STAR-S1924F+上划分出各自的VLAN,储蓄子网VLAN在左侧路由器上的HSRP的优先级较高,默认使用网通的FR线路;邮政系统(办公、报刊、EMS、VOIP等等)子网VLAN在右侧路由器上的HSRP的优先级较高,默认使用联通的FR线路。充分利用了带宽资源,而且实现了负载均衡。

  3.充分利用了多以太口路由器在划分多业务网段上的功能,也只有多以太口路由器在HSRP应用中才能实现两个路由器间的负载分担,这是具有四个以太口路由器的极大的优点。

  4.在右侧路由器上启用QoS策略,VoIP业务需要较低的延时,所以将VoIP业务设置成较高的优先级。

  5.通过在交换机上设置VLAN,有效的控制了两个子网间的安全。

  6.不存在单点故障问题。

5,企业案例:

  案例拓扑

cisco

配置信息

R1:

interface FastEthernet0/0
no shutdown

interface FastEthernet0/0.10                                        //开启逻辑接口
encapsulation dot1Q 10                                              // 给逻辑接口打标签 
ip address 192.168.10.1 255.255.255.0
standby 10 ip 192.168.10.254                                     //虚拟ip地址
standby 10 priority 120                                               //修改优先级
!        
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
standby 20 ip 192.168.20.254

R2:

interface FastEthernet0/0
no shutdown

interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.2 255.255.255.0
standby 10 ip 192.168.10.254
!        
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.2 255.255.255.0
standby 20 ip 192.168.20.254
standby 20 priority 120                                              //修改优先级

sw1:

no ip routing                                                              //关闭路由功能
interface Port-channel1                                               //进入通道1
switchport mode trunk                                              //设置接口为trunk模式(即所有lan都可通过)
interface FastEthernet0/0
switchport mode trunk
!        
interface FastEthernet0/1
switchport mode trunk
channel-group 1 mode on                                       //端口聚合
!        
interface FastEthernet0/2
switchport mode trunk
channel-group 1 mode on
vlan datase                                                           //进入vlan数据库设置vlan信息
vlan 10
vlan 20
int range f0/3 -10
switchport access vlan 10                                       //将3-10端口加入vlan10
int rang f0/11 –15                                                 //将11-15端口加入vlan20                                         
switchport access vlan 20

sw2:

no ip routing
interface Port-channel1
switchport mode trunk       
interface FastEthernet0/0
switchport mode trunk
!        
interface FastEthernet0/1
switchport mode trunk
channel-group 1 mode on
!        
interface FastEthernet0/2
switchport mode trunk
channel-group 1 mode on
vlan datase
vlan 10
vlan 20
int range f0/3 -10
switchport access vlan 10
int range f0/11 -15
interface FastEthernet0/0
switchport mode trunk
switchport access vlan 20

测试结果:

 

2012-08-16_122631

 

2012-08-16_122735

二,VRRP

1,基本概述:

  虚拟路由器冗余协议(VRRP)是一种选择协议,它可以把一个虚拟路由器的责任动态分配到局域网上的 VRRP 路由器中的一台。控制虚拟路由器 IP 地址的 VRRP 路由器称为主路由器,它负责转发数据包到这些虚拟 IP 地址。一旦主路由器不可用,这种选择过程就提供了动态的故障转移机制,这就允许虚拟路由器的 IP 地址可以作为终端主机的默认第一跳路由器。使用 VRRP 的好处是有更高的默认路径的可用性而无需在每个终端主机上配置动态路由或路由发现协议。 VRRP 包封装在 IP 包中发送。

  VRRP(Virtual Router Redundancy Protocol,虚拟路由冗余协议)是一种容错协议。通常,一个网络内的所有主机都设置一条缺省路由,这样,主机发出的目的地址不在本网段的报文将被通过缺省路由发往路由器RouterA,从而实现了主机与外部网络的通信。当路由器RouterA 坏掉时,本网段内所有以RouterA 为缺省路由下一跳的主机将断掉与外部的通信。VRRP 就是为解决上述问题而提出的,它为具有多播或广播能力的局域网(如:以太网)设计。VRRP 将局域网的一组路由器(包括一个Master 即活动路由器和若干个Backup 即备份路由器)组织成一个虚拟路由器,称之为一个备份组。

2,互相区别 VRRP协议的工作机理与CISCO公司的HSRP(Hot Standby Routing Protocol)有许多相似之处。但二者主要的区别是在CISCO的HSRP中,需要单独配置一个IP地址作为虚拟路由器对外体现的地址,这个地址不能是组中任何一个成员的接口地址。

使用VRRP协议,不用改造目前的网络结构,最大限度保护了当前投资,只需最少的管理费用,却大大提升了网络性能,具有重大的应用价值。

3,工作原理

vrrp只定义了一种报文——vrrp报文,这是一种组播报文,由主三层交换机定时发出来通告他的存在。使用这些报文可以检测虚拟三层交换机各种参数,还可以用于主三层交换机的选举。

VRRP中定义了三种状态模型,初始状态Initialize,活动状态Master和备份状态Backup,其中只有活动状态的交换机可以为到虚拟IP地址的的转发请求提供服务。

vrrp报文是封装在IP报文上的,支持各种上层协议,同时VRRP还支持将真实接口IP地址设置为虚拟IP地址。

那么如何从备份组的多台交换机中选举Master?这项工作由我们在备份组内每台交换机上配置的相同IP地址的虚拟交换机完成。

虚拟交换机根据配置的优先级的大小选择主交换机,优先级最大的作为主交换机,状态为Master,若优先级相同(如果交换机没有配置优先级,就采用默认值100),则比较接口的主IP地址,主IP地址大的就成为主交换机,由它提供实际的路由服务。其他交换机作为备份交换机,随时监测主交换机的状态。当主交换机正常工作时,它会每隔一段时间发送一个VRRP组播报文,以通知组内的备份交换机,主交换机处于正常工作状态。如果组内的备份交换机长时间没有接收到来自主交换机的VRRP组播报文,则将自己状态转换为Master。当组内有多台备份交换机,将有可能产生多个主交换机。这时每一个主交换机就会比较VRRP报文中的优先级和自己本地的优先级,如果本地的优先级小于VRRP中的优先级,则将自己的状态转换为Backup,否则保持自己的状态不变。通过这样一个过程,就会将优先级最大的交换机选成新的主交换机,完成VRRP的备份功能

4,企业案例:

  案例拓扑

h3c

 

R1:

interface Ethernet1.10                                 //进入子接口
    vlan-type dot1q vid 10                            //为接口打标签
    ip address 192.168.10.1 255.255.255.0   //配置接口IP
    vrrp vrid 10 virtual-ip 192.168.10.254      // 添加虚拟IP
    vrrp vrid 10 priority 120                          //更改优先级
  !                                      
  interface Ethernet1.20
    vlan-type dot1q vid 20               
    ip address 192.168.20.1 255.255.255.0
    vrrp vrid 20 virtual-ip 192.168.20.254

R2:

interface Ethernet1.10
    vlan-type dot1q vid 10
    ip address 192.168.10.2 255.255.255.0
    vrrp vrid 10 virtual-ip 192.168.10.254
  !                                      
  interface Ethernet1.20
    vlan-type dot1q vid 20               
    ip address 192.168.20.2 255.255.255.0
    vrrp vrid 20 virtual-ip 192.168.20.254
    vrrp vrid 20 priority 120

sw1:

vlan 10     //创建vlan10                              
port e0/5 to e0/10                        //将5-10接口加入vlan10                                   
vlan 20

port e0/15 to e0/20

interface Ethernet0/1                    
port link-type trunk                    //将接口配置成为trunk模式                  
port trunk permit vlan all             //允许所有vlan通过

interface Ethernet0/24                   
port link-type trunk                    
port trunk permit vlan all

 

sw2:

interface Ethernet0/1                    
port link-type trunk                    
port trunk permit vlan all 

vlan 10                                   
port e0/5 to e0/10                                    
vlan 20

port e0/15 to e0/20

 

 

 

 

interface Ethernet0/24                   
port link-type trunk                    
port trunk permit vlan all 

测试结果:

 2012-08-16_152842

2012-08-16_152911

2012-08-16_152932

查看优先级,端口状态

 

 

 

 

 

 

2012-08-16_153036

2012-08-16_153305

 

2012-08-16_154746