最近打算在安装win10的系统下安装多个版本的CAD,之前安装了08版本,打算再安装2013版本。之前,使用的win7,安装08和2014两个版本共存没有问题,拿同样的软件安装到win10却提示失败,结果一番测试后,找到了原因,下面把解决方法和大家分享一下,以免遇到我同样的问题而浪费大量的时间去寻找解决方法。具体错误和解决方法请看下面: 安装13或者14遇到的报错如下: ![](https://s4.51cto.com/images/blog/201809/27/a794b7c9aa2896917ffd892ecf08e854.png?x-oss-process=image/watermark,size_16,text_QDUxQ1RP5Y2a5a6i,color_FFFFFF,t_100,g_se,x_10,y_10,shadow_90,type_ZmFuZ3poZW5naGVpdGk=) 点击安装日志文件查看了一下,日志里意思是说无法安装.Netframwork 4.0 Language Package。于是开始针对.Netframwork各种折腾,先是在启用和关闭特性那里关闭启用,但是安装的时候还是遇到一样的问题: ![](https://s4.51cto.com/images/blog/201809/27/e2d2030ad8f9e14b1202058813b91663.png?x-oss-process=image/watermark,size_16,text_QDUxQ1RP5Y2a5a6i,color_FFFFFF,t_100,g_se,x_10,y_10,shadow_90,type_ZmFuZ3poZW5naGVpdGk=) 于是又自寻到微软官网下载了Netframwork 4.0 Runtime和Netframwork 4.0 Language Package,下载好后安装提示系统已经自带该Feature,于是又开始怀疑是我系统英文的原因导致的,又开始下载系统中文语言包,最后还是以失败告终! 最后想想,系统既然已经有了比4.0版本高的Netframwork,那么向下兼容肯定是没有问题的,如果安装的时候能够绕过Netframwork 4.0 Language Package的安装即可。于是开始在安装程序里找配置,最后终于功夫不负有心,关键人物上场: 找到解压的文件夹中的setup.ini文件,双击打开。 ![](https://s4.51cto.com/images/blog/201809/27/e6948ee39301986a6a37be6a0da9fab9.png?x-oss-process=image/watermark,size_16,text_QDUxQ1RP5Y2a5a6i,color_FFFFFF,t_100,g_se,x_10,y_10,shadow_90,type_ZmFuZ3poZW5naGVpdGk=) 打开后找到一段代码:_DOTNET35SP1;DOTNET4;DOTNET4LANG;DOTNET4KB2468871;将该段代码删除后保存。 ![](https://s4.51cto.com/images/blog/201809/27/1794cdb865e1ac35f707247be1b1a963.png?x-oss-process=image/watermark,size_16,text_QDUxQ1RP5Y2a5a6i,color_FFFFFF,t_100,g_se,x_10,y_10,shadow_90,type_ZmFuZ3poZW5naGVpdGk=) 重新点击Setup.exe进行安装。 再次安装的时候,如果出现提示安装.NET Framework 3.5的话,可以选择跳过,然后继续安装。 ![](https://s4.51cto.com/images/blog/201809/27/1ff69b48894e58f1438af13d6c44d282.png?x-oss-process=image/watermark,size_16,text_QDUxQ1RP5Y2a5a6i,color_FFFFFF,t_100,g_se,x_10,y_10,shadow_90,type_ZmFuZ3poZW5naGVpdGk=) 最后没有特殊情况的话就可以顺利安装成功!